summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-12-08 01:20:35 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-12-08 01:20:35 +0000
commit3ef11e4a0ca5c39e4b18ee78451c6a6761f3f786 (patch)
treed1e743e9837944e9a2bab0fb4cab06be31b18988 /sys-boot
parentremove courier block for 68750 (Manifest recommit) (diff)
downloadgentoo-2-3ef11e4a0ca5c39e4b18ee78451c6a6761f3f786.tar.gz
gentoo-2-3ef11e4a0ca5c39e4b18ee78451c6a6761f3f786.tar.bz2
gentoo-2-3ef11e4a0ca5c39e4b18ee78451c6a6761f3f786.zip
Bug #70111, fix tc-getCC invocation.
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog6
-rw-r--r--sys-boot/grub/grub-0.95.20040823.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 1c198e856611..ac38ddef391c 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.28 2004/12/01 05:55:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.29 2004/12/08 01:20:35 robbat2 Exp $
+
+ 07 Dec 2004; Robin H. Johnson <robbat2@gentoo.org>
+ grub-0.95.20040823.ebuild:
+ Bug #70111, fix tc-getCC invocation.
30 Nov 2004; Michael Sterrett <mr_bones_@gentoo.org>
grub-0.95.20040823.ebuild:
diff --git a/sys-boot/grub/grub-0.95.20040823.ebuild b/sys-boot/grub/grub-0.95.20040823.ebuild
index 92f662aae334..243c38385d94 100644
--- a/sys-boot/grub/grub-0.95.20040823.ebuild
+++ b/sys-boot/grub/grub-0.95.20040823.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.95.20040823.ebuild,v 1.7 2004/12/01 05:55:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.95.20040823.ebuild,v 1.8 2004/12/08 01:20:35 robbat2 Exp $
inherit mount-boot eutils flag-o-matic gcc gnuconfig toolchain-funcs
@@ -53,8 +53,8 @@ src_compile() {
[ `gcc-major-version` -eq 3 ] && append-flags -minline-all-stringops
use static && append-ldflags -static
- has_pie && CC="${tc-getCC} `test_flag -fno-pic` `test_flag -nopie`"
- has_ssp && CC="${tc-getCC} `test_flag -fno-stack-protector`"
+ has_pie && CC="$(tc-getCC) `test_flag -fno-pic` `test_flag -nopie`"
+ has_ssp && CC="$(tc-getCC) `test_flag -fno-stack-protector`"
autoconf || die "autoconf failed"
aclocal || die "aclocal failed"