summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ostrow <dostrow@gentoo.org>2004-05-24 17:54:53 +0000
committerDaniel Ostrow <dostrow@gentoo.org>2004-05-24 17:54:53 +0000
commit9655f1d61d7fbc2a4f31c3f133d3af0afae067a8 (patch)
treeabeadeca771151a74140090bf6be52a12889b1da /sys-boot/yaboot
parentI take it back (Manifest recommit) (diff)
downloadgentoo-2-9655f1d61d7fbc2a4f31c3f133d3af0afae067a8.tar.gz
gentoo-2-9655f1d61d7fbc2a4f31c3f133d3af0afae067a8.tar.bz2
gentoo-2-9655f1d61d7fbc2a4f31c3f133d3af0afae067a8.zip
Added case statement
Diffstat (limited to 'sys-boot/yaboot')
-rw-r--r--sys-boot/yaboot/ChangeLog7
-rw-r--r--sys-boot/yaboot/yaboot-1.3.12-r1.ebuild14
2 files changed, 18 insertions, 3 deletions
diff --git a/sys-boot/yaboot/ChangeLog b/sys-boot/yaboot/ChangeLog
index 90ebcfc538b4..40111fde316b 100644
--- a/sys-boot/yaboot/ChangeLog
+++ b/sys-boot/yaboot/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for sys-boot/yaboot
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.7 2004/05/23 18:03:57 dostrow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.8 2004/05/24 17:54:53 dostrow Exp $
*yaboot-1.3.12-r1 (23 May 2004)
- 23 May 2004; Daniel Ostrow <dostrow@gentoo.org> yaboot-1.3.12-r1.ebuild,
+ 24 May 2004; Daniel Ostrow <dostrow@gentoo.org> yaboot-1.3.12-r1.ebuild:
+ Added case statement to check running kernel at install time.
+
+ 23 May 2004; Daniel Ostrow <dostrow@gentoo.org> yaboot-1.3.12-r1.ebuild:
files/yaboot-3.4.patch
files/yaboot-k2sata-ofpath.patch
Fixes compile issues with gcc-3.4 and adds support for secondary drives
diff --git a/sys-boot/yaboot/yaboot-1.3.12-r1.ebuild b/sys-boot/yaboot/yaboot-1.3.12-r1.ebuild
index ed7be4e900a9..8a3149a1b9e6 100644
--- a/sys-boot/yaboot/yaboot-1.3.12-r1.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.12-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.12-r1.ebuild,v 1.2 2004/05/23 18:09:41 dostrow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.12-r1.ebuild,v 1.3 2004/05/24 17:54:53 dostrow Exp $
inherit eutils
@@ -21,6 +21,18 @@ PROVIDE="virtual/bootloader"
MAKEOPTS='PREFIX=/usr MANDIR=share/man'
+pkg_setup() {
+ case "$(uname -r)" in
+ 2.5.*|2.6.0*|2.6.1|2.6.1-*|2.6.2|2.6.2-*)
+ eerror "You are running Linux kernel `uname -r` which is not supported"
+ eerror "Please note if you are running a 2.6 kernel the verison"
+ eerror "of ofpath included in this revision of yaboot requires"
+ eerror "that you run a kernel >= 2.6.3."
+ die
+ ;;
+ esac
+}
+
src_compile() {
export -n CFLAGS
export -n CXXFLAGS