summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-03-11 17:59:06 +0000
committerJeroen Roovers <jer@gentoo.org>2009-03-11 17:59:06 +0000
commit7b5ecc9bdbf4f7645f662a63619ea1d20dbb5af9 (patch)
tree8f39ef75a9b6066cafdcef338a5bd758fc0a7848 /sys-boot/unetbootin
parentDepend on virtual/postgresql-base, not virtual/postgresql-server. Closes bug ... (diff)
downloadgentoo-2-7b5ecc9bdbf4f7645f662a63619ea1d20dbb5af9.tar.gz
gentoo-2-7b5ecc9bdbf4f7645f662a63619ea1d20dbb5af9.tar.bz2
gentoo-2-7b5ecc9bdbf4f7645f662a63619ea1d20dbb5af9.zip
Version bump.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'sys-boot/unetbootin')
-rw-r--r--sys-boot/unetbootin/ChangeLog9
-rw-r--r--sys-boot/unetbootin/files/unetbootin-312-gentoo.patch11
-rw-r--r--sys-boot/unetbootin/unetbootin-312.ebuild7
-rw-r--r--sys-boot/unetbootin/unetbootin-319.ebuild40
4 files changed, 65 insertions, 2 deletions
diff --git a/sys-boot/unetbootin/ChangeLog b/sys-boot/unetbootin/ChangeLog
index cb4d94cb5198..58a240055cea 100644
--- a/sys-boot/unetbootin/ChangeLog
+++ b/sys-boot/unetbootin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/unetbootin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.5 2009/02/06 06:09:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.6 2009/03/11 17:59:05 jer Exp $
+
+*unetbootin-319 (11 Mar 2009)
+
+ 11 Mar 2009; Jeroen Roovers <jer@gentoo.org>
+ +files/unetbootin-312-gentoo.patch, unetbootin-312.ebuild,
+ +unetbootin-319.ebuild:
+ Version bump.
*unetbootin-312 (06 Feb 2009)
diff --git a/sys-boot/unetbootin/files/unetbootin-312-gentoo.patch b/sys-boot/unetbootin/files/unetbootin-312-gentoo.patch
new file mode 100644
index 000000000000..737b57ae2b05
--- /dev/null
+++ b/sys-boot/unetbootin/files/unetbootin-312-gentoo.patch
@@ -0,0 +1,11 @@
+--- unetbootin.cpp.orig 2009-02-03 23:02:03.000000000 +0100
++++ unetbootin.cpp 2009-02-14 18:58:44.000000000 +0100
+@@ -2610,7 +2610,7 @@
+ QFile usbmbrF(rawtargetDev);
+ QFile mbrbinF(":/mbr.bin");
+ #ifdef NOSTATIC
+- mbrbinF.setFileName("/usr/lib/syslinux/mbr.bin");
++ mbrbinF.setFileName(QFile::exists("/usr/share/syslinux/mbr.bin") ? "/usr/share/syslinux/mbr.bin" : "/usr/lib/syslinux/mbr.bin");
+ #endif
+ usbmbrF.open(QIODevice::WriteOnly);
+ mbrbinF.open(QIODevice::ReadOnly);
diff --git a/sys-boot/unetbootin/unetbootin-312.ebuild b/sys-boot/unetbootin/unetbootin-312.ebuild
index 58d143a28166..868facdc7bdf 100644
--- a/sys-boot/unetbootin/unetbootin-312.ebuild
+++ b/sys-boot/unetbootin/unetbootin-312.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-312.ebuild,v 1.1 2009/02/06 06:09:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-312.ebuild,v 1.2 2009/03/11 17:59:05 jer Exp $
inherit qt4
@@ -22,6 +22,11 @@ RDEPEND="${DEPEND}
sys-boot/syslinux
app-arch/p7zip"
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
src_compile() {
lupdate unetbootin.pro
lrelease unetbootin.pro
diff --git a/sys-boot/unetbootin/unetbootin-319.ebuild b/sys-boot/unetbootin/unetbootin-319.ebuild
new file mode 100644
index 000000000000..af4e7f75b361
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-319.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-319.ebuild,v 1.1 2009/03/11 17:59:05 jer Exp $
+
+inherit qt4
+
+DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
+distributions."
+HOMEPAGE="http://unetbootin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/unetbootin/${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+DEPEND="x11-libs/qt-gui"
+RDEPEND="${DEPEND}
+ sys-fs/mtools
+ sys-boot/syslinux
+ app-arch/p7zip"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-312-gentoo.patch
+}
+
+src_compile() {
+ lupdate unetbootin.pro
+ lrelease unetbootin.pro
+ eqmake4 unetbootin.pro
+ emake || die "make failed"
+}
+
+src_install() {
+ dodoc README.TXT
+ dobin unetbootin || die "dobin failed"
+}