summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2004-11-07 17:24:06 +0000
committerTony Vroon <chainsaw@gentoo.org>2004-11-07 17:24:06 +0000
commitf8f126eabf4d83dab5833c84f4ad08fd3bdbbe99 (patch)
tree4d85bcbb4346c2715e99bda1862990d4e8e2def5 /sys-boot/lilo
parentFixed broken Manifest. (Manifest recommit) (diff)
downloadgentoo-2-f8f126eabf4d83dab5833c84f4ad08fd3bdbbe99.tar.gz
gentoo-2-f8f126eabf4d83dab5833c84f4ad08fd3bdbbe99.tar.bz2
gentoo-2-f8f126eabf4d83dab5833c84f4ad08fd3bdbbe99.zip
Dolilo code cleanup; added memtest86+ and windows OS detection.
Diffstat (limited to 'sys-boot/lilo')
-rw-r--r--sys-boot/lilo/ChangeLog7
-rw-r--r--sys-boot/lilo/Manifest4
-rw-r--r--sys-boot/lilo/files/digest-lilo-22.6-r12
-rw-r--r--sys-boot/lilo/lilo-22.6-r1.ebuild191
4 files changed, 202 insertions, 2 deletions
diff --git a/sys-boot/lilo/ChangeLog b/sys-boot/lilo/ChangeLog
index e25e5c328c6d..083876571f76 100644
--- a/sys-boot/lilo/ChangeLog
+++ b/sys-boot/lilo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/lilo
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.26 2004/11/05 11:11:11 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.27 2004/11/07 17:24:06 chainsaw Exp $
+
+*lilo-22.6-r1 (07 Nov 2004)
+
+ 07 Nov 2004; Tony Vroon <chainsaw@gentoo.org> +lilo-22.6-r1.ebuild:
+ Dolilo code cleanup. Added memtest86+ and windows OS detection.
05 Nov 2004; Tony Vroon <chainsaw@gentoo.org> -lilo-22.5.9-r2.ebuild,
lilo-22.6.ebuild:
diff --git a/sys-boot/lilo/Manifest b/sys-boot/lilo/Manifest
index ac660adfb41d..496223137e4c 100644
--- a/sys-boot/lilo/Manifest
+++ b/sys-boot/lilo/Manifest
@@ -1,6 +1,8 @@
MD5 604d21f27d3d62c0687b8c9229d0e489 lilo-22.6.ebuild 4759
-MD5 26875dbb7fab6998f65939be7dca0d2a ChangeLog 2010
+MD5 5ecb19ae3e3660ec7809db2354cdde35 lilo-22.6-r1.ebuild 4666
+MD5 90bb876a12dd7abad1388fe5f5096dca ChangeLog 2176
MD5 eeee4743c4e463eeed3a7a4c15380e0d metadata.xml 254
+MD5 45fc85b5af273bddd66b0056811624ba files/digest-lilo-22.6-r1 122
MD5 42faa8a84fae547fe181da0ad7b67b04 files/lilo-22.6-devmapper_gentoo.patch 11826
MD5 a12e27d3f9076bb13d357533303f77ff files/digest-lilo-22.6 122
MD5 2419c22323e1cfdbbc1ca149cb05e74d files/lilo-22.6-create-install-dirs.patch 970
diff --git a/sys-boot/lilo/files/digest-lilo-22.6-r1 b/sys-boot/lilo/files/digest-lilo-22.6-r1
new file mode 100644
index 000000000000..fe4552e6d35a
--- /dev/null
+++ b/sys-boot/lilo/files/digest-lilo-22.6-r1
@@ -0,0 +1,2 @@
+MD5 ae9665536347d9cc92e0ebd473a9ac6b lilo-22.6.tar.gz 419138
+MD5 88acd6cac12da7e6da02615ba1ca6ddf dolilo-0.3.tar.bz2 3554
diff --git a/sys-boot/lilo/lilo-22.6-r1.ebuild b/sys-boot/lilo/lilo-22.6-r1.ebuild
new file mode 100644
index 000000000000..133973b3394d
--- /dev/null
+++ b/sys-boot/lilo/lilo-22.6-r1.ebuild
@@ -0,0 +1,191 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.6-r1.ebuild,v 1.1 2004/11/07 17:24:06 chainsaw Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DOLILO_V="0.3"
+IUSE="devmap static"
+
+DESCRIPTION="Standard Linux boot loader"
+HOMEPAGE="http://lilo.go.dyndns.org/pub/linux/lilo/"
+DOLILO_TAR="dolilo-${DOLILO_V}.tar.bz2"
+SRC_URI="http://home.san.rr.com/johninsd/pub/linux/lilo/${P}.tar.gz
+ ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/${P}.tar.gz
+ ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/obsolete/${P}.tar.gz
+ mirror://gentoo/${DOLILO_TAR}"
+
+SLOT="0"
+LICENSE="BSD GPL-2"
+KEYWORDS="-* ~x86"
+
+RDEPEND=">=sys-apps/sed-4
+ devmap? ( >=sys-libs/device-mapper-1.00.08 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/bin86-0.15.5"
+
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+ einfo
+ einfo "If you want to use lilo with device mapper, please enable the"
+ einfo "\"devmap\" USE flag."
+ einfo
+
+ unpack ${P}.tar.gz
+
+ # Do not try and build the dos crap.
+ sed -i -e 's|^all:.*$|all: lilo|' ${S}/Makefile
+
+ # The bootlogo patch from SuSE linux, which was originally in
+ # here, has been dropped because it's no longer compatible
+ # with lilo since the 22.5.x series.
+ # Quequero has done a good attempt to port the patch in bug
+ # #19397, but unfortunately that breaks the timeout at boot.
+ # If you can overcome these problems, a patch is very welcome.
+
+ if use devmap; then
+ # devmapper-patch (boot on evms/lvm2)
+ cd ${S}; epatch ${FILESDIR}/${P}-devmapper_gentoo.patch
+ fi
+
+ cd ${S}
+ unpack ${DOLILO_TAR}
+
+ # Fix creating install dirs, bug #39405
+ epatch ${FILESDIR}/${P}-create-install-dirs.patch
+ # Correctly document commandline options -v and -V, bug #43554
+ epatch ${FILESDIR}/${P}-correct-usage-info.patch
+ # Get the manpage path right
+ sed -i -e s,usr/man,usr/share/man,g ${S}/Makefile
+}
+
+src_compile() {
+ # hardened automatic PIC plus PIE building should be suppressed
+ # because of assembler instructions that cannot be compiled PIC
+ HARDENED_CFLAGS="`test_flag -fno-pic` `test_flag -nopie`"
+
+ # we explicitly prevent the custom CFLAGS for stability reasons
+ if use static; then
+ emake CC="$(tc-getCC) ${HARDENED_CFLAGS}" lilo-static || die
+ mv lilo-static lilo || die
+ else
+ emake CC="$(tc-getCC) ${HARDENED_CFLAGS}" lilo || die
+ fi
+}
+
+src_install() {
+ keepdir /boot
+ make ROOT=${D} install || die
+
+ into /
+ dosbin ${S}/dolilo/dolilo
+
+ into /usr
+ dosbin keytab-lilo.pl
+
+ insinto /etc
+ newins ${FILESDIR}/lilo.conf lilo.conf.example
+
+ insinto /etc/conf.d
+ newins ${S}/dolilo/dolilo.conf.d dolilo.example
+
+ doman manPages/*.[5-8]
+ dodoc CHANGES COPYING INCOMPAT README*
+ docinto samples ; dodoc sample/*
+}
+
+# Check whether LILO is installed
+# This function is from /usr/sbin/mkboot from debianutils, with copyright:
+#
+# Debian GNU/Linux
+# Copyright 1996-1997 Guy Maor <maor@debian.org>
+#
+# Modified for Gentoo for use with the lilo ebuild by:
+# Martin Schlemmer <azarah@gentoo.org> (16 Mar 2003)
+#
+lilocheck () {
+ local bootpart=
+ local rootpart="$(rdev 2> /dev/null | cut -d ' ' -f 1 2> /dev/null)"
+
+ echo
+ einfon "Checking for LILO ..."
+
+ if [ "$(whoami)" != "root" ]
+ then
+ echo; echo
+ eerror "Only root can check for LILO!"
+ return 1
+ fi
+
+ if [ -z "${rootpart}" ]
+ then
+ echo; echo
+ eerror "Could not determine root partition!"
+ return 1
+ fi
+
+ if [ ! -f /etc/lilo.conf -o ! -x /sbin/lilo ]
+ then
+ echo " No"
+ return 1
+ fi
+
+ bootpart="$(sed -n "s:^boot[ ]*=[ ]*\(.*\)[ ]*:\1:p" /etc/lilo.conf)"
+
+ if [ -z "${bootpart}" ]
+ then
+ # lilo defaults to current root when 'boot=' is not present
+ bootpart="${rootpart}"
+ fi
+
+ if ! dd if=${bootpart} ibs=16 count=1 2>&- | grep -q 'LILO'
+ then
+ echo; echo
+ ewarn "Yes, but I couldn't find a LILO signature on ${bootpart}"
+ ewarn "Check your /etc/lilo.conf, or run /sbin/lilo by hand."
+ return 1
+ fi
+
+ echo " Yes, on ${bootpart}"
+
+ return 0
+}
+
+
+pkg_postinst() {
+ if [ ! -e ${ROOT}/boot/boot.b -a ! -L ${ROOT}/boot/boot.b ]
+ then
+ [ -f "${ROOT}/boot/boot-menu.b" ] && \
+ ln -snf boot-menu.b ${ROOT}/boot/boot.b
+ fi
+
+ if [ "${ROOT}" = "/" ]
+ then
+ if lilocheck
+ then
+ einfo "Running DOLILO to complete the install ..."
+ # do not redirect to /dev/null because it may display some input
+ # prompt
+ /sbin/dolilo
+ if [ "$?" -ne 0 ]
+ then
+ echo
+ ewarn "Running /sbin/dolilo failed! Please check what the problem is"
+ ewarn "before your next reboot."
+
+ ebeep 5
+ epause 5
+ fi
+ fi
+ echo
+ fi
+
+ echo
+ einfo "Issue 'dolilo' instead of 'lilo' to have a friendly wrapper that"
+ einfo "handles mounting and unmounting /boot for you. It can do more then"
+ einfo "that when asked, edit /etc/conf.d/dolilo to harness it's full potential."
+ ebeep 5
+ epause 3
+ echo
+}