summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-11-26 00:45:38 +0000
committerMike Gilbert <floppym@gentoo.org>2014-11-26 00:45:38 +0000
commit700171ab795946651375bf1281392ba435c8063f (patch)
tree18b7ceff6ab28e5b808f41068871fdbeb39297b3 /sys-boot/efibootmgr
parentNew package, dependency of sys-boot/efibootmgr. Ebuild by Yannick Schaeffer, ... (diff)
downloadgentoo-2-700171ab795946651375bf1281392ba435c8063f.tar.gz
gentoo-2-700171ab795946651375bf1281392ba435c8063f.tar.bz2
gentoo-2-700171ab795946651375bf1281392ba435c8063f.zip
Version bump, bug 510070. Thanks to Yannick Schaeffer.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-boot/efibootmgr')
-rw-r--r--sys-boot/efibootmgr/ChangeLog8
-rw-r--r--sys-boot/efibootmgr/efibootmgr-0.11.0.ebuild36
-rw-r--r--sys-boot/efibootmgr/metadata.xml28
3 files changed, 59 insertions, 13 deletions
diff --git a/sys-boot/efibootmgr/ChangeLog b/sys-boot/efibootmgr/ChangeLog
index d0c217521c9d..01079bdd451b 100644
--- a/sys-boot/efibootmgr/ChangeLog
+++ b/sys-boot/efibootmgr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/efibootmgr
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/ChangeLog,v 1.30 2014/10/08 21:00:20 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/ChangeLog,v 1.31 2014/11/26 00:45:38 floppym Exp $
+
+*efibootmgr-0.11.0 (26 Nov 2014)
+
+ 26 Nov 2014; Mike Gilbert <floppym@gentoo.org> +efibootmgr-0.11.0.ebuild,
+ metadata.xml:
+ Version bump, bug 510070. Thanks to Yannick Schaeffer.
08 Oct 2014; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Change maintainers as discussed with them
diff --git a/sys-boot/efibootmgr/efibootmgr-0.11.0.ebuild b/sys-boot/efibootmgr/efibootmgr-0.11.0.ebuild
new file mode 100644
index 000000000000..ce4a1194664d
--- /dev/null
+++ b/sys-boot/efibootmgr/efibootmgr-0.11.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/efibootmgr-0.11.0.ebuild,v 1.1 2014/11/26 00:45:38 floppym Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="User-space application to modify the EFI boot manager"
+HOMEPAGE="https://github.com/vathpela/efibootmgr"
+SRC_URI="https://github.com/vathpela/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/pciutils
+ sys-libs/efivar"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e s/-Werror// Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+ export EXTRA_CFLAGS=${CFLAGS}
+}
+
+src_install() {
+ # build system uses perl, so just do it ourselves
+ dosbin src/efibootmgr/efibootmgr
+ doman src/man/man8/efibootmgr.8
+ dodoc AUTHORS README doc/ChangeLog doc/TODO
+}
diff --git a/sys-boot/efibootmgr/metadata.xml b/sys-boot/efibootmgr/metadata.xml
index c96846843c6f..1f9a68be5c54 100644
--- a/sys-boot/efibootmgr/metadata.xml
+++ b/sys-boot/efibootmgr/metadata.xml
@@ -1,16 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>proxy-maintainers</herd>
-<maintainer>
- <email>yannick.schaeffer@epfl.ch</email>
- <name>Yannick Schaeffer</name>
- <description>Mantainer. Assign bugs to him</description>
-</maintainer>
- <longdescription>
- This is efibootmgr, a Linux user-space application to modify the Intel
- Extensible Firmware Interface (EFI) Boot Manager. This application
- can create and destroy boot entries, change the boot order, change
- the next running boot option, and more.
-</longdescription>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>yannick.schaeffer@epfl.ch</email>
+ <name>Yannick Schaeffer</name>
+ <description>Mantainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>floppym@gentoo.org</email>
+ <name>Mike Gilbert</name>
+ </maintainer>
+ <longdescription>
+ This is efibootmgr, a Linux user-space application to modify the Intel
+ Extensible Firmware Interface (EFI) Boot Manager. This application
+ can create and destroy boot entries, change the boot order, change
+ the next running boot option, and more.
+ </longdescription>
</pkgmetadata>