summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Woods <wwoods@gentoo.org>2004-05-18 18:28:33 +0000
committerWill Woods <wwoods@gentoo.org>2004-05-18 18:28:33 +0000
commit8d934ea14bca61b830f1ce7c00e59a63e40ca00a (patch)
tree5ea4a87ee53583014230db5ea2fe0f43decc9a24 /sys-boot/aboot
parentMask fetch restricted helixplayer-bin (diff)
downloadgentoo-2-8d934ea14bca61b830f1ce7c00e59a63e40ca00a.tar.gz
gentoo-2-8d934ea14bca61b830f1ce7c00e59a63e40ca00a.tar.bz2
gentoo-2-8d934ea14bca61b830f1ce7c00e59a63e40ca00a.zip
New prerelease version ready for testing
Diffstat (limited to 'sys-boot/aboot')
-rw-r--r--sys-boot/aboot/ChangeLog10
-rw-r--r--sys-boot/aboot/Manifest6
-rw-r--r--sys-boot/aboot/aboot-1.0_pre20040408.ebuild62
-rw-r--r--sys-boot/aboot/files/digest-aboot-1.0_pre200404081
4 files changed, 75 insertions, 4 deletions
diff --git a/sys-boot/aboot/ChangeLog b/sys-boot/aboot/ChangeLog
index fd1cbf4ef887..338c31638f6b 100644
--- a/sys-boot/aboot/ChangeLog
+++ b/sys-boot/aboot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/aboot
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/aboot/ChangeLog,v 1.2 2003/12/09 08:55:58 seemant Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/aboot/ChangeLog,v 1.3 2004/05/18 18:28:33 wwoods Exp $
+
+*aboot-1.0_pre20040408 (18 May 2004)
+
+ 18 May 2004; Will Woods <wwoods@gentoo.org> aboot-1.0_pre20040408.ebuild:
+ New aboot prerelease version considered ready for testing. New features,
+ compile fixes, bug fixes.
*aboot-0.9-r1 (08 Dec 2003)
diff --git a/sys-boot/aboot/Manifest b/sys-boot/aboot/Manifest
index 84bf15f4d795..eea409e8bde7 100644
--- a/sys-boot/aboot/Manifest
+++ b/sys-boot/aboot/Manifest
@@ -1,5 +1,7 @@
-MD5 254f0c6b0c0862df2ecd486daab0bbf9 files/aboot.conf 295
-MD5 33aacae300189ee99e0df0a268dc4e4a files/digest-aboot-0.9-r1 65
MD5 2e036fb0c375b17c9680ae6675905471 ChangeLog 695
MD5 b7794d0c8778d1a4a6ba2dd087f5c610 aboot-0.9-r1.ebuild 1902
MD5 0ed40e134501a252bb21c5c5808d8028 metadata.xml 158
+MD5 b09305fe7b389b51dd110fff06426b79 aboot-1.0_pre20040408.ebuild 1866
+MD5 254f0c6b0c0862df2ecd486daab0bbf9 files/aboot.conf 295
+MD5 33aacae300189ee99e0df0a268dc4e4a files/digest-aboot-0.9-r1 65
+MD5 746d744469877288661af19f5f0f5d12 files/digest-aboot-1.0_pre20040408 74
diff --git a/sys-boot/aboot/aboot-1.0_pre20040408.ebuild b/sys-boot/aboot/aboot-1.0_pre20040408.ebuild
new file mode 100644
index 000000000000..18eb33d30126
--- /dev/null
+++ b/sys-boot/aboot/aboot-1.0_pre20040408.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/aboot/aboot-1.0_pre20040408.ebuild,v 1.1 2004/05/18 18:28:33 wwoods Exp $
+
+DESCRIPTION="Alpha Linux boot loader for SRM"
+HOMEPAGE="http://aboot.sourceforge.net/"
+SRC_URI="http://aboot.sourceforge.net/tarballs/aboot-1.0_pre20040408.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~alpha"
+
+DEPEND="virtual/glibc"
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s:/usr/man:/usr/share/man:" Makefile || die
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dodir /boot /sbin /usr/share/man/man5
+ make \
+ root=${D} \
+ bindir=${D}/sbin \
+ bootdir=${D}/boot \
+ mandir=${D}/usr/share/man \
+ install
+
+ dodoc ChangeLog INSTALL README TODO aboot.conf
+
+ insinto /etc
+ newins ${FILESDIR}/aboot.conf aboot.conf.example
+}
+
+pkg_postinst() {
+ einfo "To make aboot install a new bootloader on your harddisk follow"
+ einfo "these steps:"
+ einfo ""
+ einfo " - edit the file /etc/aboot.conf"
+ einfo " - cd /boot"
+ einfo " - swriteboot -c2 /dev/sda bootlx"
+ einfo " This will install a new bootsector on /dev/sda and aboot will"
+ einfo " use the second partition on this device to lookup kernel and "
+ einfo " initrd (as described in the aboot.conf file)"
+ einfo ""
+ einfo "IMPORTANT :"
+ einfo ""
+ einfo "The partition table of your boot device has to contain "
+ einfo "a BSD-DISKLABEL and the first 12 megabytes of your boot device"
+ einfo "must not be part of a partition as aboot will write its bootloader"
+ einfo "in there and not as with most x86 bootloaders into the "
+ einfo "master boot sector. If your partition table does not reflect this"
+ einfo "you are going to destroy your installation !"
+ einfo "Also note that aboot currently only supports ext2/3 partitions"
+ einfo "to boot from."
+}
diff --git a/sys-boot/aboot/files/digest-aboot-1.0_pre20040408 b/sys-boot/aboot/files/digest-aboot-1.0_pre20040408
new file mode 100644
index 000000000000..45491432776c
--- /dev/null
+++ b/sys-boot/aboot/files/digest-aboot-1.0_pre20040408
@@ -0,0 +1 @@
+MD5 ac1214102d8304f326655e3e36d89847 aboot-1.0_pre20040408.tar.bz2 115062