summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-01-29 05:45:06 +0000
committerJeroen Roovers <jer@gentoo.org>2011-01-29 05:45:06 +0000
commit91c33f6085b5cf8fcd1467eca583aa04d499c99d (patch)
tree3036d6668168dd5272aff9fdb8a6404aed69df44 /sys-block
parentVersion bump. (diff)
downloadgentoo-2-91c33f6085b5cf8fcd1467eca583aa04d499c99d.tar.gz
gentoo-2-91c33f6085b5cf8fcd1467eca583aa04d499c99d.tar.bz2
gentoo-2-91c33f6085b5cf8fcd1467eca583aa04d499c99d.zip
Move to xz.
(Portage version: 2.2.0_alpha19/cvs/Linux i686)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/parted/ChangeLog9
-rw-r--r--sys-block/parted/parted-2.3-r1.ebuild72
2 files changed, 79 insertions, 2 deletions
diff --git a/sys-block/parted/ChangeLog b/sys-block/parted/ChangeLog
index 3b07ee1da5ef..96176de5651b 100644
--- a/sys-block/parted/ChangeLog
+++ b/sys-block/parted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-block/parted
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/parted/ChangeLog,v 1.2 2010/10/29 15:42:37 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/parted/ChangeLog,v 1.3 2011/01/29 05:45:06 jer Exp $
+
+*parted-2.3-r1 (29 Jan 2011)
+
+ 29 Jan 2011; Jeroen Roovers <jer@gentoo.org> +parted-2.3-r1.ebuild:
+ Move to xz.
29 Oct 2010; Jeroen Roovers <jer@gentoo.org> parted-2.3.ebuild:
Add dev-util/pkgconfig to DEPEND by Mike Hiretsky (bug #343239). Set
diff --git a/sys-block/parted/parted-2.3-r1.ebuild b/sys-block/parted/parted-2.3-r1.ebuild
new file mode 100644
index 000000000000..194ca38d73dc
--- /dev/null
+++ b/sys-block/parted/parted-2.3-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/parted/parted-2.3-r1.ebuild,v 1.1 2011/01/29 05:45:06 jer Exp $
+
+EAPI="3"
+
+WANT_AUTOMAKE="1.11"
+
+inherit autotools eutils
+
+DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
+HOMEPAGE="http://www.gnu.org/software/parted"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls readline +debug selinux device-mapper"
+
+# specific version for gettext needed
+# to fix bug 85999
+RDEPEND="
+ >=sys-fs/e2fsprogs-1.27
+ >=sys-libs/ncurses-5.2
+ nls? ( >=sys-devel/gettext-0.12.1-r2 )
+ readline? ( >=sys-libs/readline-5.2 )
+ selinux? ( sys-libs/libselinux )
+ device-mapper? ( || ( >=sys-fs/lvm2-2.02.45 sys-fs/device-mapper ) )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/pkgconfig
+"
+
+src_prepare() {
+ # Remove tests known to FAIL instead of SKIP without OS/userland support
+ sed -i libparted/tests/Makefile.am \
+ -e 's|t3000-symlink.sh||g' || die "sed failed"
+ sed -i tests/Makefile.am \
+ -e '/t4100-msdos-partition-limits.sh/d' \
+ -e '/t4100-dvh-partition-limits.sh/d' \
+ -e '/t6000-dm.sh/d' || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with readline) \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_enable selinux) \
+ $(use_enable device-mapper) \
+ --disable-rpath \
+ --disable-Werror || die "Configure failed"
+}
+
+src_test() {
+ if use debug; then
+ # Do not die when tests fail - some requirements are not
+ # properly checked and should not lead to the ebuild failing.
+ emake check
+ else
+ ewarn "Skipping tests because USE=-debug is set."
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Install failed"
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
+ dodoc doc/{API,FAT,USER.jp}
+}