summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2011-08-18 00:03:00 +0000
committerMatt Turner <mattst88@gentoo.org>2011-08-18 00:03:00 +0000
commitd713b4657645839d64c4b6d7daff3a072040f0f1 (patch)
tree9e21cd12d41bdbc166714e97a0bb1708ffdc9ced /sys-auth
parentVersion bump (diff)
downloadgentoo-2-d713b4657645839d64c4b6d7daff3a072040f0f1.tar.gz
gentoo-2-d713b4657645839d64c4b6d7daff3a072040f0f1.tar.bz2
gentoo-2-d713b4657645839d64c4b6d7daff3a072040f0f1.zip
Fix build with USE=-crypt, bug 379267
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/ChangeLog6
-rw-r--r--sys-auth/pam_mount/files/pam_mount-2.11-fix-build-without-cryptsetup.patch25
-rw-r--r--sys-auth/pam_mount/pam_mount-2.11.ebuild8
3 files changed, 36 insertions, 3 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 3349912c8d94..29fc1f44dc0e 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.55 2011/08/14 18:31:29 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.56 2011/08/18 00:03:00 mattst88 Exp $
+
+ 18 Aug 2011; Matt Turner <mattst88@gentoo.org> pam_mount-2.11.ebuild,
+ +files/pam_mount-2.11-fix-build-without-cryptsetup.patch:
+ Fix build with USE=-crypt, bug 379267
*pam_mount-2.11 (14 Aug 2011)
diff --git a/sys-auth/pam_mount/files/pam_mount-2.11-fix-build-without-cryptsetup.patch b/sys-auth/pam_mount/files/pam_mount-2.11-fix-build-without-cryptsetup.patch
new file mode 100644
index 000000000000..5f422e234265
--- /dev/null
+++ b/sys-auth/pam_mount/files/pam_mount-2.11-fix-build-without-cryptsetup.patch
@@ -0,0 +1,25 @@
+From a3b07a52a41b17dacbc1b703b6dd331cd1cf6e61 Mon Sep 17 00:00:00 2001
+From: Jan Engelhardt <jengelh@medozas.de>
+Date: Tue, 16 Aug 2011 07:28:21 +0200
+Subject: [PATCH] build: make build of pmt-ehd dependent upon HAVE_LIBCRYPTSETUP
+
+---
+ src/Makefile.am | 2 +-
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 347d475..38e8395 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -8,7 +8,7 @@ AM_CFLAGS = ${regular_CFLAGS} ${GCC_FVISIBILITY_HIDDEN} \
+ moduledir = @PAM_MODDIR@
+ module_LTLIBRARIES = pam_mount.la
+ sbin_PROGRAMS = pmvarrun
+-if HAVE_LIBCRYPTO
++if HAVE_LIBCRYPTSETUP
+ sbin_PROGRAMS += pmt-ehd
+ endif
+ ssbin_PROGRAMS = mount.crypt
+--
+1.7.3.4
+
diff --git a/sys-auth/pam_mount/pam_mount-2.11.ebuild b/sys-auth/pam_mount/pam_mount-2.11.ebuild
index dd1c76d589d4..4b28a902b28d 100644
--- a/sys-auth/pam_mount/pam_mount-2.11.ebuild
+++ b/sys-auth/pam_mount/pam_mount-2.11.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-2.11.ebuild,v 1.1 2011/08/14 18:31:29 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-2.11.ebuild,v 1.2 2011/08/18 00:03:00 mattst88 Exp $
EAPI=4
-inherit multilib
+inherit eutils multilib
DESCRIPTION="A PAM module that can mount volumes for a user session"
HOMEPAGE="http://pam-mount.sourceforge.net"
@@ -27,6 +27,10 @@ DEPEND="${COMMON_DEPEND}
app-arch/xz-utils"
RDEPEND="${COMMON_DEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-build-without-cryptsetup.patch
+}
+
src_configure() {
econf --with-slibdir="/$(get_libdir)" \
$(use_with crypt cryptsetup) \