summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2011-11-24 18:27:15 +0000
committerHanno Böck <hanno@gentoo.org>2011-11-24 18:27:15 +0000
commitd38bec4adfb1c99ea7a3b4c267330694f7aef70e (patch)
tree8d05256bbe1adc0e758c00d6817cdccf027f8b6f /sys-auth
parentnet-mail/notmuch: Version bump to 0.10. (diff)
downloadgentoo-2-d38bec4adfb1c99ea7a3b4c267330694f7aef70e.tar.gz
gentoo-2-d38bec4adfb1c99ea7a3b4c267330694f7aef70e.tar.bz2
gentoo-2-d38bec4adfb1c99ea7a3b4c267330694f7aef70e.zip
pam_mysql: fix memleak
(Portage version: 2.1.10.37/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mysql/ChangeLog8
-rw-r--r--sys-auth/pam_mysql/files/pam_mysql-0.7_rc1-memleak.diff10
-rw-r--r--sys-auth/pam_mysql/pam_mysql-0.7_rc1-r4.ebuild39
3 files changed, 56 insertions, 1 deletions
diff --git a/sys-auth/pam_mysql/ChangeLog b/sys-auth/pam_mysql/ChangeLog
index ffed435920ed..552f7afe5d23 100644
--- a/sys-auth/pam_mysql/ChangeLog
+++ b/sys-auth/pam_mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/pam_mysql
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mysql/ChangeLog,v 1.16 2011/09/13 07:29:13 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mysql/ChangeLog,v 1.17 2011/11/24 18:27:15 hanno Exp $
+
+*pam_mysql-0.7_rc1-r4 (24 Nov 2011)
+
+ 24 Nov 2011; Hanno Boeck <hanno@gentoo.org> +pam_mysql-0.7_rc1-r4.ebuild,
+ +files/pam_mysql-0.7_rc1-memleak.diff:
+ Fix memleak, closes #364639.
*pam_mysql-0.7_rc1-r3 (13 Sep 2011)
diff --git a/sys-auth/pam_mysql/files/pam_mysql-0.7_rc1-memleak.diff b/sys-auth/pam_mysql/files/pam_mysql-0.7_rc1-memleak.diff
new file mode 100644
index 000000000000..e746be72029d
--- /dev/null
+++ b/sys-auth/pam_mysql/files/pam_mysql-0.7_rc1-memleak.diff
@@ -0,0 +1,10 @@
+--- pam_mysql-0.7RC1/pam_mysql.c 2006-01-09 11:35:59.000000000 +0100
++++ pam_mysql-0.7RC1-1/pam_mysql.c 2011-10-18 20:26:38.655425994 +0200
+@@ -2338,6 +2338,7 @@
+ }
+
+ mysql_close(ctx->mysql_hdl);
++ mysql_library_end();
+
+ xfree(ctx->mysql_hdl);
+ ctx->mysql_hdl = NULL;
diff --git a/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r4.ebuild b/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r4.ebuild
new file mode 100644
index 000000000000..c1d212502272
--- /dev/null
+++ b/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r4.ebuild,v 1.1 2011/11/24 18:27:15 hanno Exp $
+
+EAPI=2
+inherit autotools libtool pam
+
+DESCRIPTION="pam_mysql is a module for pam to authenticate users with mysql"
+HOMEPAGE="http://pam-mysql.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/pam-mysql/${P/_rc/RC}.tar.gz"
+DEPEND=">=sys-libs/pam-0.72 virtual/mysql"
+RDEPEND="${DEPEND}"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="openssl"
+S="${WORKDIR}/${P/_rc/RC}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-link-to-pam.diff"
+ epatch "${FILESDIR}/${P}-memleak.diff"
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf $(use_with openssl)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" libdir="$(getpam_mod_dir)" install || die "install failed"
+ rm "${D}/$(getpam_mod_dir)/pam_mysql.la" || die "Failed to remove pam_mysql.la"
+ dodoc CREDITS ChangeLog NEWS README
+}