summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2011-12-15 20:03:36 +0000
committerHanno Böck <hanno@gentoo.org>2011-12-15 20:03:36 +0000
commit56e430bfeb3d42e2594cd04ceafbbd3ae2a2f838 (patch)
tree59796782b998c59aded3b89d53d8bd0a527ee088 /sys-auth
parentlibhx: version bump (diff)
downloadgentoo-2-56e430bfeb3d42e2594cd04ceafbbd3ae2a2f838.tar.gz
gentoo-2-56e430bfeb3d42e2594cd04ceafbbd3ae2a2f838.tar.bz2
gentoo-2-56e430bfeb3d42e2594cd04ceafbbd3ae2a2f838.zip
pam_mount: version bump
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-2.13.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 735b1c0ef0a3..e45fcdd20e76 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.61 2011/10/06 14:35:03 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.62 2011/12/15 20:03:36 hanno Exp $
+
+*pam_mount-2.13 (15 Dec 2011)
+
+ 15 Dec 2011; Hanno Boeck <hanno@gentoo.org> +pam_mount-2.13.ebuild:
+ Version bump.
*pam_mount-2.12 (06 Oct 2011)
diff --git a/sys-auth/pam_mount/pam_mount-2.13.ebuild b/sys-auth/pam_mount/pam_mount-2.13.ebuild
new file mode 100644
index 000000000000..01845513f2d8
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-2.13.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-2.13.ebuild,v 1.1 2011/12/15 20:03:36 hanno Exp $
+
+EAPI=4
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt ssl selinux"
+
+COMMON_DEPEND=">=sys-libs/pam-0.99
+ >=sys-libs/libhx-3.12.1
+ >=dev-libs/libxml2-2.6
+ crypt? ( >=sys-fs/cryptsetup-1.1.0 )
+ ssl? ( >=dev-libs/openssl-0.9.8 )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ app-arch/xz-utils"
+RDEPEND="${COMMON_DEPEND}"
+
+src_configure() {
+ econf --with-slibdir="/$(get_libdir)" \
+ $(use_with crypt cryptsetup) \
+ $(use_with ssl crypto) \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ use selinux || rm -r "${D}"/etc/selinux
+ dodoc doc/*.txt
+}