summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-30 14:28:56 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-30 14:28:56 +0000
commit91d97675bfda8911690c0ef0fa45e7c7a4823139 (patch)
treef023c14aad03c3cba577756720aa888f188a49af /sys-auth/pam_ldap/pam_ldap-186-r1.ebuild
parentEnable multilib support. (diff)
downloadgentoo-2-91d97675bfda8911690c0ef0fa45e7c7a4823139.tar.gz
gentoo-2-91d97675bfda8911690c0ef0fa45e7c7a4823139.tar.bz2
gentoo-2-91d97675bfda8911690c0ef0fa45e7c7a4823139.zip
Enable multilib support.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-auth/pam_ldap/pam_ldap-186-r1.ebuild')
-rw-r--r--sys-auth/pam_ldap/pam_ldap-186-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-auth/pam_ldap/pam_ldap-186-r1.ebuild b/sys-auth/pam_ldap/pam_ldap-186-r1.ebuild
new file mode 100644
index 000000000000..7053b6f415fe
--- /dev/null
+++ b/sys-auth/pam_ldap/pam_ldap-186-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ldap/pam_ldap-186-r1.ebuild,v 1.1 2014/05/30 14:28:56 mgorny Exp $
+
+EAPI=5
+inherit eutils multilib-minimal pam
+
+DESCRIPTION="PAM LDAP Module"
+HOMEPAGE="http://www.padl.com/OSS/pam_ldap.html"
+SRC_URI="http://www.padl.com/download/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl sasl"
+
+DEPEND="|| ( >=sys-libs/glibc-2.1.3 >=sys-freebsd/freebsd-lib-9.1 )
+ virtual/pam[${MULTILIB_USEDEP}]
+ >=net-nds/openldap-2.1.30-r5[${MULTILIB_USEDEP}]
+ sasl? ( dev-libs/cyrus-sasl )"
+RDEPEND="${DEPEND}
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508-r7
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+
+multilib_src_configure() {
+ local myconf=(
+ --with-ldap-lib=openldap
+ $(use_enable ssl)
+ )
+ if ! multilib_is_native_abi || ! use sasl; then
+ myconf+=( ac_cv_header_sasl_sasl_h=no )
+ fi
+
+ ECONF_SOURCE=${S} \
+ econf "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ PERL5LIB=${S} \
+ emake
+}
+
+multilib_src_install() {
+ dopammod pam_ldap.so
+}
+
+multilib_src_install_all() {
+ dodoc pam.conf ldap.conf ldapns.schema chsh chfn certutil
+ dodoc ChangeLog CVSVersionInfo.txt README AUTHORS ns-pwd-policy.schema
+ doman pam_ldap.5
+
+ docinto pam.d
+ dodoc pam.d/*
+}