summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-01-11 05:48:34 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-01-11 05:48:34 +0000
commitf366c408d4bf73db73fba2c5bb5afc166750c42a (patch)
tree1523b4a5b8144640eaa85649cc07192d92b19dde /sys-auth/nss-mdns
parentNew revision, installs xhtml1 entries in the global XML catalog (bug #159122). (diff)
downloadgentoo-2-f366c408d4bf73db73fba2c5bb5afc166750c42a.tar.gz
gentoo-2-f366c408d4bf73db73fba2c5bb5afc166750c42a.tar.bz2
gentoo-2-f366c408d4bf73db73fba2c5bb5afc166750c42a.zip
Disable legacy code and force avahi (bug #159798)
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'sys-auth/nss-mdns')
-rw-r--r--sys-auth/nss-mdns/ChangeLog9
-rw-r--r--sys-auth/nss-mdns/files/digest-nss-mdns-0.9-r13
-rw-r--r--sys-auth/nss-mdns/nss-mdns-0.9-r1.ebuild63
3 files changed, 74 insertions, 1 deletions
diff --git a/sys-auth/nss-mdns/ChangeLog b/sys-auth/nss-mdns/ChangeLog
index 1ec520df198f..16e9726dff6b 100644
--- a/sys-auth/nss-mdns/ChangeLog
+++ b/sys-auth/nss-mdns/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/nss-mdns
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-mdns/ChangeLog,v 1.15 2007/01/02 19:30:34 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-mdns/ChangeLog,v 1.16 2007/01/11 05:48:34 compnerd Exp $
+
+*nss-mdns-0.9-r1 (11 Jan 2007)
+
+ 11 Jan 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+ +nss-mdns-0.9-r1.ebuild:
+ Force avahi, disable legacy code (bug #159798) thanks to Gioele Barabucci
+ for noticing
*nss-mdns-0.9 (02 Jan 2007)
diff --git a/sys-auth/nss-mdns/files/digest-nss-mdns-0.9-r1 b/sys-auth/nss-mdns/files/digest-nss-mdns-0.9-r1
new file mode 100644
index 000000000000..b8b2a3bc4e52
--- /dev/null
+++ b/sys-auth/nss-mdns/files/digest-nss-mdns-0.9-r1
@@ -0,0 +1,3 @@
+MD5 bc72f5b19cc6ce8cacde448236b30868 nss-mdns-0.9.tar.gz 346397
+RMD160 4ee2d374040005b185dec04934ede34e9a63362a nss-mdns-0.9.tar.gz 346397
+SHA256 0bf226bb3a1716e6eb97355e08a7ffcf09aadfb91ba41ccef2ef1ba7a01719a2 nss-mdns-0.9.tar.gz 346397
diff --git a/sys-auth/nss-mdns/nss-mdns-0.9-r1.ebuild b/sys-auth/nss-mdns/nss-mdns-0.9-r1.ebuild
new file mode 100644
index 000000000000..93aa17793d7a
--- /dev/null
+++ b/sys-auth/nss-mdns/nss-mdns-0.9-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-mdns/nss-mdns-0.9-r1.ebuild,v 1.1 2007/01/11 05:48:34 compnerd Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.9"
+
+inherit autotools eutils
+
+DESCRIPTION="Name Service Switch module for Multicast DNS"
+HOMEPAGE="http://0pointer.de/lennart/projects/nss-mdns/"
+SRC_URI="http://0pointer.de/lennart/projects/nss-mdns/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="net-dns/avahi"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-0.8-avahi-socket.patch
+ eautomake
+}
+
+src_compile() {
+ econf --enable-search-domains --enable-avahi || die "configure failed"
+ emake || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+
+ insinto /etc
+ doins ${FILESDIR}/mdns.allow
+
+ dodoc README
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "You must modify your name service switch look up file to enable"
+ ewarn "multicast DNS lookups. If you wish to resolve only IPv6 addresses"
+ ewarn "use mdns6. For IPv4 addresses only, use mdns4. To resolve both"
+ ewarn "use mdns. Keep in mind that mdns will be slower if there are no"
+ ewarn "IPv6 addresses published via mDNS on the network. There are also"
+ ewarn "minimal (mdns?_minimal) libraries which only lookup .local hosts"
+ ewarn "and 169.254.x.x addresses."
+ ewarn
+ ewarn "Add the appropriate mdns into the hosts line in /etc/nsswitch.conf"
+ ewarn "An example line looks like:"
+ einfo "hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4"
+ ewarn
+ ewarn "If you want to perform mDNS lookups for domains other than the ones"
+ ewarn "ending in .local, add them to /etc/mdns.allow"
+ ewarn
+ ebeep 5
+ epause 10
+}