summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2004-11-23 00:42:08 +0000
committerChris PeBenito <pebenito@gentoo.org>2004-11-23 00:42:08 +0000
commitfaafe28c80ef49b380cd7510b437e96608dd02ca (patch)
tree6dfd1e982c84d7b652ca093bc491545b9d91569f /sys-apps
parentVersion bumped. Bug 71976. (Manifest recommit) (diff)
downloadgentoo-2-faafe28c80ef49b380cd7510b437e96608dd02ca.tar.gz
gentoo-2-faafe28c80ef49b380cd7510b437e96608dd02ca.tar.bz2
gentoo-2-faafe28c80ef49b380cd7510b437e96608dd02ca.zip
cleanup plus stage1 stuff
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/policycoreutils/ChangeLog6
-rw-r--r--sys-apps/policycoreutils/policycoreutils-1.18.ebuild24
2 files changed, 23 insertions, 7 deletions
diff --git a/sys-apps/policycoreutils/ChangeLog b/sys-apps/policycoreutils/ChangeLog
index 4a655e11a172..7f600ecafa75 100644
--- a/sys-apps/policycoreutils/ChangeLog
+++ b/sys-apps/policycoreutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/policycoreutils
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.36 2004/11/15 20:47:39 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.37 2004/11/23 00:42:08 pebenito Exp $
+
+ 22 Nov 2004; Chris PeBenito <pebenito@gentoo.org>
+ policycoreutils-1.18.ebuild:
+ Ensure a few dirs and perms during stage1 build.
15 Nov 2004; Chris PeBenito <pebenito@gentoo.org>
policycoreutils-1.18.ebuild:
diff --git a/sys-apps/policycoreutils/policycoreutils-1.18.ebuild b/sys-apps/policycoreutils/policycoreutils-1.18.ebuild
index 3172897176b1..117ab67cbb6a 100644
--- a/sys-apps/policycoreutils/policycoreutils-1.18.ebuild
+++ b/sys-apps/policycoreutils/policycoreutils-1.18.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-1.18.ebuild,v 1.2 2004/11/15 20:47:39 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-1.18.ebuild,v 1.3 2004/11/23 00:42:08 pebenito Exp $
IUSE="build"
inherit eutils
EXTRAS_VER="1.9"
+SEPOL_VER="1.2"
DESCRIPTION="SELinux core utilities"
HOMEPAGE="http://www.nsa.gov/selinux"
@@ -17,9 +18,10 @@ SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~amd64"
DEPEND=">=sys-libs/libselinux-${PV}
- >=sys-libs/libsepol-1.2
+ >=sys-libs/libsepol-${SEPOL_VER}
sys-devel/gettext
- !build? ( sys-libs/pam )"
+ !build? ( sys-libs/pam )
+ build? ( sys-apps/baselayout )"
S2=${WORKDIR}/policycoreutils-extra
@@ -28,9 +30,6 @@ src_unpack() {
cd ${S}
- # add compatibility for number of genhomedircon command line args
-# epatch ${FILESDIR}/policycoreutils-1.16-genhomedircon-compat.diff
-
# dont install fixfiles cron script
sed -i -e '/^all/s/fixfiles//' ${S}/scripts/Makefile \
|| die "fixfiles sed 1 failed"
@@ -67,3 +66,16 @@ src_install() {
make DESTDIR="${D}" -C ${S2} install || die
fi
}
+
+pkg_postinst() {
+ if use build; then
+ # need to ensure these
+ mkdir -p ${ROOT}/selinux
+ touch ${ROOT}/selinux/.keep
+ mkdir -p ${ROOT}/sys
+ touch ${ROOT}/sys/.keep
+ mkdir -p ${ROOT}/dev/pts
+ touch ${ROOT}/dev/pts/.keep
+ chmod 0666 ${ROOT}/dev/{ptmx,tty}
+ fi
+}