summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-02-04 23:03:24 +0000
committerMike Frysinger <vapier@gentoo.org>2007-02-04 23:03:24 +0000
commite9f5ff094b14ab74867c87699ba493d3848909ee (patch)
tree6d806f6d302ff03852ded5530ab7c71846d56c3d /sys-apps
parentVersion bump (diff)
downloadgentoo-2-e9f5ff094b14ab74867c87699ba493d3848909ee.tar.gz
gentoo-2-e9f5ff094b14ab74867c87699ba493d3848909ee.tar.bz2
gentoo-2-e9f5ff094b14ab74867c87699ba493d3848909ee.zip
Version bump.
(Portage version: 2.1.2-r6)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/microcode-ctl/ChangeLog10
-rw-r--r--sys-apps/microcode-ctl/files/digest-microcode-ctl-1.163
-rw-r--r--sys-apps/microcode-ctl/microcode-ctl-1.16.ebuild43
3 files changed, 54 insertions, 2 deletions
diff --git a/sys-apps/microcode-ctl/ChangeLog b/sys-apps/microcode-ctl/ChangeLog
index 35ac6d9dfdb6..006c8d981e1e 100644
--- a/sys-apps/microcode-ctl/ChangeLog
+++ b/sys-apps/microcode-ctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/microcode-ctl
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.19 2006/11/10 00:08:28 vapier Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.20 2007/02/04 23:03:24 vapier Exp $
+
+*microcode-ctl-1.16 (04 Feb 2007)
+
+ 04 Feb 2007; Mike Frysinger <vapier@gentoo.org>
+ +microcode-ctl-1.16.ebuild:
+ Version bump.
*microcode-ctl-1.15 (10 Nov 2006)
diff --git a/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.16 b/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.16
new file mode 100644
index 000000000000..9fc7cac2a0e8
--- /dev/null
+++ b/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.16
@@ -0,0 +1,3 @@
+MD5 9788fad3b9c430667767f7d4238789c4 microcode_ctl-1.16.tar.gz 318239
+RMD160 52263a54a6ba1c8a5937bd03b3c9262e7baee3a6 microcode_ctl-1.16.tar.gz 318239
+SHA256 bbfdc69e0f599ff655c79b1e652bce4cb167940f660b9c3b1d57a04caa0f65e1 microcode_ctl-1.16.tar.gz 318239
diff --git a/sys-apps/microcode-ctl/microcode-ctl-1.16.ebuild b/sys-apps/microcode-ctl/microcode-ctl-1.16.ebuild
new file mode 100644
index 000000000000..dd07996ec95d
--- /dev/null
+++ b/sys-apps/microcode-ctl/microcode-ctl-1.16.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/microcode-ctl-1.16.ebuild,v 1.1 2007/02/04 23:03:24 vapier Exp $
+
+inherit toolchain-funcs
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Intel IA32 microcode update utility"
+HOMEPAGE="http://www.urbanmyth.org/microcode"
+SRC_URI="http://www.urbanmyth.org/microcode/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ || die "compile problem"
+}
+
+src_install() {
+ dosbin microcode_ctl || die "dosbin"
+ doman microcode_ctl.8
+ dodoc Changelog README
+
+ insinto /etc
+ newins intel-ia32microcode-*.txt microcode.dat
+
+ newinitd "${FILESDIR}"/microcode_ctl.rc microcode_ctl
+ newconfd "${FILESDIR}"/microcode_ctl.conf.d microcode_ctl
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must include microcode update support."
+ echo
+ einfo "Microcode updates will be lost at every reboot."
+ einfo "You can use the init.d script to update at boot time."
+}