summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2013-08-14 03:56:38 +0000
committerWilliam Hubbs <williamh@gentoo.org>2013-08-14 03:56:38 +0000
commite77b790558bc7a9525aa2828867f3d35087d120e (patch)
tree698bf35c5f72e5c32d7785a1421bd48f24cc5d8f /sys-apps
parentInitial perl-5.18.1 ebuild borrowed from the perl-experimental overlay (diff)
downloadgentoo-2-e77b790558bc7a9525aa2828867f3d35087d120e.tar.gz
gentoo-2-e77b790558bc7a9525aa2828867f3d35087d120e.tar.bz2
gentoo-2-e77b790558bc7a9525aa2828867f3d35087d120e.zip
adjustments for separating netifrc: add a temporary pdepend with a use flag to bring it in and add warnings about both network use flags missing.
(Portage version: 2.2.0/cvs/Linux i686, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/openrc/ChangeLog7
-rw-r--r--sys-apps/openrc/metadata.xml1
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild36
3 files changed, 22 insertions, 22 deletions
diff --git a/sys-apps/openrc/ChangeLog b/sys-apps/openrc/ChangeLog
index a42c5079f575..90ad86dd00d5 100644
--- a/sys-apps/openrc/ChangeLog
+++ b/sys-apps/openrc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/openrc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.271 2013/08/11 06:56:36 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.272 2013/08/14 03:56:38 williamh Exp $
+
+ 14 Aug 2013; William Hubbs <williamh@gentoo.org> metadata.xml,
+ openrc-9999.ebuild:
+ adjustments for separating netifrc: add a temporary pdepend with a use flag to
+ bring it in and add warnings about both network use flags missing.
11 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> openrc-0.11.8.ebuild,
openrc-9999.ebuild:
diff --git a/sys-apps/openrc/metadata.xml b/sys-apps/openrc/metadata.xml
index 6222e313b3ff..00439362b480 100644
--- a/sys-apps/openrc/metadata.xml
+++ b/sys-apps/openrc/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>openrc</herd>
<use>
+ <flag name="netifrc">enable Gentoo's network stack (net.* scripts)</flag>
<flag name="newnet">enable the new network stack (experimental)</flag>
<flag name="tools">build optional tools</flag>
</use>
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 55ff188ef2e4..30e2691c5e08 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.125 2013/08/11 06:56:36 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.126 2013/08/14 03:56:38 williamh Exp $
EAPI=5
@@ -19,8 +19,8 @@ fi
LICENSE="BSD-2"
SLOT="0"
-IUSE="debug elibc_glibc ncurses pam newnet prefix selinux static-libs tools
- unicode kernel_linux kernel_FreeBSD"
+IUSE="debug elibc_glibc ncurses pam newnet prefix +netifrc selinux static-libs
+ tools unicode kernel_linux kernel_FreeBSD"
COMMON_DEPEND=">=sys-apps/baselayout-2.1-r1
kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-ubin-9.0_rc sys-process/fuser-bsd ) )
@@ -43,9 +43,10 @@ RDEPEND="${COMMON_DEPEND}
kernel_FreeBSD? ( sys-freebsd/freebsd-sbin )
)"
+PDEPEND="netifrc? ( net-misc/netifrc )"
+
src_prepare() {
sed -i 's:0444:0644:' mk/sys.mk || die
- sed -i "/^DIR/s:/openrc:/${PF}:" doc/Makefile || die #241342
if [[ ${PV} == "9999" ]] ; then
local ver="git-${EGIT_VERSION:0:6}"
@@ -119,9 +120,6 @@ src_install() {
cp -PR "${ED}"/etc/runlevels "${ED}"/usr/share/${PN} || die
rm -rf "${ED}"/etc/runlevels
- # Install the default net configuration
- doconfd conf.d/net
-
# Setup unicode defaults for silly unicode users
set_config_yes_no /etc/rc.conf unicode use unicode
@@ -178,14 +176,6 @@ add_boot_init_mit_config() {
pkg_preinst() {
local f LIBDIR=$(get_libdir)
- # default net script is just comments, so no point in biting people
- # in the ass by accident. we save in preinst so that the package
- # manager doesnt go throwing etc-update crap at us -- postinst is
- # too late to prevent that. this behavior also lets us keep the
- # file in the CONTENTS for binary packages.
- [[ -e "${EROOT}"etc/conf.d/net ]] && \
- cp "${EROOT}"etc/conf.d/net "${ED}"/etc/conf.d/
-
# avoid default thrashing in conf.d files when possible #295406
if [[ -e "${EROOT}"etc/conf.d/hostname ]] ; then
(
@@ -276,14 +266,18 @@ pkg_postinst() {
# update the dependency tree after touching all files #224171
[[ "${EROOT}" = "/" ]] && "${EROOT}/${LIBDIR}"/rc/bin/rc-depend -u
- if use newnet; then
- local netscript=network
- else
- local netscript=net.lo
+ if ! use newnet && ! use netifrc; then
+ ewarn "You have emerged OpenRc without network support. This"
+ ewarn "means you need to SET UP a network manager such as"
+ ewarn " net-misc/netifrc, net-misc/dhcpcd, net-misc/wicd,"
+ ewarn "net-misc/NetworkManager, or net-misc/badvpn."
+ ewarn "Or, you have the option of emerging openrc with the newnet"
+ ewarn "use flag and configuring /etc/conf.d/network and"
+ ewarn "/etc/conf.d/staticroute if you only use static interfaces."
fi
- if [ ! -e "${EROOT}"etc/runlevels/boot/${netscript} ]; then
- ewarn "Please add the $netscript script to your boot runlevel"
+ if use newnet && [ ! -e "${EROOT}"etc/runlevels/boot/network ]; then
+ ewarn "Please add the network service to your boot runlevel"
ewarn "as soon as possible. Not doing so could leave you with a system"
ewarn "without networking."
fi