summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2014-10-29 17:33:11 +0000
committerSven Vermeulen <swift@gentoo.org>2014-10-29 17:33:11 +0000
commitd5a9567b36e53caf7705386684c0b1bf27f4d41a (patch)
treed743e30d5c5bf99519eb505665a7c97366717a25 /sys-apps
parentBump to 2.4_rc5 (diff)
downloadgentoo-2-d5a9567b36e53caf7705386684c0b1bf27f4d41a.tar.gz
gentoo-2-d5a9567b36e53caf7705386684c0b1bf27f4d41a.tar.bz2
gentoo-2-d5a9567b36e53caf7705386684c0b1bf27f4d41a.zip
Bump to 2.4_rc5
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x2EDD52403B68AF47)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/policycoreutils/ChangeLog9
-rw-r--r--sys-apps/policycoreutils/policycoreutils-2.4_rc2.ebuild4
-rw-r--r--sys-apps/policycoreutils/policycoreutils-2.4_rc5.ebuild (renamed from sys-apps/policycoreutils/policycoreutils-2.4_rc4.ebuild)21
3 files changed, 29 insertions, 5 deletions
diff --git a/sys-apps/policycoreutils/ChangeLog b/sys-apps/policycoreutils/ChangeLog
index fbc37ed775f7..2fc772cf04a7 100644
--- a/sys-apps/policycoreutils/ChangeLog
+++ b/sys-apps/policycoreutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/policycoreutils
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.143 2014/10/07 19:04:20 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.144 2014/10/29 17:33:11 swift Exp $
+
+*policycoreutils-2.4_rc5 (29 Oct 2014)
+
+ 29 Oct 2014; Sven Vermeulen <swift@gentoo.org>
+ +policycoreutils-2.4_rc5.ebuild, -policycoreutils-2.4_rc4.ebuild,
+ policycoreutils-2.4_rc2.ebuild:
+ Bump to 2.4_rc5
*policycoreutils-2.4_rc4 (07 Oct 2014)
diff --git a/sys-apps/policycoreutils/policycoreutils-2.4_rc2.ebuild b/sys-apps/policycoreutils/policycoreutils-2.4_rc2.ebuild
index 0bf23e78fa18..aca9d8a524fe 100644
--- a/sys-apps/policycoreutils/policycoreutils-2.4_rc2.ebuild
+++ b/sys-apps/policycoreutils/policycoreutils-2.4_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-2.4_rc2.ebuild,v 1.1 2014/09/21 10:22:57 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-2.4_rc2.ebuild,v 1.2 2014/10/29 17:33:11 swift Exp $
EAPI="5"
PYTHON_COMPAT=( python2_7 )
@@ -34,7 +34,7 @@ COMMON_DEPS=">=sys-libs/libselinux-${SELNX_VER}[python]
sys-libs/libcap-ng
>=sys-libs/libsepol-${SEPOL_VER}
sys-devel/gettext
- dev-python/ipy
+ dev-python/ipy[${PYTHON_USEDEP}]
dbus? (
sys-apps/dbus
dev-libs/dbus-glib
diff --git a/sys-apps/policycoreutils/policycoreutils-2.4_rc4.ebuild b/sys-apps/policycoreutils/policycoreutils-2.4_rc5.ebuild
index ada21e47bd83..4b6fa1691283 100644
--- a/sys-apps/policycoreutils/policycoreutils-2.4_rc4.ebuild
+++ b/sys-apps/policycoreutils/policycoreutils-2.4_rc5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-2.4_rc4.ebuild,v 1.1 2014/10/07 19:04:20 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-2.4_rc5.ebuild,v 1.1 2014/10/29 17:33:11 swift Exp $
EAPI="5"
PYTHON_COMPAT=( python2_7 )
@@ -34,7 +34,7 @@ COMMON_DEPS=">=sys-libs/libselinux-${SELNX_VER}[python]
sys-libs/libcap-ng
>=sys-libs/libsepol-${SEPOL_VER}
sys-devel/gettext
- dev-python/ipy
+ dev-python/ipy[${PYTHON_USEDEP}]
dbus? (
sys-apps/dbus
dev-libs/dbus-glib
@@ -151,3 +151,20 @@ src_install() {
dodir /usr/share/doc/${PF}/mcstrans/examples
cp -dR "${S1}"/mcstrans/share/examples/* "${D}/usr/share/doc/${PF}/mcstrans/examples"
}
+
+pkg_postinst() {
+ # The selinux_gentoo init script is no longer needed with recent OpenRC
+ elog "The selinux_gentoo init script will be removed in future versions when OpenRC 0.13.x is stabilized."
+
+ # Migrate the SELinux semanage configuration store if not done already
+ local selinuxtype=$(awk -F'=' '/SELINUXTYPE=/ {print $2}' /etc/selinux/config);
+ if [ -n "${selinuxtype}" ] && [ ! -d /var/lib/selinux/${mcs}/active ] ; then
+ ewarn "Since the 2.4 SELinux userspace, the policy module store is moved"
+ ewarn "from /etc/selinux to /var/lib/selinux. In order to continue with"
+ ewarn "the 2.4 userspace, please migrate the necessary files by executing"
+ ewarn "/usr/libexec/selinux/semanage_migrate_store. Warnings about 'else'"
+ ewarn "blocks can be safely ignored."
+ ewarn "For more information, please see"
+ ewarn "- https://github.com/SELinuxProject/selinux/wiki/Policy-Store-Migration"
+ fi
+}