summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2014-05-30 13:44:29 +0000
committerSven Vermeulen <swift@gentoo.org>2014-05-30 13:44:29 +0000
commitd1470f815b2038a77689726b944357f5657b1cb4 (patch)
treec00332e66e20e440384822199c9905f09ff46770 /sys-apps
parentBump fakechroot to 2.17.2, thanks to Anthoine Bourgeois (bug #506118) (diff)
downloadgentoo-2-d1470f815b2038a77689726b944357f5657b1cb4.tar.gz
gentoo-2-d1470f815b2038a77689726b944357f5657b1cb4.tar.bz2
gentoo-2-d1470f815b2038a77689726b944357f5657b1cb4.zip
Fix x86 build failure with gcc 4.8.2, thanks to Martin Väth for the patch and Anthoine Bourgeios as maintainer for the ebuild (bug #492896)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2EDD52403B68AF47)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/fakeroot-ng/ChangeLog11
-rw-r--r--sys-apps/fakeroot-ng/fakeroot-ng-0.18-r1.ebuild22
-rw-r--r--sys-apps/fakeroot-ng/files/fakeroot-ng-gcc-4.8.2.patch10
3 files changed, 41 insertions, 2 deletions
diff --git a/sys-apps/fakeroot-ng/ChangeLog b/sys-apps/fakeroot-ng/ChangeLog
index f0b3a1e74dab..00e16792d5f1 100644
--- a/sys-apps/fakeroot-ng/ChangeLog
+++ b/sys-apps/fakeroot-ng/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/fakeroot-ng
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot-ng/ChangeLog,v 1.13 2013/11/27 19:54:54 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot-ng/ChangeLog,v 1.14 2014/05/30 13:44:28 swift Exp $
+
+*fakeroot-ng-0.18-r1 (30 May 2014)
+
+ 30 May 2014; Sven Vermeulen <swift@gentoo.org> +fakeroot-ng-0.18-r1.ebuild,
+ +files/fakeroot-ng-gcc-4.8.2.patch:
+ Fix x86 build failure with gcc 4.8.2, thanks to Martin Väth for the patch and
+ Anthoine Bourgeios as maintainer for the ebuild (bug #492896)
*fakeroot-ng-0.18 (27 Nov 2013)
diff --git a/sys-apps/fakeroot-ng/fakeroot-ng-0.18-r1.ebuild b/sys-apps/fakeroot-ng/fakeroot-ng-0.18-r1.ebuild
new file mode 100644
index 000000000000..d93ed379b23f
--- /dev/null
+++ b/sys-apps/fakeroot-ng/fakeroot-ng-0.18-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot-ng/fakeroot-ng-0.18-r1.ebuild,v 1.1 2014/05/30 13:44:28 swift Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A utility to run commands with fake root privileges"
+HOMEPAGE="http://sourceforge.net/projects/fakerootng/"
+SRC_URI="mirror://sourceforge/${PN//-/}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-gcc-4.8.2.patch
+}
diff --git a/sys-apps/fakeroot-ng/files/fakeroot-ng-gcc-4.8.2.patch b/sys-apps/fakeroot-ng/files/fakeroot-ng-gcc-4.8.2.patch
new file mode 100644
index 000000000000..50df56d51bdb
--- /dev/null
+++ b/sys-apps/fakeroot-ng/files/fakeroot-ng-gcc-4.8.2.patch
@@ -0,0 +1,10 @@
+--- 1/arch/linux/i386/platform_specific.h
++++ 1/arch/linux/i386/platform_specific.h
+@@ -2,6 +2,7 @@
+ #define PLATFORM_SPECIFIC_H
+
+ #include <asm/ptrace.h>
++#include <sys/types.h>
+ #include <sys/syscall.h>
+ #include <sys/resource.h>
+