summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-03 06:13:04 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-03 06:13:04 +0000
commit7b7ee3f67fd5efea39444fac691462e77a58cec4 (patch)
tree2a0d05e83f7f7a31a0bb6d81a910c7c0d90de9c6 /sys-apps
parentdrop portage depend #167415 (diff)
downloadgentoo-2-7b7ee3f67fd5efea39444fac691462e77a58cec4.tar.gz
gentoo-2-7b7ee3f67fd5efea39444fac691462e77a58cec4.tar.bz2
gentoo-2-7b7ee3f67fd5efea39444fac691462e77a58cec4.zip
Fix building when asm/page.h is not available #168278 by Daniel Black.
(Portage version: 2.1.2-r13)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/util-linux/ChangeLog6
-rw-r--r--sys-apps/util-linux/files/util-linux-2.12r-HAVE_asm_page_h.patch28
-rw-r--r--sys-apps/util-linux/util-linux-2.12r-r5.ebuild3
3 files changed, 35 insertions, 2 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index c81c6e49f410..7db64ccc43f1 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.178 2007/01/31 21:09:40 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.179 2007/03/03 06:13:04 vapier Exp $
+
+ 03 Mar 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/util-linux-2.12r-HAVE_asm_page_h.patch, util-linux-2.12r-r5.ebuild:
+ Fix building when asm/page.h is not available #168278 by Daniel Black.
31 Jan 2007; Markus Rothe <corsair@gentoo.org> util-linux-2.12r-r5.ebuild:
Stable on ppc64; bug #164011
diff --git a/sys-apps/util-linux/files/util-linux-2.12r-HAVE_asm_page_h.patch b/sys-apps/util-linux/files/util-linux-2.12r-HAVE_asm_page_h.patch
new file mode 100644
index 000000000000..0f7c3e252f70
--- /dev/null
+++ b/sys-apps/util-linux/files/util-linux-2.12r-HAVE_asm_page_h.patch
@@ -0,0 +1,28 @@
+fix building when asm/page.h is not available
+
+http://bugs.gentoo.org/168278
+
+--- disk-utils/fsck.cramfs.c
++++ disk-utils/fsck.cramfs.c
+@@ -76,7 +76,9 @@
+
+ #define PAD_SIZE 512
+
++#ifdef HAVE_asm_page_h
+ #include <asm/page.h>
++#endif
+ #ifdef PAGE_SIZE
+ #define PAGE_CACHE_SIZE ((int) PAGE_SIZE)
+ #elif defined __ia64__
+--- mount/swapon.c
++++ mount/swapon.c
+@@ -31,7 +31,9 @@
+ #include <sys/ioctl.h>
+ #include <sys/utsname.h>
+ #include <sys/time.h>
++#ifdef HAVE_asm_page_h
+ #include <asm/page.h>
++#endif
+ #include "xmalloc.h"
+ #include "swap_constants.h"
+ #include "swapargs.h"
diff --git a/sys-apps/util-linux/util-linux-2.12r-r5.ebuild b/sys-apps/util-linux/util-linux-2.12r-r5.ebuild
index eb4180d4d075..05ed32fdd32d 100644
--- a/sys-apps/util-linux/util-linux-2.12r-r5.ebuild
+++ b/sys-apps/util-linux/util-linux-2.12r-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12r-r5.ebuild,v 1.11 2007/01/31 21:09:40 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12r-r5.ebuild,v 1.12 2007/03/03 06:13:04 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -118,6 +118,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-2.12-mips-lseek.patch
epatch "${FILESDIR}"/${PN}-2.12r-no-_syscall.patch #150852
+ epatch "${FILESDIR}"/${PN}-2.12r-HAVE_asm_page_h.patch #168278
# Enable random features
local mconfigs="MCONFIG"