summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-07-22 01:44:28 +0000
committerIan Delaney <idella4@gentoo.org>2015-07-22 01:44:28 +0000
commit2ce188d9bf3883ab7e195c749ff910db2bd0ea43 (patch)
tree11770223335f8940423b4a26c0e6823823fbbbfb /sys-apps
parentRemove old. (diff)
downloadgentoo-2-2ce188d9bf3883ab7e195c749ff910db2bd0ea43.tar.gz
gentoo-2-2ce188d9bf3883ab7e195c749ff910db2bd0ea43.tar.bz2
gentoo-2-2ce188d9bf3883ab7e195c749ff910db2bd0ea43.zip
add -3.4.0 by request of proxy maintainer in bug #548388
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/roccat-tools/ChangeLog7
-rw-r--r--sys-apps/roccat-tools/roccat-tools-3.4.0.ebuild92
2 files changed, 98 insertions, 1 deletions
diff --git a/sys-apps/roccat-tools/ChangeLog b/sys-apps/roccat-tools/ChangeLog
index 8e42dec857db..9e330b26edec 100644
--- a/sys-apps/roccat-tools/ChangeLog
+++ b/sys-apps/roccat-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/roccat-tools
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/ChangeLog,v 1.17 2015/07/21 08:20:46 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/ChangeLog,v 1.18 2015/07/22 01:44:28 idella4 Exp $
+
+*roccat-tools-3.4.0 (22 Jul 2015)
+
+ 22 Jul 2015; Ian Delaney <idella4@gentoo.org> +roccat-tools-3.4.0.ebuild:
+ add -3.4.0 by request of proxy maintainer in bug #548388
*roccat-tools-3.5.0 (21 Jul 2015)
*roccat-tools-3.5.0-r1 (21 Jul 2015)
diff --git a/sys-apps/roccat-tools/roccat-tools-3.4.0.ebuild b/sys-apps/roccat-tools/roccat-tools-3.4.0.ebuild
new file mode 100644
index 000000000000..066c914e5e92
--- /dev/null
+++ b/sys-apps/roccat-tools/roccat-tools-3.4.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/roccat-tools-3.4.0.ebuild,v 1.1 2015/07/22 01:44:28 idella4 Exp $
+
+EAPI=5
+
+inherit readme.gentoo cmake-utils gnome2-utils udev user
+
+DESCRIPTION="Utility for advanced configuration of Roccat devices"
+
+HOMEPAGE="http://roccat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/roccat/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE_INPUT_DEVICES="
+ input_devices_roccat_arvo
+ input_devices_roccat_isku
+ input_devices_roccat_iskufx
+ input_devices_roccat_kone
+ input_devices_roccat_koneplus
+ input_devices_roccat_konepure
+ input_devices_roccat_konepuremilitary
+ input_devices_roccat_konepureoptical
+ input_devices_roccat_konextd
+ input_devices_roccat_konextdoptical
+ input_devices_roccat_kovaplus
+ input_devices_roccat_lua
+ input_devices_roccat_pyra
+ input_devices_roccat_savu
+ input_devices_roccat_ryosmk
+ input_devices_roccat_ryostkl
+ input_devices_roccat_tyon
+"
+IUSE="${IUSE_INPUT_DEVICES} lua"
+REQUIRED_USE="
+ lua? ( input_devices_roccat_ryosmk )
+"
+
+RDEPEND="
+ >=dev-libs/libgaminggear-0.10
+ x11-libs/gtk+:2
+ x11-libs/libnotify
+ media-libs/libcanberra
+ virtual/libusb:1
+ dev-libs/dbus-glib
+ virtual/libgudev:=
+ lua? ( || ( dev-lang/lua:5.1 dev-lang/lua:0 ) )
+"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ enewgroup roccat
+}
+
+src_configure() {
+ local UDEVDIR="$(get_udevdir)"/rules.d
+ local MODELS=${INPUT_DEVICES//roccat_/}
+ mycmakeargs=(
+ -DDEVICES=${MODELS// /;} \
+ -DUDEVDIR="${UDEVDIR/"//"//}"
+ )
+ if use lua ; then
+ mycmakeargs+=( -DWITH_LUA=5.1 )
+ fi
+ cmake-utils_src_configure
+}
+src_install() {
+ cmake-utils_src_install
+ local stat_dir=/var/lib/roccat
+ keepdir $stat_dir
+ fowners root:roccat $stat_dir
+ fperms 2770 $stat_dir
+ readme.gentoo_src_install
+}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+pkg_postinst() {
+ gnome2_icon_cache_update
+ readme.gentoo_print_elog
+ ewarn
+ ewarn "Starting from version 3.0.0, executables were renamed and now prefixed with 'roccat',"
+ ewarn "so konextdconfig is now roccatkonextdconfig and so on"
+ ewarn "Everything that was ryos is now ryosmk to distinguish it from the ryostkl product range"
+ ewarn
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}