summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2006-07-06 23:15:23 +0000
committerMarius Mauch <genone@gentoo.org>2006-07-06 23:15:23 +0000
commit0ab66171e8ed9b7828679b3f73fced0de6d2cfbc (patch)
treee11d13de20aa56367007054a9e39fc05706ea227 /sys-apps
parentStable on amd64, bug #103926. (diff)
downloadgentoo-2-0ab66171e8ed9b7828679b3f73fced0de6d2cfbc.tar.gz
gentoo-2-0ab66171e8ed9b7828679b3f73fced0de6d2cfbc.tar.bz2
gentoo-2-0ab66171e8ed9b7828679b3f73fced0de6d2cfbc.zip
replace einfo with elog
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/ChangeLog8
-rw-r--r--sys-apps/portage/portage-2.0.51.22-r3.ebuild26
-rw-r--r--sys-apps/portage/portage-2.0.54-r2.ebuild12
-rw-r--r--sys-apps/portage/portage-2.1-r1.ebuild62
-rw-r--r--sys-apps/portage/portage-2.1.1_pre1-r5.ebuild12
-rw-r--r--sys-apps/portage/portage-2.1.1_pre2-r2.ebuild12
-rw-r--r--sys-apps/portage/portage-2.1.1_pre2-r4.ebuild12
-rw-r--r--sys-apps/portage/portage-2.1.ebuild62
8 files changed, 106 insertions, 100 deletions
diff --git a/sys-apps/portage/ChangeLog b/sys-apps/portage/ChangeLog
index 75296eef78fa..c8b22b7d6bf6 100644
--- a/sys-apps/portage/ChangeLog
+++ b/sys-apps/portage/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/portage
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.200 2006/07/05 18:58:57 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.201 2006/07/06 23:15:23 genone Exp $
+
+ 06 Jul 2006; Marius Mauch <genone@gentoo.org> portage-2.0.51.22-r3.ebuild,
+ portage-2.0.54-r2.ebuild, portage-2.1.ebuild, portage-2.1-r1.ebuild,
+ portage-2.1.1_pre1-r5.ebuild, portage-2.1.1_pre2-r2.ebuild,
+ portage-2.1.1_pre2-r4.ebuild:
+ replace einfo with elog
*portage-2.1.1_pre2-r4 (05 Jul 2006)
diff --git a/sys-apps/portage/portage-2.0.51.22-r3.ebuild b/sys-apps/portage/portage-2.0.51.22-r3.ebuild
index 3adbff99fde4..163ae4fa4864 100644
--- a/sys-apps/portage/portage-2.0.51.22-r3.ebuild
+++ b/sys-apps/portage/portage-2.0.51.22-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51.22-r3.ebuild,v 1.5 2006/02/02 11:36:30 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51.22-r3.ebuild,v 1.6 2006/07/06 23:15:23 genone Exp $
inherit toolchain-funcs
@@ -136,11 +136,11 @@ pkg_postinst() {
fi
echo
- einfo "Feature additions are noted in help and make.conf descriptions."
+ elog "Feature additions are noted in help and make.conf descriptions."
echo
- einfo "Update configs using 'etc-update' please. Maintaining current configs"
- einfo "for portage and other system packages is fairly important for the"
- einfo "continued health of your system."
+ elog "Update configs using 'etc-update' please. Maintaining current configs"
+ elog "for portage and other system packages is fairly important for the"
+ elog "continued health of your system."
echo
ewarn "NOTICE: There have been changes in the location of some internal files"
ewarn " to better match the FHS. The changes do not directly affect users"
@@ -148,11 +148,11 @@ pkg_postinst() {
ewarn " with and without these changes may introduce some inconsistencies"
ewarn " in package data regarding 'world' and 'virtuals' (provides)."
echo
- einfo " /var/cache/edb/world has moved to /var/lib/portage/world"
+ elog " /var/cache/edb/world has moved to /var/lib/portage/world"
echo
- einfo " /var/cache/edb/virtuals has been deprecated and is now calculated"
- einfo " on demand. Strictly _USER_ modifications to virtuals may go into"
- einfo " /etc/portage/profile/virtuals and will not be modified by portage."
+ elog " /var/cache/edb/virtuals has been deprecated and is now calculated"
+ elog " on demand. Strictly _USER_ modifications to virtuals may go into"
+ elog " /etc/portage/profile/virtuals and will not be modified by portage."
echo
for X in ${ROOT}etc/._cfg????_make.globals; do
@@ -160,8 +160,8 @@ pkg_postinst() {
[ -e "${X}" ] && mv -f "${X}" "${ROOT}etc/make.globals"
done
- einfo "You may run 'emerge metadata' to perform cache updates if you have"
- einfo "changed versions of portage. This will provide a fairly dramatic"
- einfo "speedup. Alternatively, you may 'emerge sync' if it has been more"
- einfo "than 30 minutes since your last sync."
+ elog "You may run 'emerge metadata' to perform cache updates if you have"
+ elog "changed versions of portage. This will provide a fairly dramatic"
+ elog "speedup. Alternatively, you may 'emerge sync' if it has been more"
+ elog "than 30 minutes since your last sync."
}
diff --git a/sys-apps/portage/portage-2.0.54-r2.ebuild b/sys-apps/portage/portage-2.0.54-r2.ebuild
index 67f77317ba1c..b28748456ee5 100644
--- a/sys-apps/portage/portage-2.0.54-r2.ebuild
+++ b/sys-apps/portage/portage-2.0.54-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.54-r2.ebuild,v 1.12 2006/05/29 17:35:45 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.54-r2.ebuild,v 1.13 2006/07/06 23:15:23 genone Exp $
inherit toolchain-funcs eutils
@@ -21,10 +21,10 @@ PROVIDE="virtual/portage"
S=${WORKDIR}/${PN}-${PV}
portage_docs() {
- einfo ""
- einfo "For help with using portage please consult the Gentoo Handbook"
- einfo "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
- einfo ""
+ elog ""
+ elog "For help with using portage please consult the Gentoo Handbook"
+ elog "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
+ elog ""
}
src_unpack() {
@@ -35,7 +35,7 @@ src_unpack() {
done
if [ "${PR}" != "r0" ]; then
- einfo "Setting portage.VERSION to ${PVR} ..."
+ elog "Setting portage.VERSION to ${PVR} ..."
sed -i "s/^VERSION=.*/VERSION=\"${PVR}\"/" pym/portage.py || \
die "Failed to patch portage.VERSION"
fi
diff --git a/sys-apps/portage/portage-2.1-r1.ebuild b/sys-apps/portage/portage-2.1-r1.ebuild
index f47d6597eccb..721acd20bd30 100644
--- a/sys-apps/portage/portage-2.1-r1.ebuild
+++ b/sys-apps/portage/portage-2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1-r1.ebuild,v 1.11 2006/07/02 20:30:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1-r1.ebuild,v 1.12 2006/07/06 23:15:23 genone Exp $
inherit toolchain-funcs eutils
@@ -48,10 +48,10 @@ S="${WORKDIR}"/${PN}-${PV}
S_PL="${WORKDIR}"/${PN}-${PV_PL}
portage_docs() {
- einfo ""
- einfo "For help with using portage please consult the Gentoo Handbook"
- einfo "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
- einfo ""
+ elog ""
+ elog "For help with using portage please consult the Gentoo Handbook"
+ elog "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
+ elog ""
}
src_unpack() {
@@ -61,7 +61,7 @@ src_unpack() {
epatch "${WORKDIR}/${PN}-${PV}${PATCHVER}.patch"
use linguas_pl && \
epatch "${WORKDIR}/${PN}-man-pl-${PV_PL}${PATCHVER_PL}.patch"
- einfo "Setting portage.VERSION to ${PVR} ..."
+ elog "Setting portage.VERSION to ${PVR} ..."
sed -i "s/^VERSION=.*/VERSION=\"${PVR}\"/" pym/portage.py || \
die "Failed to patch portage.VERSION"
eend 0
@@ -191,35 +191,35 @@ pkg_postinst() {
ewarn "the CDB cache module), portage will not work until they have"
ewarn "been disabled via /etc/portage/modules."
echo
- einfo "The default cache format has changed between 2.0.x and 2.1"
- einfo "versions. If you have upgraded from 2.0.x, before using"
- einfo "emerge, run \`emerge --metadata\` to restore portage's local"
- einfo "cache."
+ elog "The default cache format has changed between 2.0.x and 2.1"
+ elog "versions. If you have upgraded from 2.0.x, before using"
+ elog "emerge, run \`emerge --metadata\` to restore portage's local"
+ elog "cache."
echo
- einfo "With the new metadata_overlay cache module, it is possible to"
- einfo "disable FEATURES=\"metadata-transfer\" (see make.conf.5)."
- einfo "When this module is used, eclasses in \${PORTDIR} must never"
- einfo "be modified by the user because portage will not be able to"
- einfo "detect that cache regeneration is necessary."
- einfo "When metadata_overlay is initially enabled by setting"
- einfo "portdbapi.auxdbmodule = cache.metadata_overlay.database"
- einfo "in /etc/portage/modules, the user must completely remove"
- einfo "/var/cache/edb/dep/\${PORTDIR} in order to avoid unecessary"
- einfo "cache regeneration."
+ elog "With the new metadata_overlay cache module, it is possible to"
+ elog "disable FEATURES=\"metadata-transfer\" (see make.conf.5)."
+ elog "When this module is used, eclasses in \${PORTDIR} must never"
+ elog "be modified by the user because portage will not be able to"
+ elog "detect that cache regeneration is necessary."
+ elog "When metadata_overlay is initially enabled by setting"
+ elog "portdbapi.auxdbmodule = cache.metadata_overlay.database"
+ elog "in /etc/portage/modules, the user must completely remove"
+ elog "/var/cache/edb/dep/\${PORTDIR} in order to avoid unecessary"
+ elog "cache regeneration."
echo
- einfo "Flag ordering has changed for \`emerge --pretend --verbose\`."
- einfo "Add EMERGE_DEFAULT_OPTS=\"--alphabetical\" to /etc/make.conf"
- einfo "to restore the previous ordering."
+ elog "Flag ordering has changed for \`emerge --pretend --verbose\`."
+ elog "Add EMERGE_DEFAULT_OPTS=\"--alphabetical\" to /etc/make.conf"
+ elog "to restore the previous ordering."
echo
- einfo "The default USE_ORDER setting (see make.conf.5) has changed in"
- einfo "2.1 so that auto USE flags (from use.defaults) are no longer"
- einfo "enabled. In order to find out which flags have been disabled,"
- einfo "the command \`env USE_ORDER=auto portageq envvar USE\` may be"
- einfo "helpful. These flags can be manually added to make.conf by the"
- einfo "user (the command output may contain a few other automatically"
- einfo "generated flags that do not need to be added to make.conf)."
+ elog "The default USE_ORDER setting (see make.conf.5) has changed in"
+ elog "2.1 so that auto USE flags (from use.defaults) are no longer"
+ elog "enabled. In order to find out which flags have been disabled,"
+ elog "the command \`env USE_ORDER=auto portageq envvar USE\` may be"
+ elog "helpful. These flags can be manually added to make.conf by the"
+ elog "user (the command output may contain a few other automatically"
+ elog "generated flags that do not need to be added to make.conf)."
echo
- einfo "See NEWS and RELEASE-NOTES for further changes."
+ elog "See NEWS and RELEASE-NOTES for further changes."
portage_docs
}
diff --git a/sys-apps/portage/portage-2.1.1_pre1-r5.ebuild b/sys-apps/portage/portage-2.1.1_pre1-r5.ebuild
index 98849a37e465..4748b4cd2811 100644
--- a/sys-apps/portage/portage-2.1.1_pre1-r5.ebuild
+++ b/sys-apps/portage/portage-2.1.1_pre1-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.1_pre1-r5.ebuild,v 1.1 2006/06/27 20:44:16 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.1_pre1-r5.ebuild,v 1.2 2006/07/06 23:15:23 genone Exp $
inherit toolchain-funcs eutils
@@ -47,10 +47,10 @@ S="${WORKDIR}"/${PN}-${PV}
S_PL="${WORKDIR}"/${PN}-${PV_PL}
portage_docs() {
- einfo ""
- einfo "For help with using portage please consult the Gentoo Handbook"
- einfo "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
- einfo ""
+ elog ""
+ elog "For help with using portage please consult the Gentoo Handbook"
+ elog "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
+ elog ""
}
src_unpack() {
@@ -61,7 +61,7 @@ src_unpack() {
epatch "${FILESDIR}/bugs_138246_138259.patch"
use linguas_pl && \
epatch "${WORKDIR}/${PN}-man-pl-${PV_PL}${PATCHVER_PL}.patch"
- einfo "Setting portage.VERSION to ${PVR} ..."
+ elog "Setting portage.VERSION to ${PVR} ..."
sed -i "s/^VERSION=.*/VERSION=\"${PVR}\"/" pym/portage.py || \
die "Failed to patch portage.VERSION"
eend 0
diff --git a/sys-apps/portage/portage-2.1.1_pre2-r2.ebuild b/sys-apps/portage/portage-2.1.1_pre2-r2.ebuild
index 079a52136918..f02a266462e8 100644
--- a/sys-apps/portage/portage-2.1.1_pre2-r2.ebuild
+++ b/sys-apps/portage/portage-2.1.1_pre2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.1_pre2-r2.ebuild,v 1.1 2006/07/03 03:39:45 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.1_pre2-r2.ebuild,v 1.2 2006/07/06 23:15:23 genone Exp $
inherit toolchain-funcs eutils
@@ -51,10 +51,10 @@ S="${WORKDIR}"/${PN}-${PV}
S_PL="${WORKDIR}"/${PN}-${PV_PL}
portage_docs() {
- einfo ""
- einfo "For help with using portage please consult the Gentoo Handbook"
- einfo "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
- einfo ""
+ elog ""
+ elog "For help with using portage please consult the Gentoo Handbook"
+ elog "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
+ elog ""
}
src_unpack() {
@@ -65,7 +65,7 @@ src_unpack() {
epatch "${WORKDIR}/${PN}-${PV}${PATCHVER}.patch"
fi
if [ "${PR}" != "r0" ]; then
- einfo "Setting portage.VERSION to ${PVR} ..."
+ elog "Setting portage.VERSION to ${PVR} ..."
sed -i "s/^VERSION=.*/VERSION=\"${PVR}\"/" pym/portage.py || \
die "Failed to patch portage.VERSION"
eend 0
diff --git a/sys-apps/portage/portage-2.1.1_pre2-r4.ebuild b/sys-apps/portage/portage-2.1.1_pre2-r4.ebuild
index 950154773e34..0cdaa5e896fb 100644
--- a/sys-apps/portage/portage-2.1.1_pre2-r4.ebuild
+++ b/sys-apps/portage/portage-2.1.1_pre2-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.1_pre2-r4.ebuild,v 1.1 2006/07/05 18:58:57 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.1_pre2-r4.ebuild,v 1.2 2006/07/06 23:15:23 genone Exp $
inherit toolchain-funcs eutils
@@ -51,10 +51,10 @@ S="${WORKDIR}"/${PN}-${PV}
S_PL="${WORKDIR}"/${PN}-${PV_PL}
portage_docs() {
- einfo ""
- einfo "For help with using portage please consult the Gentoo Handbook"
- einfo "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
- einfo ""
+ elog ""
+ elog "For help with using portage please consult the Gentoo Handbook"
+ elog "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
+ elog ""
}
src_unpack() {
@@ -67,7 +67,7 @@ src_unpack() {
epatch "${FILESDIR}/bug_132601.patch"
epatch "${FILESDIR}/bug_132601-2.patch"
if [ "${PR}" != "r0" ]; then
- einfo "Setting portage.VERSION to ${PVR} ..."
+ elog "Setting portage.VERSION to ${PVR} ..."
sed -i "s/^VERSION=.*/VERSION=\"${PVR}\"/" pym/portage.py || \
die "Failed to patch portage.VERSION"
eend 0
diff --git a/sys-apps/portage/portage-2.1.ebuild b/sys-apps/portage/portage-2.1.ebuild
index 1b496e563de5..54a59af89678 100644
--- a/sys-apps/portage/portage-2.1.ebuild
+++ b/sys-apps/portage/portage-2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.ebuild,v 1.9 2006/06/20 22:18:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.ebuild,v 1.10 2006/07/06 23:15:23 genone Exp $
inherit toolchain-funcs eutils
@@ -44,10 +44,10 @@ S="${WORKDIR}"/${PN}-${PV}
S_PL="${WORKDIR}"/${PN}-${PV_PL}
portage_docs() {
- einfo ""
- einfo "For help with using portage please consult the Gentoo Handbook"
- einfo "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
- einfo ""
+ elog ""
+ elog "For help with using portage please consult the Gentoo Handbook"
+ elog "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
+ elog ""
}
src_unpack() {
@@ -55,7 +55,7 @@ src_unpack() {
if [ "${PR}" != "r0" ]; then
cd "${S}"
epatch "${WORKDIR}/${PN}-${PV}${PATCHVER}.patch"
- einfo "Setting portage.VERSION to ${PVR} ..."
+ elog "Setting portage.VERSION to ${PVR} ..."
sed -i "s/^VERSION=.*/VERSION=\"${PVR}\"/" pym/portage.py || \
die "Failed to patch portage.VERSION"
eend 0
@@ -185,35 +185,35 @@ pkg_postinst() {
ewarn "the CDB cache module), portage will not work until they have"
ewarn "been disabled via /etc/portage/modules."
echo
- einfo "The default cache format has changed between 2.0.x and 2.1"
- einfo "versions. If you have upgraded from 2.0.x, before using"
- einfo "emerge, run \`emerge --metadata\` to restore portage's local"
- einfo "cache."
+ elog "The default cache format has changed between 2.0.x and 2.1"
+ elog "versions. If you have upgraded from 2.0.x, before using"
+ elog "emerge, run \`emerge --metadata\` to restore portage's local"
+ elog "cache."
echo
- einfo "With the new metadata_overlay cache module, it is possible to"
- einfo "disable FEATURES=\"metadata-transfer\" (see make.conf.5)."
- einfo "When this module is used, eclasses in \${PORTDIR} must never"
- einfo "be modified by the user because portage will not be able to"
- einfo "detect that cache regeneration is necessary."
- einfo "When metadata_overlay is initially enabled by setting"
- einfo "portdbapi.auxdbmodule = cache.metadata_overlay.database"
- einfo "in /etc/portage/modules, the user must completely remove"
- einfo "/var/cache/edb/dep/\${PORTDIR} in order to avoid unecessary"
- einfo "cache regeneration."
+ elog "With the new metadata_overlay cache module, it is possible to"
+ elog "disable FEATURES=\"metadata-transfer\" (see make.conf.5)."
+ elog "When this module is used, eclasses in \${PORTDIR} must never"
+ elog "be modified by the user because portage will not be able to"
+ elog "detect that cache regeneration is necessary."
+ elog "When metadata_overlay is initially enabled by setting"
+ elog "portdbapi.auxdbmodule = cache.metadata_overlay.database"
+ elog "in /etc/portage/modules, the user must completely remove"
+ elog "/var/cache/edb/dep/\${PORTDIR} in order to avoid unecessary"
+ elog "cache regeneration."
echo
- einfo "Flag ordering has changed for \`emerge --pretend --verbose\`."
- einfo "Add EMERGE_DEFAULT_OPTS=\"--alphabetical\" to /etc/make.conf"
- einfo "to restore the previous ordering."
+ elog "Flag ordering has changed for \`emerge --pretend --verbose\`."
+ elog "Add EMERGE_DEFAULT_OPTS=\"--alphabetical\" to /etc/make.conf"
+ elog "to restore the previous ordering."
echo
- einfo "The default USE_ORDER setting (see make.conf.5) has changed in"
- einfo "2.1 so that auto USE flags (from use.defaults) are no longer"
- einfo "enabled. In order to find out which flags have been disabled,"
- einfo "the command \`env USE_ORDER=auto portageq envvar USE\` may be"
- einfo "helpful. These flags can be manually added to make.conf by the"
- einfo "user (the command output may contain a few other automatically"
- einfo "generated flags that do not need to be added to make.conf)."
+ elog "The default USE_ORDER setting (see make.conf.5) has changed in"
+ elog "2.1 so that auto USE flags (from use.defaults) are no longer"
+ elog "enabled. In order to find out which flags have been disabled,"
+ elog "the command \`env USE_ORDER=auto portageq envvar USE\` may be"
+ elog "helpful. These flags can be manually added to make.conf by the"
+ elog "user (the command output may contain a few other automatically"
+ elog "generated flags that do not need to be added to make.conf)."
echo
- einfo "See NEWS and RELEASE-NOTES for further changes."
+ elog "See NEWS and RELEASE-NOTES for further changes."
portage_docs
}