summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-13 05:21:25 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-13 05:21:25 +0000
commitb8ed7c1cf65a0eee779fc3531612b063bc8f85cb (patch)
treee8e00a2361a5f9a7460da858e82e876c459dd242 /sys-apps/xmbmon
parentold (diff)
downloadgentoo-2-b8ed7c1cf65a0eee779fc3531612b063bc8f85cb.tar.gz
gentoo-2-b8ed7c1cf65a0eee779fc3531612b063bc8f85cb.tar.bz2
gentoo-2-b8ed7c1cf65a0eee779fc3531612b063bc8f85cb.zip
fowners fix #38041
Diffstat (limited to 'sys-apps/xmbmon')
-rw-r--r--sys-apps/xmbmon/xmbmon-2.0.3.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/sys-apps/xmbmon/xmbmon-2.0.3.ebuild b/sys-apps/xmbmon/xmbmon-2.0.3.ebuild
index be26ff86c8f1..6f21467b687e 100644
--- a/sys-apps/xmbmon/xmbmon-2.0.3.ebuild
+++ b/sys-apps/xmbmon/xmbmon-2.0.3.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xmbmon/xmbmon-2.0.3.ebuild,v 1.2 2003/09/07 00:34:58 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xmbmon/xmbmon-2.0.3.ebuild,v 1.3 2004/01/13 05:21:25 vapier Exp $
MY_P="${PN}${PV//.}"
DESCRIPTION="Mother Board Monitor Program for X Window System"
HOMEPAGE="http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/download.html"
SRC_URI="http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/${MY_P}.tar.gz"
+
LICENSE="freedist"
SLOT="0"
KEYWORDS="x86 amd64"
@@ -13,29 +14,26 @@ IUSE="X"
DEPEND="virtual/glibc
X? ( virtual/x11 )"
-RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
src_compile() {
-
econf || die "Configure failed"
emake CFLAGS="$CFLAGS \$(INCLUDES) \$(DEFS)" mbmon || die "Make mbmon failed"
- if use X; then
+ if [ `use X` ] ; then
emake CFLAGSX="$CFLAGS \$(INCLUDES) \$(DEFS)" xmbmon || die "Make xmbmon failed"
fi
}
src_install() {
-
dosbin mbmon
fperms 4555 /usr/sbin/mbmon
- fowners root.wheel /usr/sbin/mbmon
+ fowners root:wheel /usr/sbin/mbmon
- if use X; then
+ if [ `use X` ] ; then
dosbin xmbmon
fperms 4555 /usr/sbin/xmbmon
- fowners root.wheel /usr/sbin/xmbmon
+ fowners root:wheel /usr/sbin/xmbmon
fi
dodoc 00README*