summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-27 01:49:25 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-27 01:49:25 +0000
commit7611bbf4486c6fb9f63e4408e50e3e869bef1e20 (patch)
treef1fbdb4c44189ccab1adb15f752d58577fa85526 /sys-apps/xinetd
parentFixed svc-run for the new version (diff)
downloadgentoo-2-7611bbf4486c6fb9f63e4408e50e3e869bef1e20.tar.gz
gentoo-2-7611bbf4486c6fb9f63e4408e50e3e869bef1e20.tar.bz2
gentoo-2-7611bbf4486c6fb9f63e4408e50e3e869bef1e20.zip
Removed /**/ comments
Diffstat (limited to 'sys-apps/xinetd')
-rwxr-xr-xsys-apps/xinetd/files/xconv.pl111
-rw-r--r--sys-apps/xinetd/xinetd-2.1.8.9_pre16.ebuild6
2 files changed, 115 insertions, 2 deletions
diff --git a/sys-apps/xinetd/files/xconv.pl b/sys-apps/xinetd/files/xconv.pl
new file mode 100755
index 000000000000..04745d72f713
--- /dev/null
+++ b/sys-apps/xinetd/files/xconv.pl
@@ -0,0 +1,111 @@
+#!/usr/bin/perl
+
+# $RCSid = "$Id: xconv.pl,v 1.1 2001/06/27 01:49:25 achim Exp $";
+
+sub print_header;
+sub print_defaults;
+
+
+print_header;
+print_defaults;
+
+while( <STDIN> ) {
+
+ chomp;
+
+ # Remove comment lines
+ if( grep /^#/, $_ ) {
+ next;
+ }
+
+ @command = split ;
+
+ if( !defined $command[0] ) {
+ next;
+ }
+
+ if( grep /rpc/, $command[2] ) {
+ print STDERR "Warning: Service $command[0] not added because\n";
+ print STDERR "xinetd does not handle rpc services well\n";
+ next;
+ }
+
+ print "service $command[0]\n";
+ print "{\n";
+ print "\tflags = REUSE NAMEINARGS\n";
+ print "\tsocket_type = $command[1]\n";
+ print "\tprotocol = $command[2]\n";
+ if( grep /no/, $command[3] ) {
+ print "\twait = no\n";
+ } else {
+ print "\twait = yes\n";
+ }
+ @user = split /\./, $command[4];
+ print "\tuser = $user[0]\n";
+ if( defined $user[1] ) {
+ print "\tgroup = $user[1]\n";
+ }
+ if( grep /internal/, $command[5] ) {
+ print "\ttype = INTERNAL\n";
+ print "\tid = $command[0]-$command[1]\n";
+ } else {
+ print "\tserver = $command[5]\n";
+ print "\tserver_args = ";
+
+ $i = 6;
+ while( defined $command[$i] ) {
+ print "$command[$i] ";
+ $i++;
+ }
+
+ print "\n";
+ }
+ print "}\n";
+ print "\n";
+}
+
+sub print_defaults
+{
+ print "# The defaults section sets some information for all services\n";
+ print "defaults\n";
+ print "{\n";
+ print "\t#The maximum number of requests a particular service may handle\n";
+ print "\t# at once.\n";
+ print "\tinstances = 25\n";
+ print "\n";
+ print "\t# The type of logging. This logs to a file that is specified.\n";
+ print "\t# Another option is: SYSLOG syslog_facility [syslog_level]\n";
+ print "\tlog_type = FILE /var/log/servicelog\n";
+ print "\n";
+ print "\t# What to log when the connection succeeds.\n";
+ print "\t# PID logs the pid of the server processing the request.\n";
+ print "\t# HOST logs the remote host's ip address.\n";
+ print "\t# USERID logs the remote user (using RFC 1413)\n";
+ print "\t# EXIT logs the exit status of the server.\n";
+ print "\t# DURATION logs the duration of the session.\n";
+ print "\tlog_on_success = HOST PID\n";
+ print "\n";
+ print "\t# What to log when the connection fails. Same options as above\n";
+ print "\tlog_on_failure = HOST RECORD\n";
+ print "\n";
+ print "\t# The maximum number of connections a specific IP address can\n";
+ print "\t# have to a specific service. \n";
+ print "\tper_source = 5\n";
+
+ print "}\n";
+ print "\n";
+}
+
+sub print_header
+{
+ print "# This file generated by xconv.pl, included with the xinetd\n";
+ print "# package. xconv.pl was written by Rob Braun (bbraun\@synack.net)\n";
+ print "#\n";
+ print "# The file is merely a translation of your inetd.conf file into\n";
+ print "# the equivalent in xinetd.conf syntax. xinetd has many \n";
+ print "# features that may not be taken advantage of with this translation.\n";
+ print "# Please refer to the xinetd.conf man page for more information \n";
+ print "# on how to properly configure xinetd.\n";
+ print "\n";
+ print "\n";
+}
diff --git a/sys-apps/xinetd/xinetd-2.1.8.9_pre16.ebuild b/sys-apps/xinetd/xinetd-2.1.8.9_pre16.ebuild
index 3b545e1f6684..71012f9f439a 100644
--- a/sys-apps/xinetd/xinetd-2.1.8.9_pre16.ebuild
+++ b/sys-apps/xinetd/xinetd-2.1.8.9_pre16.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.1.8.9_pre16.ebuild,v 1.1 2001/06/21 14:16:26 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.1.8.9_pre16.ebuild,v 1.2 2001/06/27 01:49:25 achim Exp $
P=${PN}-2.1.8.9pre16
A=${P}.tar.gz
@@ -37,7 +37,9 @@ src_install() {
insinto /etc
#doins ${FILESDIR}/xinetd.conf
exeinto /var/lib/supervise/services/xinetd
- newexe ${FILESDIR}/xinetd-run run
+ newexe ${FILESDIR}/xinetd-run-${PV} run
+ exeinto /usr/sbin
+ doexe ${FILESDIR}/xconv.pl
}