summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-11-17 08:37:49 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-11-17 08:37:49 +0000
commitf71cafaf40529e8b9b31a8e96f4a8a746f8013b9 (patch)
tree2af0e4340fcaf2050be75d2dddf25735aa11a5e9 /sys-apps/xfsdump
parentlots of new xfs stuff (diff)
downloadgentoo-2-f71cafaf40529e8b9b31a8e96f4a8a746f8013b9.tar.gz
gentoo-2-f71cafaf40529e8b9b31a8e96f4a8a746f8013b9.tar.bz2
gentoo-2-f71cafaf40529e8b9b31a8e96f4a8a746f8013b9.zip
xfsdump!
Diffstat (limited to 'sys-apps/xfsdump')
-rw-r--r--sys-apps/xfsdump/xfsdump-1.1.7.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-apps/xfsdump/xfsdump-1.1.7.ebuild b/sys-apps/xfsdump/xfsdump-1.1.7.ebuild
new file mode 100644
index 000000000000..1d20d9579f4b
--- /dev/null
+++ b/sys-apps/xfsdump/xfsdump-1.1.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsdump/xfsdump-1.1.7.ebuild,v 1.1 2001/11/17 08:37:49 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="xfs dump/restore utilities"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/latest/cmd_tars/${P}.src.tar.gz"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make sys-apps/e2fsprogs sys-apps/xfsprogs sys-apps/dmapi sys-apps/attr"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ # 4) we fix some Makefile-created library symlinks that contains absolute paths
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" -e 's:-O1::' -e 's:-S \(.*\) $(PKG_.*_DIR)/\(.*$\):-S \1 \2:' include/builddefs.orig > include/builddefs || die
+ # 5) We now fix some absolute path symlinks in various makefiles
+ local x
+ for x in dump restore
+ do
+ cp ${x}/Makefile ${x}/Makefile.orig
+ sed -e 's:$(INSTALL) -S $(PKG_.*_DIR)/\(.*\) \(.*/.*\):$(INSTALL) -S ../../sbin/\1 \2:' ${x}/Makefile.orig > ${x}/Makefile
+ done
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}