summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-19 04:06:04 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-19 04:06:04 +0000
commit19cb0f71bda03839bbc446854a3d0781e42aa83c (patch)
tree335792d0d70f21ee49b3f24962bbd47823a6c047 /sys-apps/thinkpad
parentsymlink fixes (diff)
downloadgentoo-2-19cb0f71bda03839bbc446854a3d0781e42aa83c.tar.gz
gentoo-2-19cb0f71bda03839bbc446854a3d0781e42aa83c.tar.bz2
gentoo-2-19cb0f71bda03839bbc446854a3d0781e42aa83c.zip
lintool fixes for #9258
Diffstat (limited to 'sys-apps/thinkpad')
-rw-r--r--sys-apps/thinkpad/thinkpad-3.2.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/sys-apps/thinkpad/thinkpad-3.2.ebuild b/sys-apps/thinkpad/thinkpad-3.2.ebuild
index ab762aa83ed9..0dfe2e73e87f 100644
--- a/sys-apps/thinkpad/thinkpad-3.2.ebuild
+++ b/sys-apps/thinkpad/thinkpad-3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/thinkpad-3.2.ebuild,v 1.7 2002/10/04 06:31:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/thinkpad-3.2.ebuild,v 1.8 2002/10/19 04:06:04 vapier Exp $
#transform P to match tarball versioning
MYPV=${PV/_beta/beta}
@@ -15,6 +15,7 @@ LICENSE="GPL-2"
#virtual/glibc should depend on specific kernel headers
DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
pkg_setup() {
#thinkpad will compile modules for the kernel pointed to by /usr/src/linux
@@ -29,14 +30,11 @@ pkg_setup() {
fi
}
-src_compile () {
-
+src_compile() {
emake || die "Make failed"
-
}
-src_install () {
-
+src_install() {
dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TECHNOTES
dodir /lib/modules/${KV}/thinkpad
cp ${S}/drivers/{thinkpad,smapi,superio,rtcmosram,thinkpadpm}.o \
@@ -48,10 +46,10 @@ src_install () {
> ${D}/etc/devfsd.conf
}
-pkg_postinst () {
+pkg_postinst() {
/usr/sbin/update-modules || return 0
}
-pkg_prerm () {
+pkg_prerm() {
/sbin/modprobe -r smapi superion rtcmosram thinkpadpm thinkpad
}