summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2014-04-03 17:53:21 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2014-04-03 17:53:21 +0000
commit0224b8984ef7e2be042d374fb5fabcd85a34a637 (patch)
treed7a318383f1d86d8a3b4100df35280b30c1aedce /sys-apps/sg3_utils
parentAdd python3_4 support. (diff)
downloadgentoo-2-0224b8984ef7e2be042d374fb5fabcd85a34a637.tar.gz
gentoo-2-0224b8984ef7e2be042d374fb5fabcd85a34a637.tar.bz2
gentoo-2-0224b8984ef7e2be042d374fb5fabcd85a34a637.zip
Bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-apps/sg3_utils')
-rw-r--r--sys-apps/sg3_utils/ChangeLog7
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.38.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-apps/sg3_utils/ChangeLog b/sys-apps/sg3_utils/ChangeLog
index f433fc7ed7c0..54cfa0f09eb4 100644
--- a/sys-apps/sg3_utils/ChangeLog
+++ b/sys-apps/sg3_utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sg3_utils
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.117 2014/01/26 12:19:06 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.118 2014/04/03 17:53:21 robbat2 Exp $
+
+*sg3_utils-1.38 (03 Apr 2014)
+
+ 03 Apr 2014; Robin H. Johnson <robbat2@gentoo.org> +sg3_utils-1.38.ebuild:
+ Bump.
26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> sg3_utils-1.37.ebuild:
Stable for sparc, wrt bug #495932
diff --git a/sys-apps/sg3_utils/sg3_utils-1.38.ebuild b/sys-apps/sg3_utils/sg3_utils-1.38.ebuild
new file mode 100644
index 000000000000..8fe7a3238fa4
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.38.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/sg3_utils-1.38.ebuild,v 1.1 2014/04/03 17:53:21 robbat2 Exp $
+
+EAPI="4"
+
+inherit eutils multilib
+
+DESCRIPTION="Apps for querying the sg SCSI interface"
+HOMEPAGE="http://sg.danny.cz/sg/"
+SRC_URI="http://sg.danny.cz/sg/p/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="sys-devel/libtool"
+RDEPEND=""
+PDEPEND=">=sys-apps/rescan-scsi-bus-1.24"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.26-stdint.patch
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodoc COVERAGE doc/README examples/*.txt
+ newdoc scripts/README README.scripts
+ dosbin scripts/scsi*
+
+ # Better fix for bug 231089; some packages look for sgutils2
+ local path lib
+ path="/usr/$(get_libdir)"
+ for lib in "${ED}"/usr/$(get_libdir)/libsgutils2.*; do
+ lib=${lib##*/}
+ dosym "${lib}" "${path}/${lib/libsgutils2/libsgutils}"
+ done
+
+ prune_libtool_files
+}