summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-01-08 09:34:16 +0000
committerMike Frysinger <vapier@gentoo.org>2007-01-08 09:34:16 +0000
commitb40969b2cb0d8f66cadc956c40fb996d9551abea (patch)
treeb719cac6ce58f469f3dbee24a3b026bcbb14db5d /sys-apps/rlocate
parentforgot to apply the year 2007 patch (diff)
downloadgentoo-2-b40969b2cb0d8f66cadc956c40fb996d9551abea.tar.gz
gentoo-2-b40969b2cb0d8f66cadc956c40fb996d9551abea.tar.bz2
gentoo-2-b40969b2cb0d8f66cadc956c40fb996d9551abea.zip
Version bump.
(Portage version: 2.1.2_rc4-r6)
Diffstat (limited to 'sys-apps/rlocate')
-rw-r--r--sys-apps/rlocate/ChangeLog9
-rw-r--r--sys-apps/rlocate/files/digest-rlocate-0.5.53
-rw-r--r--sys-apps/rlocate/rlocate-0.5.5.ebuild48
3 files changed, 58 insertions, 2 deletions
diff --git a/sys-apps/rlocate/ChangeLog b/sys-apps/rlocate/ChangeLog
index 32f0731941a9..8d15cd04c3e9 100644
--- a/sys-apps/rlocate/ChangeLog
+++ b/sys-apps/rlocate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/rlocate
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.21 2006/12/21 04:42:10 vapier Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.22 2007/01/08 09:34:16 vapier Exp $
+
+*rlocate-0.5.5 (08 Jan 2007)
+
+ 08 Jan 2007; Mike Frysinger <vapier@gentoo.org> +rlocate-0.5.5.ebuild:
+ Version bump.
*rlocate-0.5.4 (21 Dec 2006)
diff --git a/sys-apps/rlocate/files/digest-rlocate-0.5.5 b/sys-apps/rlocate/files/digest-rlocate-0.5.5
new file mode 100644
index 000000000000..61c4af36d827
--- /dev/null
+++ b/sys-apps/rlocate/files/digest-rlocate-0.5.5
@@ -0,0 +1,3 @@
+MD5 18a92b443575e15811b42db261393050 rlocate-0.5.5.tar.gz 182210
+RMD160 97d38504bf25d2230485b544216de7dd18e950bb rlocate-0.5.5.tar.gz 182210
+SHA256 30af224698a300a54808f74b3186b993d765e9be2cbf1c79c5779596eb2c604b rlocate-0.5.5.tar.gz 182210
diff --git a/sys-apps/rlocate/rlocate-0.5.5.ebuild b/sys-apps/rlocate/rlocate-0.5.5.ebuild
new file mode 100644
index 000000000000..1027ad406614
--- /dev/null
+++ b/sys-apps/rlocate/rlocate-0.5.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/rlocate-0.5.5.ebuild,v 1.1 2007/01/08 09:34:16 vapier Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="locate implementation that is always up-to-date"
+HOMEPAGE="http://rlocate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rlocate/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/slocate"
+
+pkg_setup() {
+ MODULE_NAMES="rlocate(misc:${S}/src/rlocate-module)"
+ CONFIG_CHECK="SECURITY"
+ SECURITY_ERROR="You need to select the \"Enable different security models\" option in the kernel configuration (CONFIG_SECURITY)."
+ BUILD_TARGETS="all"
+ linux-mod_pkg_setup
+
+ enewgroup locate
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.5.3-build.patch
+}
+
+src_compile() {
+ econf \
+ --with-kernel=${KV_DIR} \
+ --with-rlocate-group=locate \
+ || die
+ emake || die
+ linux-mod_src_compile
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ newinitd "${FILESDIR}"/rlocated.rc rlocated
+ linux-mod_src_install
+ dodoc AUTHORS ChangeLog* NEWS README
+}