summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Klimaszewski <steev@gentoo.org>2006-12-11 02:57:08 +0000
committerStephen Klimaszewski <steev@gentoo.org>2006-12-11 02:57:08 +0000
commitd93b14a0bd86e538143ab463424b96455f8ca22c (patch)
treeacff99497a9e9c7ce00bd6986199423aca63042b /sys-apps/pmount
parentmake boo compile option more pretty. (diff)
downloadgentoo-2-d93b14a0bd86e538143ab463424b96455f8ca22c.tar.gz
gentoo-2-d93b14a0bd86e538143ab463424b96455f8ca22c.tar.bz2
gentoo-2-d93b14a0bd86e538143ab463424b96455f8ca22c.zip
Added patch to fix pmount-hal, fixes bug #157456.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'sys-apps/pmount')
-rw-r--r--sys-apps/pmount/ChangeLog7
-rw-r--r--sys-apps/pmount/files/pmount-0.9.13-no_close.patch11
-rw-r--r--sys-apps/pmount/pmount-0.9.13.ebuild4
3 files changed, 19 insertions, 3 deletions
diff --git a/sys-apps/pmount/ChangeLog b/sys-apps/pmount/ChangeLog
index 17afe344a0b0..41c050f0e5e4 100644
--- a/sys-apps/pmount/ChangeLog
+++ b/sys-apps/pmount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pmount
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.35 2006/10/31 01:11:26 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.36 2006/12/11 02:57:08 steev Exp $
+
+ 11 Dec 2006; Steev Klimaszewski <steev@gentoo.org>
+ +files/pmount-0.9.13-no_close.patch, pmount-0.9.13.ebuild:
+ Add a patch to remove dbus_connection_close. This fixes bug #157456. Thanks
+ to Dustin C. Hatch for reporting.
31 Oct 2006; Doug Goldstein <cardoe@gentoo.org> pmount-0.9.9.ebuild,
pmount-0.9.11.ebuild, pmount-0.9.13.ebuild:
diff --git a/sys-apps/pmount/files/pmount-0.9.13-no_close.patch b/sys-apps/pmount/files/pmount-0.9.13-no_close.patch
new file mode 100644
index 000000000000..e03a7b375432
--- /dev/null
+++ b/sys-apps/pmount/files/pmount-0.9.13-no_close.patch
@@ -0,0 +1,11 @@
+diff -ruN pmount-0.9.13.orig/src/pmount-hal.c pmount-0.9.13/src/pmount-hal.c
+--- pmount-0.9.13.orig/src/pmount-hal.c 2006-12-02 16:59:56.000000000 -0600
++++ pmount-0.9.13/src/pmount-hal.c 2006-12-02 17:00:16.000000000 -0600
+@@ -361,7 +361,6 @@
+ /* shut down hal connection */
+ libhal_ctx_shutdown( hal_ctx, &error );
+ libhal_ctx_free( hal_ctx );
+- dbus_connection_close( dbus_conn );
+ dbus_connection_unref( dbus_conn );
+
+ /* go */
diff --git a/sys-apps/pmount/pmount-0.9.13.ebuild b/sys-apps/pmount/pmount-0.9.13.ebuild
index aba65f451e02..ac95558c60ae 100644
--- a/sys-apps/pmount/pmount-0.9.13.ebuild
+++ b/sys-apps/pmount/pmount-0.9.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.13.ebuild,v 1.3 2006/10/31 01:11:26 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.13.ebuild,v 1.4 2006/12/11 02:57:08 steev Exp $
inherit eutils flag-o-matic
@@ -25,13 +25,13 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch ${FILESDIR}/${PN}-0.9.13-no_close.patch
append-ldflags $(bindnow-flags)
}
src_compile() {
econf $(use_enable hal) \
--with-cryptsetup-prog=/bin/cryptsetup
-
emake || die "emake failed"
}