summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-09-25 07:23:50 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-09-25 07:23:50 +0000
commit0568be83d9a9960204df62f651a2fc253882ad76 (patch)
tree2e50ba0c918731487a0f56f6410218c4e79ccdba /sys-apps/pmount
parentmedia-video/mplayer: Fix typo (diff)
downloadgentoo-2-0568be83d9a9960204df62f651a2fc253882ad76.tar.gz
gentoo-2-0568be83d9a9960204df62f651a2fc253882ad76.tar.bz2
gentoo-2-0568be83d9a9960204df62f651a2fc253882ad76.zip
Fix regex problem with et_EE localization wrt #416985 by Leho Kraav
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-apps/pmount')
-rw-r--r--sys-apps/pmount/ChangeLog11
-rw-r--r--sys-apps/pmount/files/pmount-0.9.99_alpha-locale-regex.patch22
-rw-r--r--sys-apps/pmount/pmount-0.9.99_alpha-r2.ebuild81
3 files changed, 111 insertions, 3 deletions
diff --git a/sys-apps/pmount/ChangeLog b/sys-apps/pmount/ChangeLog
index adfd17d5fa4e..61640d57c9c7 100644
--- a/sys-apps/pmount/ChangeLog
+++ b/sys-apps/pmount/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pmount
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.96 2012/05/24 02:36:19 vapier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.97 2013/09/25 07:23:50 ssuominen Exp $
+
+*pmount-0.9.99_alpha-r2 (25 Sep 2013)
+
+ 25 Sep 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +files/pmount-0.9.99_alpha-locale-regex.patch, +pmount-0.9.99_alpha-r2.ebuild:
+ Fix regex problem with et_EE localization wrt #416985 by Leho Kraav
24 May 2012; Mike Frysinger <vapier@gentoo.org> pmount-0.9.99_alpha-r1.ebuild:
Inherit user for enewuser/etc...
@@ -346,4 +352,3 @@
24 Aug 2005; Doug Goldstein <cardoe@gentoo.org> +metadata.xml,
+pmount-0.9.3.ebuild:
Added new pmount package from Gentopia to allow for auto-mounting of devices
-
diff --git a/sys-apps/pmount/files/pmount-0.9.99_alpha-locale-regex.patch b/sys-apps/pmount/files/pmount-0.9.99_alpha-locale-regex.patch
new file mode 100644
index 000000000000..c96fc0554522
--- /dev/null
+++ b/sys-apps/pmount/files/pmount-0.9.99_alpha-locale-regex.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/416985
+
+--- src/conffile.c
++++ src/conffile.c
+@@ -372,7 +372,7 @@ static int cf_prepare_regexps()
+ /* A regexp matching a boolean value*/
+
+ if( regcomp(&declaration_RE,
+- "^[[:blank:]]*([-a-zA-Z_]+)[[:blank:]]*"
++ "^[[:blank:]]*([-[:alpha:]_]+)[[:blank:]]*"
+ "=[[:blank:]]*(.*)$",
+ REG_EXTENDED )) {
+ perror(_("Could not compile regular expression for boolean values"));
+@@ -392,7 +392,7 @@ static int cf_prepare_regexps()
+ }
+
+ if( regcomp(&uint_RE,
+- "^[[:blank:]]*([a-zA-Z_]+)[[:blank:]]*"
++ "^[[:blank:]]*([[:alpha:]_]+)[[:blank:]]*"
+ "=[[:blank:]]*([0-9]+)$",
+ REG_EXTENDED )) {
+ perror(_("Could not compile regular expression for integer values"));
diff --git a/sys-apps/pmount/pmount-0.9.99_alpha-r2.ebuild b/sys-apps/pmount/pmount-0.9.99_alpha-r2.ebuild
new file mode 100644
index 000000000000..98d6dc2e9697
--- /dev/null
+++ b/sys-apps/pmount/pmount-0.9.99_alpha-r2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.99_alpha-r2.ebuild,v 1.1 2013/09/25 07:23:50 ssuominen Exp $
+
+EAPI=5
+inherit eutils user
+
+DESCRIPTION="Policy based mounter that gives the ability to mount removable devices as a user"
+HOMEPAGE="http://pmount.alioth.debian.org/"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV/_/-}.orig.tar.bz2"
+#SRC_URI="http://alioth.debian.org/frs/download.php/3530/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="crypt"
+
+RDEPEND=">=sys-apps/util-linux-2.17.2
+ crypt? ( >=sys-fs/cryptsetup-1.0.6-r2 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext"
+
+S=${WORKDIR}/${P/_/-}
+
+pkg_setup() {
+ enewgroup plugdev
+}
+
+src_prepare() {
+ # Restore default value from pmount <= 0.9.23 wrt #393633
+ sed -i -e '/^not_physically_logged_allow/s:=.*:= yes:' etc/pmount.conf || die
+
+ cat <<-EOF > po/POTFILES.skip
+ src/conffile.c
+ src/configuration.c
+ src/loop.c
+ EOF
+
+ epatch \
+ "${FILESDIR}"/${PN}-0.9.19-testsuite-missing-dir.patch \
+ "${FILESDIR}"/${P}-locale-regex.patch
+}
+
+src_configure() {
+ econf --disable-hal
+}
+
+src_test() {
+ local testdir=${S}/tests/check_fstab
+
+ ln -s $testdir/a $testdir/b && ln -s $testdir/d $testdir/c && \
+ ln -s $testdir/c $testdir/e \
+ || die "Unable to create fake symlinks required for testsuite"
+
+ emake check
+}
+
+src_install () {
+ # Must be run SETUID+SETGID, bug #250106
+ exeinto /usr/bin
+ exeopts -m 6710 -g plugdev
+ doexe src/{p,pu}mount
+
+ dodoc AUTHORS ChangeLog TODO
+ doman man/{{p,pu}mount.1,pmount.conf.5}
+
+ insinto /etc
+ doins etc/pmount.{allow,conf}
+}
+
+pkg_postinst() {
+ elog
+ elog "This package has been installed setuid and setgid."
+
+ elog "The permissions are as such that only users that belong to the plugdev"
+ elog "group are allowed to run this. But if a script run by root mounts a"
+ elog "device, members of the plugdev group will have access to it."
+ elog
+ elog "Please add your user to the plugdev group to be able to mount USB drives"
+}