summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-27 17:36:28 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-27 17:36:28 +0000
commit5695be3fe8d1c876df1794729211733bbb4e4e61 (patch)
treed688eb65584add8aa4bed2008c693ae89de9d7ac /sys-apps/pcmcia-cs
parentMarking stable on ppc (Manifest recommit) (diff)
downloadgentoo-2-5695be3fe8d1c876df1794729211733bbb4e4e61.tar.gz
gentoo-2-5695be3fe8d1c876df1794729211733bbb4e4e61.tar.bz2
gentoo-2-5695be3fe8d1c876df1794729211733bbb4e4e61.zip
QA - fix use invocation
Diffstat (limited to 'sys-apps/pcmcia-cs')
-rw-r--r--sys-apps/pcmcia-cs/ChangeLog6
-rw-r--r--sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r8.ebuild14
-rw-r--r--sys-apps/pcmcia-cs/pcmcia-cs-3.2.4.ebuild12
3 files changed, 18 insertions, 14 deletions
diff --git a/sys-apps/pcmcia-cs/ChangeLog b/sys-apps/pcmcia-cs/ChangeLog
index e1a15fa1b898..4fdb9c47c87f 100644
--- a/sys-apps/pcmcia-cs/ChangeLog
+++ b/sys-apps/pcmcia-cs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/pcmcia-cs
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/ChangeLog,v 1.66 2004/06/24 22:20:57 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/ChangeLog,v 1.67 2004/06/27 17:36:28 agriffis Exp $
+
+ 27 Jun 2004; Aron Griffis <agriffis@gentoo.org> pcmcia-cs-3.1.34-r8.ebuild,
+ pcmcia-cs-3.2.4.ebuild:
+ QA - fix use invocation
18 Mar 2004; Peter Johanson <latexer@gentoo.org> files/pcmcia.rc:
Added a slightly smarter check for pcmcia present in the kernel before
diff --git a/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r8.ebuild b/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r8.ebuild
index 90f79ac0fbef..14c72369940c 100644
--- a/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r8.ebuild
+++ b/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r8.ebuild,v 1.13 2004/06/24 22:20:57 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r8.ebuild,v 1.14 2004/06/27 17:36:28 agriffis Exp $
S=${WORKDIR}/${P}
DESCRIPTION="PCMCIA tools for Linux"
@@ -27,7 +27,7 @@ src_unpack() {
unpack ${P}.tar.gz
patch -p0 < ${FILESDIR}/gentoo-${P}.patch
- if [ -z "`use wavelan`" ] ; then
+ if ! use wavelan ; then
unpack orinoco-0.12b.tar.gz
cd ${S}
@@ -52,25 +52,25 @@ src_unpack() {
src_compile() {
local myconf
- if [ -n "`use trusted`" ] ; then
+ if use trusted ; then
myconf="--trust"
else
myconf="--notrust"
fi
- if [ -n "`use apm`" ] ; then
+ if use apm ; then
myconf="$myconf --apm"
else
myconf="$myconf --noapm"
fi
- if [ -n "`use pnp`" ] ; then
+ if use pnp ; then
myconf="$myconf --pnp"
else
myconf="$myconf --nopnp"
fi
- if [ -n "`use nocardbus`" ] ; then
+ if use nocardbus ; then
myconf="$myconf --nocardbus"
else
myconf="$myconf --cardbus"
@@ -115,7 +115,7 @@ src_install () {
# install our own init script
exeinto /etc/init.d
newexe ${FILESDIR}/pcmcia.rc pcmcia
- if [ -z "`use build`" ]
+ if ! use build
then
cd ${S}
# install docs
diff --git a/sys-apps/pcmcia-cs/pcmcia-cs-3.2.4.ebuild b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.4.ebuild
index 68d39a9867d7..aaf4bb686d2e 100644
--- a/sys-apps/pcmcia-cs/pcmcia-cs-3.2.4.ebuild
+++ b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.2.4.ebuild,v 1.8 2004/06/24 22:20:57 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.2.4.ebuild,v 1.9 2004/06/27 17:36:28 agriffis Exp $
inherit eutils
@@ -57,25 +57,25 @@ src_unpack() {
src_compile() {
local myconf
- if [ -n "`use trusted`" ] ; then
+ if use trusted ; then
myconf="--trust"
else
myconf="--notrust"
fi
- if [ -n "`use apm`" ] ; then
+ if use apm ; then
myconf="$myconf --apm"
else
myconf="$myconf --noapm"
fi
- if [ -n "`use pnp`" ] ; then
+ if use pnp ; then
myconf="$myconf --pnp"
else
myconf="$myconf --nopnp"
fi
- if [ -n "`use nocardbus`" ] ; then
+ if use nocardbus ; then
myconf="$myconf --nocardbus"
else
myconf="$myconf --cardbus"
@@ -128,7 +128,7 @@ src_install () {
# install our own init script
exeinto /etc/init.d
newexe ${FILESDIR}/pcmcia.rc pcmcia
- if [ -z "`use build`" ]
+ if ! use build
then
cd ${S}
# install docs