summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2002-07-02 02:41:58 +0000
committerChad Huneycutt <chadh@gentoo.org>2002-07-02 02:41:58 +0000
commit2b4a116dec9320e9f56a8f9ae5d4270bd8b449ef (patch)
treeabdddb949dee3f18b408719803829a418e1a2834 /sys-apps/pcmcia-cs
parentOops, left -mjc2 in the wrong spot. (diff)
downloadgentoo-2-2b4a116dec9320e9f56a8f9ae5d4270bd8b449ef.tar.gz
gentoo-2-2b4a116dec9320e9f56a8f9ae5d4270bd8b449ef.tar.bz2
gentoo-2-2b4a116dec9320e9f56a8f9ae5d4270bd8b449ef.zip
bumped pcmcia-cs version to 3.1.34, -r1 has updated orinoco drivers
Diffstat (limited to 'sys-apps/pcmcia-cs')
-rw-r--r--sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.342
-rw-r--r--sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.34-r12
-rw-r--r--sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r1.ebuild129
-rw-r--r--sys-apps/pcmcia-cs/pcmcia-cs-3.1.34.ebuild129
4 files changed, 262 insertions, 0 deletions
diff --git a/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.34 b/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.34
new file mode 100644
index 000000000000..9db7d7f99fce
--- /dev/null
+++ b/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.34
@@ -0,0 +1,2 @@
+MD5 c31d1bbd2117cc90f4bf1cac31f97d1d pcmcia-cs-3.1.34.tar.gz 1247038
+MD5 0c17725f8eae10d8f59df1d39fc1ff0b orinoco-0.11a.tar.gz 61877
diff --git a/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.34-r1 b/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.34-r1
new file mode 100644
index 000000000000..1881184fd64d
--- /dev/null
+++ b/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.34-r1
@@ -0,0 +1,2 @@
+MD5 c31d1bbd2117cc90f4bf1cac31f97d1d pcmcia-cs-3.1.34.tar.gz 1247038
+MD5 c37334fe04942dbabdb8e7f4c4a24e0b orinoco-0.12.tar.gz 62127
diff --git a/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r1.ebuild b/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r1.ebuild
new file mode 100644
index 000000000000..af6537a05f8c
--- /dev/null
+++ b/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r1.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r1.ebuild,v 1.1 2002/07/02 02:41:58 chadh Exp $
+
+# This ebuild installs ${FILESDIR}/hermes.conf, which you can get from
+# http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/hermes.conf
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PCMCIA tools for Linux"
+SRC_URI="mirror://sourceforge/pcmcia-cs/${P}.tar.gz
+ http://ozlabs.org/people/dgibson/dldwd/orinoco-0.12.tar.gz"
+
+HOMEPAGE="http://pcmcia-cs.sourceforge.net"
+DEPEND="sys-kernel/linux-headers"
+RDEPEND=""
+SLOT="0"
+LICENSE=GPL
+
+# check arch for configure
+if [ ${ARCH} = "x86" ] ; then
+ MY_ARCH="i386"
+else
+ MY_ARCH="ppc"
+fi
+
+# Note: To use this ebuild, you should have the usr/src/linux symlink to
+# the kernel directory that pcmcia-cs should use for configuration.
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ unpack orinoco-0.12.tar.gz
+ cd ${S}
+ mv ../orinoco-0.12/hermes*.{c,h} \
+ ../orinoco-0.12/orinoco*.{c,h} \
+ ../orinoco-0.12/ieee802_11.h wireless/
+ cp Configure Configure.orig
+ sed -e 's:usr/man:usr/share/man:g' Configure.orig > Configure
+ #man pages will now install into /usr/share/man
+}
+
+src_compile() {
+ local myconf
+ if [ -n "`use trusted`" ] ; then
+ myconf="--trust"
+ else
+ myconf="--notrust"
+ fi
+
+ if [ -n "`use apm`" ] ; then
+ myconf="$myconf --apm"
+ else
+ myconf="$myconf --noapm"
+ fi
+
+ if [ -n "`use pnp`" ] ; then
+ myconf="$myconf --pnp"
+ else
+ myconf="$myconf --nopnp"
+ fi
+
+ if [ -n "`use nocardbus`" ] ; then
+ myconf="$myconf --nocardbus"
+ else
+ myconf="$myconf --cardbus"
+ fi
+
+ #use $CFLAGS for user tools, but standard kernel optimizations for the kernel modules (for compatibility)
+ ./Configure -n \
+ --target=${D} \
+ --srctree \
+ --kernel=/usr/src/linux \
+ --arch="${MY_ARCH}" \
+ --uflags="$CFLAGS" \
+ --kflags="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer" \
+ $myconf || die "failed configuring"
+ # nopnp and noapm are important, because without them the pcmcia-cs
+ # tools will require a kernel with ISA PnP and/or APM support,
+ # which cannot be guaranteed. We need to make sure the tools
+ # work *all* the time, not just some of the time.
+
+ # The --srctree option tells pcmcia-cs to configure for the kernel in /usr/src/linux
+ # rather than the currently-running kernel. It's Gentoo Linux policy to configure for
+ # the kernel in /usr/src/linux
+ emake all || die "failed compiling"
+}
+
+src_install () {
+ make PREFIX=${D} install || die "failed installing"
+ cd ${D}
+ rm -rf etc/rc*.d
+ # remove X
+ # this is simply much easier than patching configure or the makefiles
+ # not to build them in the first place
+ rm -rf usr/X11R6
+ # todo: if they are nstalled, move them to /usr
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/pcmcia.conf pcmcia
+
+ exeinto /etc/pcmcia
+ doexe ${FILESDIR}/network
+
+ # install our own init script
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pcmcia.rc6 pcmcia
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ # install docs
+ dodoc BUGS CHANGES COPYING LICENSE MAINTAINERS README \
+ README-2.4 SUPPORTED.CARDS doc/*
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+ rm -f ${D}/etc/modules.conf
+ rm -rf ${D}/var/lib/pcmcia
+
+ # if on ppc set the ppc revised config.opts
+ if [ ${ARCH} = "ppc" ] ; then
+ insinto /etc/pcmcia
+ newins ${FILESDIR}/ppc.config.opts config.opts
+ fi
+}
+
+src_postinst() {
+ einfo "To avail yourself of the pcmcia-cs drivers, you have to disable the PCMCIA support in the kernel."
+ einfo "(Otherwise, you might experience CardServices version mismatch errors)"
+}
diff --git a/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34.ebuild b/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34.ebuild
new file mode 100644
index 000000000000..be96ddfefbaa
--- /dev/null
+++ b/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Header: $
+
+# This ebuild installs ${FILESDIR}/hermes.conf, which you can get from
+# http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/hermes.conf
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PCMCIA tools for Linux"
+SRC_URI="mirror://sourceforge/pcmcia-cs/${P}.tar.gz
+ http://ozlabs.org/people/dgibson/dldwd/orinoco-0.11a.tar.gz"
+
+HOMEPAGE="http://pcmcia-cs.sourceforge.net"
+DEPEND="sys-kernel/linux-headers"
+RDEPEND=""
+SLOT=0
+LICENSE=GPL
+
+# check arch for configure
+if [ ${ARCH} = "x86" ] ; then
+ MY_ARCH="i386"
+else
+ MY_ARCH="ppc"
+fi
+
+# Note: To use this ebuild, you should have the usr/src/linux symlink to
+# the kernel directory that pcmcia-cs should use for configuration.
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ unpack orinoco-0.11a.tar.gz
+ cd ${S}
+ mv ../orinoco-0.11a/hermes*.{c,h} \
+ ../orinoco-0.11a/orinoco*.{c,h} \
+ ../orinoco-0.11a/ieee802_11.h wireless/
+ cp Configure Configure.orig
+ sed -e 's:usr/man:usr/share/man:g' Configure.orig > Configure
+ #man pages will now install into /usr/share/man
+}
+
+src_compile() {
+ local myconf
+ if [ -n "`use trusted`" ] ; then
+ myconf="--trust"
+ else
+ myconf="--notrust"
+ fi
+
+ if [ -n "`use apm`" ] ; then
+ myconf="$myconf --apm"
+ else
+ myconf="$myconf --noapm"
+ fi
+
+ if [ -n "`use pnp`" ] ; then
+ myconf="$myconf --pnp"
+ else
+ myconf="$myconf --nopnp"
+ fi
+
+ if [ -n "`use nocardbus`" ] ; then
+ myconf="$myconf --nocardbus"
+ else
+ myconf="$myconf --cardbus"
+ fi
+
+ #use $CFLAGS for user tools, but standard kernel optimizations for the kernel modules (for compatibility)
+ ./Configure -n \
+ --target=${D} \
+ --srctree \
+ --kernel=/usr/src/linux \
+ --arch="${MY_ARCH}" \
+ --uflags="$CFLAGS" \
+ --kflags="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer" \
+ $myconf || die "failed configuring"
+ # nopnp and noapm are important, because without them the pcmcia-cs
+ # tools will require a kernel with ISA PnP and/or APM support,
+ # which cannot be guaranteed. We need to make sure the tools
+ # work *all* the time, not just some of the time.
+
+ # The --srctree option tells pcmcia-cs to configure for the kernel in /usr/src/linux
+ # rather than the currently-running kernel. It's Gentoo Linux policy to configure for
+ # the kernel in /usr/src/linux
+ emake all || die "failed compiling"
+}
+
+src_install () {
+ make PREFIX=${D} install || die "failed installing"
+ cd ${D}
+ rm -rf etc/rc*.d
+ # remove X
+ # this is simply much easier than patching configure or the makefiles
+ # not to build them in the first place
+ rm -rf usr/X11R6
+ # todo: if they are nstalled, move them to /usr
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/pcmcia.conf pcmcia
+
+ exeinto /etc/pcmcia
+ doexe ${FILESDIR}/network
+
+ # install our own init script
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pcmcia.rc6 pcmcia
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ # install docs
+ dodoc BUGS CHANGES COPYING LICENSE MAINTAINERS README \
+ README-2.4 SUPPORTED.CARDS doc/*
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+ rm -f ${D}/etc/modules.conf
+ rm -rf ${D}/var/lib/pcmcia
+
+ # if on ppc set the ppc revised config.opts
+ if [ ${ARCH} = "ppc" ] ; then
+ insinto /etc/pcmcia
+ newins ${FILESDIR}/ppc.config.opts config.opts
+ fi
+}
+
+src_postinst() {
+ einfo "To avail yourself of the pcmcia-cs drivers, you have to disable the PCMCIA support in the kernel."
+ einfo "(Otherwise, you might experience CardServices version mismatch errors)"
+}