summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-05-03 01:47:18 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-05-03 01:47:18 +0000
commitc4ca66e4b8f1b0dd85252da44592e54cf393286a (patch)
tree621ec9da632dc07d352e02be0653f8df6d914e57 /sys-apps/pciutils
parentInitial version of the ebuild, submitted by blauwers@cisco.com (Bart (diff)
downloadgentoo-2-c4ca66e4b8f1b0dd85252da44592e54cf393286a.tar.gz
gentoo-2-c4ca66e4b8f1b0dd85252da44592e54cf393286a.tar.bz2
gentoo-2-c4ca66e4b8f1b0dd85252da44592e54cf393286a.zip
Close bug #2366.
Diffstat (limited to 'sys-apps/pciutils')
-rw-r--r--sys-apps/pciutils/ChangeLog6
-rw-r--r--sys-apps/pciutils/files/digest-pciutils-2.1.9-r12
-rw-r--r--sys-apps/pciutils/pciutils-2.1.9-r1.ebuild48
3 files changed, 55 insertions, 1 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index 1b5335336eb4..760bd8b55a11 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,11 +1,15 @@
# ChangeLog for sys-apps/pciutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.1 2002/02/25 01:43:19 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.2 2002/05/03 01:47:18 agenkin Exp $
*pciutils-2.1.9 (24 Feb 2002)
22 Feb 2002; Bruce A. Locke <blocke@shivan.org> pciutils-2.1.9.ebuild :
+ Now installs the header files and the lib, as per bug #2366.
+
+ 22 Feb 2002; Bruce A. Locke <blocke@shivan.org> pciutils-2.1.9.ebuild :
+
- app-admin/pciutils moved to sys-apps/pciutils
- Updated ebuild contributed by folokai@earthlink.net (scott worley)
diff --git a/sys-apps/pciutils/files/digest-pciutils-2.1.9-r1 b/sys-apps/pciutils/files/digest-pciutils-2.1.9-r1
new file mode 100644
index 000000000000..81273457a9db
--- /dev/null
+++ b/sys-apps/pciutils/files/digest-pciutils-2.1.9-r1
@@ -0,0 +1,2 @@
+MD5 2f3a604c137f5ff77461efed44a4b53a pciutils-2.1.9.tar.gz 100222
+MD5 7be1fd73b14feb79499c5117a3d05385 pcimodules-pciutils-2.1.8.diff.gz 4489
diff --git a/sys-apps/pciutils/pciutils-2.1.9-r1.ebuild b/sys-apps/pciutils/pciutils-2.1.9-r1.ebuild
new file mode 100644
index 000000000000..6765427adc88
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-2.1.9-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.1.9-r1.ebuild,v 1.1 2002/05/03 01:47:18 agenkin Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Various utilities dealing with the PCI bus"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz
+ ftp://ftp.yggdrasil.com/pub/dist/device_control/pcimodules/pcimodules-pciutils-2.1.8.diff.gz"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ # this patch does apply cleanly to pciutils-2.1.9
+ # add pcimodules utility
+ gunzip -c ${DISTDIR}/pcimodules-pciutils-2.1.8.diff.gz | patch -p1
+
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+}
+
+src_compile() {
+ make PREFIX=/usr lib/config.h || die
+
+ cd ${S}/lib
+ cp config.h config.h.orig
+ sed -e "s:/usr/share/pci.ids:/usr/share/misc/pci.ids:" config.h.orig > config.h || die
+
+ cd ${S}
+ make PREFIX=/usr || die
+}
+
+src_install () {
+ into /
+ dosbin setpci lspci pcimodules
+ doman *.8
+
+ insinto /usr/share/misc
+ doins pci.ids
+
+ dolib lib/libpci.a
+
+ insinto /usr/include/pci
+ doins lib/*.h
+}