summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-02-25 01:43:19 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-02-25 01:43:19 +0000
commit7ba65791b5d7d6f2bfb965edd8944a23860eba6f (patch)
tree732389af6632d6a76461e27ce931eacbf18a33dc /sys-apps/pciutils
parentupdato (diff)
downloadgentoo-2-7ba65791b5d7d6f2bfb965edd8944a23860eba6f.tar.gz
gentoo-2-7ba65791b5d7d6f2bfb965edd8944a23860eba6f.tar.bz2
gentoo-2-7ba65791b5d7d6f2bfb965edd8944a23860eba6f.zip
app-admin/pciutils moved to sys-apps/pciutils and updated
Diffstat (limited to 'sys-apps/pciutils')
-rw-r--r--sys-apps/pciutils/ChangeLog11
-rw-r--r--sys-apps/pciutils/files/digest-pciutils-2.1.92
-rw-r--r--sys-apps/pciutils/pciutils-2.1.9.ebuild44
3 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
new file mode 100644
index 000000000000..1b5335336eb4
--- /dev/null
+++ b/sys-apps/pciutils/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-apps/pciutils
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.1 2002/02/25 01:43:19 blocke Exp $
+
+*pciutils-2.1.9 (24 Feb 2002)
+
+ 22 Feb 2002; Bruce A. Locke <blocke@shivan.org> pciutils-2.1.9.ebuild :
+
+ - app-admin/pciutils moved to sys-apps/pciutils
+ - Updated ebuild contributed by folokai@earthlink.net (scott worley)
+
diff --git a/sys-apps/pciutils/files/digest-pciutils-2.1.9 b/sys-apps/pciutils/files/digest-pciutils-2.1.9
new file mode 100644
index 000000000000..84cb1ac1d701
--- /dev/null
+++ b/sys-apps/pciutils/files/digest-pciutils-2.1.9
@@ -0,0 +1,2 @@
+MD5 7be1fd73b14feb79499c5117a3d05385 pcimodules-pciutils-2.1.8.diff.gz 4489
+MD5 2f3a604c137f5ff77461efed44a4b53a pciutils-2.1.9.tar.gz 100222
diff --git a/sys-apps/pciutils/pciutils-2.1.9.ebuild b/sys-apps/pciutils/pciutils-2.1.9.ebuild
new file mode 100644
index 000000000000..923a90a85911
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-2.1.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.1.9.ebuild,v 1.1 2002/02/25 01:43:19 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Various utilities dealing with the PCI bus"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz
+ ftp://ftp.yggdrasil.com/pub/dist/device_control/pcimodules/pcimodules-pciutils-2.1.8.diff.gz"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ # this patch does apply cleanly to pciutils-2.1.9
+ # add pcimodules utility
+ gunzip -c ${DISTDIR}/pcimodules-pciutils-2.1.8.diff.gz | patch -p1
+
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+}
+
+src_compile() {
+ make PREFIX=/usr lib/config.h || die
+
+ cd ${S}/lib
+ cp config.h config.h.orig
+ sed -e "s:/usr/share/pci.ids:/usr/share/misc/pci.ids:" config.h.orig > config.h || die
+
+ cd ${S}
+ make PREFIX=/usr || die
+}
+
+src_install () {
+ into /
+ dosbin setpci lspci pcimodules
+ doman *.8
+
+ insinto /usr/share/misc
+ doins pci.ids
+}
+