summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-07-06 05:09:40 +0000
committerMike Frysinger <vapier@gentoo.org>2007-07-06 05:09:40 +0000
commit59033e86c6403435c9f64253af824322d1ad4058 (patch)
tree6233483b8afb22f9af77b24bb7be3457c7c95a36 /sys-apps/pciutils
parentold (diff)
downloadgentoo-2-59033e86c6403435c9f64253af824322d1ad4058.tar.gz
gentoo-2-59033e86c6403435c9f64253af824322d1ad4058.tar.bz2
gentoo-2-59033e86c6403435c9f64253af824322d1ad4058.zip
Fix install of pkg-config file.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'sys-apps/pciutils')
-rw-r--r--sys-apps/pciutils/ChangeLog7
-rw-r--r--sys-apps/pciutils/files/digest-pciutils-2.2.6-r13
-rw-r--r--sys-apps/pciutils/pciutils-2.2.6-r1.ebuild46
3 files changed, 55 insertions, 1 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index 273092c9b359..f941d7cb83fb 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pciutils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.107 2007/06/24 20:14:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.108 2007/07/06 05:09:40 vapier Exp $
+
+*pciutils-2.2.6-r1 (06 Jul 2007)
+
+ 06 Jul 2007; Mike Frysinger <vapier@gentoo.org> +pciutils-2.2.6-r1.ebuild:
+ Fix install of pkg-config file.
24 Jun 2007; Mike Frysinger <vapier@gentoo.org> pciutils-2.2.4-r3.ebuild:
Add workaround for stable where we decompress pci.ids when USE=hal.
diff --git a/sys-apps/pciutils/files/digest-pciutils-2.2.6-r1 b/sys-apps/pciutils/files/digest-pciutils-2.2.6-r1
new file mode 100644
index 000000000000..efee508018c5
--- /dev/null
+++ b/sys-apps/pciutils/files/digest-pciutils-2.2.6-r1
@@ -0,0 +1,3 @@
+MD5 e26593ab38ef9ae4457826be9e35aff8 pciutils-2.2.6.tar.gz 226049
+RMD160 9f184affb481e51ca59134f5fd72259cf5e16298 pciutils-2.2.6.tar.gz 226049
+SHA256 30019fa23996429d3bedaa1b30e32b9ddcd2eaa4fe39ec015d533af6afc0ee6b pciutils-2.2.6.tar.gz 226049
diff --git a/sys-apps/pciutils/pciutils-2.2.6-r1.ebuild b/sys-apps/pciutils/pciutils-2.2.6-r1.ebuild
new file mode 100644
index 000000000000..6eee4b3af765
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-2.2.6-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.6-r1.ebuild,v 1.1 2007/07/06 05:09:40 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="Various utilities dealing with the PCI bus"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="network-cron zlib"
+
+DEPEND="zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.2.3-build.patch
+ epatch "${FILESDIR}"/pcimodules-${PN}-2.2.6.patch
+ epatch "${FILESDIR}"/${PN}-2.2.6-link.patch #160421
+ epatch "${FILESDIR}"/${PN}-2.2.4-update-pciids.patch
+ sed -i "/^LIBDIR=/s:/lib:/$(get_libdir):" Makefile
+}
+
+src_compile() {
+ export ZLIB=$(use zlib && echo yes || echo no)
+ tc-export AR CC RANLIB
+ emake OPT="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install install-lib DESTDIR="${D}" || die
+
+ use network-cron || return 0
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/pciutils.cron update-pciids || die
+}
+
+pkg_postinst() {
+ cd "${ROOT}"/usr/share/misc
+ rm -f pci.ids{,.gz}.old
+ use zlib && rm -f pci.ids || rm -f pci.ids.gz
+}