summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-11-02 21:40:20 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-11-02 21:40:20 +0000
commit749d48a02ea6d656db26bb6473eb6a2aad3d4003 (patch)
treed8de077b7f9a53484cc0f37da20271d9799fa860 /sys-apps/pciutils/pciutils-2.2.6-r2.ebuild
parentadded rss for app-admin/conky (diff)
downloadgentoo-2-749d48a02ea6d656db26bb6473eb6a2aad3d4003.tar.gz
gentoo-2-749d48a02ea6d656db26bb6473eb6a2aad3d4003.tar.bz2
gentoo-2-749d48a02ea6d656db26bb6473eb6a2aad3d4003.zip
Backport the HAL-zlib Gentoo patch from 2.2.8 to the other unstable ebuilds.
(Portage version: 2.1.3.16)
Diffstat (limited to 'sys-apps/pciutils/pciutils-2.2.6-r2.ebuild')
-rw-r--r--sys-apps/pciutils/pciutils-2.2.6-r2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/pciutils/pciutils-2.2.6-r2.ebuild b/sys-apps/pciutils/pciutils-2.2.6-r2.ebuild
new file mode 100644
index 000000000000..0479180a7ef8
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-2.2.6-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.6-r2.ebuild,v 1.1 2007/11/02 21:40:20 robbat2 Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="Various utilities dealing with the PCI bus"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="network-cron zlib"
+
+DEPEND="zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.2.3-build.patch
+ epatch "${FILESDIR}"/pcimodules-${PN}-2.2.6.patch
+ epatch "${FILESDIR}"/${PN}-2.2.6-link.patch #160421
+ epatch "${FILESDIR}"/${PN}-2.2.4-update-pciids.patch
+ epatch "${FILESDIR}"/${PN}-2.2.7-update-pciids-both-forms.patch
+ epatch "${FILESDIR}"/${PN}-2.2.6-alloca.patch
+ sed -i "/^LIBDIR=/s:/lib:/$(get_libdir):" Makefile
+}
+
+src_compile() {
+ export ZLIB=$(use zlib && echo yes || echo no)
+ tc-export AR CC RANLIB
+ emake OPT="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install install-lib DESTDIR="${D}" || die
+
+ if use network-cron; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/pciutils.cron update-pciids \
+ || die "Failed to install update cronjob"
+ fi
+ # Install both forms until HAL has migrated
+ sharedir="${D}"/usr/share/misc
+ if use zlib; then
+ elog "Providing a backwards compatability non-compressed pci.ids"
+ gzip -d <"${sharedir}"/pci.ids.gz >"${sharedir}"/pci.ids
+ fi
+}