summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-10-16 23:02:17 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-10-16 23:02:17 +0000
commit66b88e8bbd34cab95716d6b0b693519d2273bb10 (patch)
tree38131eee32f31c6b15d77d245b4477df1b7591a6 /sys-apps/pacman
parentBump to libbtbb-0.6 at zero_chaos's request, with a patch to fix QA warning a... (diff)
downloadgentoo-2-66b88e8bbd34cab95716d6b0b693519d2273bb10.tar.gz
gentoo-2-66b88e8bbd34cab95716d6b0b693519d2273bb10.tar.bz2
gentoo-2-66b88e8bbd34cab95716d6b0b693519d2273bb10.zip
Clean out old versions (pacman-3.4.1, pacman-3.5.2).
(Portage version: 2.2.0_alpha67-r1/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/pacman')
-rw-r--r--sys-apps/pacman/ChangeLog6
-rw-r--r--sys-apps/pacman/pacman-3.4.1.ebuild58
-rw-r--r--sys-apps/pacman/pacman-3.5.2.ebuild63
3 files changed, 5 insertions, 122 deletions
diff --git a/sys-apps/pacman/ChangeLog b/sys-apps/pacman/ChangeLog
index f021724b4a36..b40606a3ee54 100644
--- a/sys-apps/pacman/ChangeLog
+++ b/sys-apps/pacman/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/pacman
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pacman/ChangeLog,v 1.6 2011/08/23 04:05:45 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pacman/ChangeLog,v 1.7 2011/10/16 23:02:15 binki Exp $
+
+ 16 Oct 2011; Nathan Phillip Brink <binki@gentoo.org> -pacman-3.4.1.ebuild,
+ -pacman-3.5.2.ebuild:
+ Clean out old versions (pacman-3.4.1, pacman-3.5.2).
*pacman-3.5.4 (23 Aug 2011)
diff --git a/sys-apps/pacman/pacman-3.4.1.ebuild b/sys-apps/pacman/pacman-3.4.1.ebuild
deleted file mode 100644
index ee3e1e9cf6af..000000000000
--- a/sys-apps/pacman/pacman-3.4.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pacman/pacman-3.4.1.ebuild,v 1.1 2010/11/01 00:56:08 hwoarang Exp $
-
-EAPI=2
-
-inherit autotools
-
-DESCRIPTION="Archlinux's binary package manager"
-HOMEPAGE="http://archlinux.org/pacman/"
-SRC_URI="ftp://ftp.archlinux.org/other/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="debug doc test"
-
-COMMON_DEPEND="app-arch/libarchive
- virtual/libiconv
- virtual/libintl
- sys-devel/gettext"
-RDEPEND="${COMMON_DEPEND}
- app-arch/xz-utils"
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )
- test? ( dev-lang/python )"
-
-RESTRICT="test"
-
-src_prepare() {
- sed -i -e '/-Werror/d' configure.ac || die "-Werror"
- # acinclude.m4 overrides libtool macros from /usr/share/aclocal, causing
- # elibtoolize's ltmain.sh to incompatible with ./configure after
- # eautoreconf is run.
- sed -i -e '4,/dnl Add some custom macros for pacman and libalpm/d' acinclude.m4 || die "libtool fix"
- eautoreconf
-}
-
-src_configure() {
- econf \
- --localstatedir=/var \
- --disable-git-version \
- --disable-internal-download \
- $(use_enable debug) \
- $(use_enable doc) \
- $(use_enable doc doxygen)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodir /etc/pacman.d || die
-}
-
-pkg_postinst() {
- einfo "Please see http://ohnopub.net/~ohnobinki/gentoo/arch/ for information"
- einfo "about setting up an archlinux chroot."
-}
diff --git a/sys-apps/pacman/pacman-3.5.2.ebuild b/sys-apps/pacman/pacman-3.5.2.ebuild
deleted file mode 100644
index 5ebd27afaa5d..000000000000
--- a/sys-apps/pacman/pacman-3.5.2.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pacman/pacman-3.5.2.ebuild,v 1.1 2011/06/08 01:37:54 binki Exp $
-
-EAPI=4
-
-inherit autotools autotools-utils
-
-DESCRIPTION="Archlinux's binary package manager"
-HOMEPAGE="http://archlinux.org/pacman/"
-SRC_URI="ftp://ftp.archlinux.org/other/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="debug doc test"
-
-COMMON_DEPEND="app-arch/libarchive
- dev-libs/openssl
- virtual/libiconv
- virtual/libintl
- sys-devel/gettext"
-RDEPEND="${COMMON_DEPEND}
- app-arch/xz-utils"
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )
- test? ( dev-lang/python )"
-
-RESTRICT="test"
-
-src_prepare() {
- # Remove a line that adds -Werror in ./configure when --enable-debug
- # is passed:
- sed -i -e '/-Werror/d' configure.ac || die "-Werror"
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --localstatedir=/var
- --disable-git-version
- --without-fetch
- --with-openssl
- # Help protect users from shooting their Gentoo installation in
- # its foot.
- --with-root-dir="${EPREFIX}"/var/chroot/archlinux
- $(use_enable debug)
- $(use_enable doc)
- $(use_enable doc doxygen)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- dodir /etc/pacman.d
-}
-
-pkg_postinst() {
- einfo "Please see http://ohnopub.net/~ohnobinki/gentoo/arch/ for information"
- einfo "about setting up an archlinux chroot."
-}