summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2003-01-27 16:16:05 +0000
committerChad Huneycutt <chadh@gentoo.org>2003-01-27 16:16:05 +0000
commit1e47badd69f5931cb7103c0bc6f632551bfa2718 (patch)
treeae648e5be780a54697d97cd5ca24f224575c965d /sys-apps/mpi350-driver
parentfixes (diff)
downloadgentoo-2-1e47badd69f5931cb7103c0bc6f632551bfa2718.tar.gz
gentoo-2-1e47badd69f5931cb7103c0bc6f632551bfa2718.tar.bz2
gentoo-2-1e47badd69f5931cb7103c0bc6f632551bfa2718.zip
new ebuild
Diffstat (limited to 'sys-apps/mpi350-driver')
-rw-r--r--sys-apps/mpi350-driver/ChangeLog8
-rw-r--r--sys-apps/mpi350-driver/mpi350-driver-2.0.ebuild93
2 files changed, 101 insertions, 0 deletions
diff --git a/sys-apps/mpi350-driver/ChangeLog b/sys-apps/mpi350-driver/ChangeLog
new file mode 100644
index 000000000000..30003d5ac2be
--- /dev/null
+++ b/sys-apps/mpi350-driver/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sys-apps/mpi350-driver
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mpi350-driver/ChangeLog,v 1.1 2003/01/27 16:16:01 chadh Exp $
+
+*mpi350-driver-2.0 (27 Jan 2003)
+
+ 27 Jan 2003; Chad Huneycutt <chadh@gentoo.org> mpi350-driver-2.0.ebuild :
+ new ebuild (bug #14563).
diff --git a/sys-apps/mpi350-driver/mpi350-driver-2.0.ebuild b/sys-apps/mpi350-driver/mpi350-driver-2.0.ebuild
new file mode 100644
index 000000000000..5a773828d9c0
--- /dev/null
+++ b/sys-apps/mpi350-driver/mpi350-driver-2.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mpi350-driver/mpi350-driver-2.0.ebuild,v 1.1 2003/01/27 16:16:05 chadh Exp $
+
+DESCRIPTION="Cisco's wireless drivers and utilities"
+
+HOMEPAGE="http://www.cisco.com/"
+
+SRC_DOWNLOAD="http://www.cisco.com/public/sw-center/sw-wireless.shtml"
+SRC_URI="Linux-ACU-Driver-v2.0.tar.gz"
+RESTRICT="fetch"
+
+LICENSE="MPL"
+
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc"
+
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${P}
+
+MOD_DIR="/lib/modules/`uname -r`"
+KERNEL_SRC="/usr/src/linux"
+
+# ------------------------------------------------- #
+# The script that Cisco provides is basically
+# WORH (works on redhat) and doesn't mesh w/
+# portage at all. Thus this ebuild does everything
+# by hand, not using any of the scripts in their
+# package.
+# ------------------------------------------------- #
+
+pkg_nofetch() {
+ eerror "Please download ${SRC_URI} from ${SRC_DOWNLOAD}"
+ eerror "and put it in ${DISTDIR}."
+}
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+}
+
+src_compile() {
+ # Compile and install the drivers. the script that cisco provides
+ # with the package stinks. Doesn't allow for DESTDIR or anything
+ # Thus we compile them by hand here.
+
+ cd ${S}/driver
+ einfo "Compiling mpi350.o"
+ ${CC} -MD -Wall -I${KERNEL_SRC}/include -D__KERNEL__ -DMODULE -c ${S}/driver/mpi350.c
+}
+
+src_install() {
+ # Install the drivers into the right place
+
+ dodir ${MOD_DIR}/net
+
+ cp ${S}/driver/mpi350.o ${D}/${MOD_DIR}/net
+
+
+ # Next we install the utilities. They're binaries, so we simply
+ # put them in the right place.
+
+ cd ${S}/utilities
+
+ dodir /opt/cisco/bin
+ exeinto /opt/cisco/bin
+ doexe acu bcard leapset leapscript leaplogin
+
+ # Install the helpml stuff
+
+ cd ${S}
+ tar xfz ${S}/helpml.tar.gz
+ dodir /opt/cisco/helpml
+ cp ${S}/helpml/* ${D}/opt/cisco/helpml/
+
+ cp ${S}/ACU.PRFS ${D}/opt/cisco
+
+ cd ${S}
+ dodoc ethX.cfg readme.txt
+}
+pkg_postinst() {
+ einfo "The cisco utilities are placed in /opt/cisco/bin"
+ einfo "To use them either add them to your PATH, or"
+ einfo "specify the full path to them."
+
+ einfo "You need to gunzip ethX.cfg from /usr/share/doc/${P}"
+ einfo "and copy it to /etc/ethX.cfg where X is the number ethernet"
+ einfo "device using the cisco driver."
+}