summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-05-05 14:47:23 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-05-05 14:47:23 +0000
commit885c569c9ade4977711270bdcae6fef61f1ab81f (patch)
treef2853071cffda873b78e279e54cb74a8b0d24cd0 /sys-apps/mlocate
parentadd dev-ruby/rubygems as dependency (diff)
downloadgentoo-2-885c569c9ade4977711270bdcae6fef61f1ab81f.tar.gz
gentoo-2-885c569c9ade4977711270bdcae6fef61f1ab81f.tar.bz2
gentoo-2-885c569c9ade4977711270bdcae6fef61f1ab81f.zip
version bump
(Portage version: 2.1.6.11/cvs/Linux i686)
Diffstat (limited to 'sys-apps/mlocate')
-rw-r--r--sys-apps/mlocate/ChangeLog7
-rw-r--r--sys-apps/mlocate/mlocate-0.22.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/sys-apps/mlocate/ChangeLog b/sys-apps/mlocate/ChangeLog
index 1c5b9cccb0d0..ed3fdc48e1ec 100644
--- a/sys-apps/mlocate/ChangeLog
+++ b/sys-apps/mlocate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/mlocate
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/ChangeLog,v 1.40 2009/03/15 13:18:25 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/ChangeLog,v 1.41 2009/05/05 14:47:23 fauli Exp $
+
+*mlocate-0.22 (05 May 2009)
+
+ 05 May 2009; Christian Faulhammer <fauli@gentoo.org> +mlocate-0.22.ebuild:
+ version bump
15 Mar 2009; Brent Baude <ranger@gentoo.org> mlocate-0.21.1.ebuild:
keyworded ~arch for ppc64, bug 262026
diff --git a/sys-apps/mlocate/mlocate-0.22.ebuild b/sys-apps/mlocate/mlocate-0.22.ebuild
new file mode 100644
index 000000000000..b4762132267c
--- /dev/null
+++ b/sys-apps/mlocate/mlocate-0.22.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/mlocate-0.22.ebuild,v 1.1 2009/05/05 14:47:23 fauli Exp $
+
+inherit eutils
+
+DESCRIPTION="Merging locate is an utility to index and quickly search for files"
+HOMEPAGE="https://fedorahosted.org/mlocate/"
+SRC_URI="https://fedorahosted.org/releases/m/l/mlocate/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/slocate
+ !sys-apps/rlocate"
+
+pkg_setup() {
+ enewgroup locate
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake groupname=locate || die "emake failed"
+}
+
+src_install() {
+ emake groupname=locate DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README NEWS
+
+ insinto /etc
+ doins "${FILESDIR}/updatedb.conf"
+ fperms 0644 /etc/updatedb.conf
+
+ insinto /etc
+ doins "${FILESDIR}/mlocate-cron.conf"
+ fperms 0644 /etc/mlocate-cron.conf
+
+ insinto /etc/cron.daily
+ newins "${FILESDIR}/mlocate.cron-r1" mlocate
+ fperms 0755 /etc/cron.daily/mlocate
+
+ fowners 0:locate /usr/bin/locate
+ fperms go-r,g+s /usr/bin/locate
+
+ chown -R 0:locate "${D}/var/lib/mlocate"
+ fperms 0750 /var/lib/mlocate
+ keepdir /var/lib/mlocate
+}
+
+src_test() {
+ if has userpriv ${FEATURES} && ! has usersandbox ${FEATURES}; then
+ make check-local || die "test suite failed"
+ else
+ ewarn "Activate FEATURES=userpriv and deactivate FEATURES=usersandbox to run testsuite."
+ fi
+}
+
+pkg_postinst() {
+ elog "Note that the /etc/updatedb.conf file is generic"
+ elog "Please customize it to your system requirements"
+}