summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-11-27 13:04:04 +0000
committerMichael Januszewski <spock@gentoo.org>2008-11-27 13:04:04 +0000
commit4368af9367debb886e19d488dc0f375aed4bd8b3 (patch)
treee10e18174f991c6d944c51a6f33ab3075d9c95c0 /sys-apps/memtest86+/files
parentAdded qt-assistant dependency, closing bug #248659 (diff)
downloadgentoo-2-4368af9367debb886e19d488dc0f375aed4bd8b3.tar.gz
gentoo-2-4368af9367debb886e19d488dc0f375aed4bd8b3.tar.bz2
gentoo-2-4368af9367debb886e19d488dc0f375aed4bd8b3.zip
Version bump.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27 x86_64)
Diffstat (limited to 'sys-apps/memtest86+/files')
-rw-r--r--sys-apps/memtest86+/files/memtest86+-2.10-hardcoded_cc.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/memtest86+/files/memtest86+-2.10-hardcoded_cc.patch b/sys-apps/memtest86+/files/memtest86+-2.10-hardcoded_cc.patch
new file mode 100644
index 000000000000..43e3fbb3fcc5
--- /dev/null
+++ b/sys-apps/memtest86+/files/memtest86+-2.10-hardcoded_cc.patch
@@ -0,0 +1,30 @@
+diff -Naurp memtest86+-2.10-orig/Makefile memtest86+-2.10/Makefile
+--- memtest86+-2.10-orig/Makefile 2008-11-27 13:54:49.000000000 +0100
++++ memtest86+-2.10/Makefile 2008-11-27 13:56:32.000000000 +0100
+@@ -8,10 +8,9 @@
+ #
+ FDISK=/dev/fd0
+
+-AS=as -32
+-CC=gcc
+-
+-CFLAGS= -fno-stack-protector -Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC
++CPPFLAGS=-m32
++CFLAGS=-Wall -m32 -march=i486 -O1 -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC -fno-stack-protector
++ASFLAGS=-32
+
+ OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
+ config.o linuxbios.o memsize.o pci.o controller.o random.o extra.o \
+@@ -47,10 +46,10 @@ memtest.bin: memtest_shared.bin bootsect
+ memtest_shared.bin -o memtest.bin
+
+ reloc.o: reloc.c
+- $(CC) -c $(CFLAGS) -fno-strict-aliasing reloc.c
++ $(CC) -c $(CFLAGS) -fno-strict-aliasing -fno-stack-protector reloc.c
+
+ test.o: test.c
+- $(CC) -c -Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding test.c
++ $(CC) -c -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin -ffreestanding -fno-stack-protector -fno-pie -nopie test.c
+
+ clean:
+ rm -f *.o *.s *.iso memtest.bin memtest memtest_shared memtest_shared.bin