summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-16 17:56:48 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-16 17:56:48 +0000
commit2e8af1405f0968b732d4e750a133a025474d29e7 (patch)
treefd0c76c97af90d0992daed299dca3f892a10e58f /sys-apps/man-db
parentUse proper name and version number to install the gem so that it matches the ... (diff)
downloadgentoo-2-2e8af1405f0968b732d4e750a133a025474d29e7.tar.gz
gentoo-2-2e8af1405f0968b732d4e750a133a025474d29e7.tar.bz2
gentoo-2-2e8af1405f0968b732d4e750a133a025474d29e7.zip
Fix building with USE=-gdbm by Maciej Mrozowski.
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/man-db')
-rw-r--r--sys-apps/man-db/ChangeLog6
-rw-r--r--sys-apps/man-db/files/man-db-2.6.0.2-flock.h.patch69
-rw-r--r--sys-apps/man-db/man-db-2.6.0.2.ebuild7
3 files changed, 80 insertions, 2 deletions
diff --git a/sys-apps/man-db/ChangeLog b/sys-apps/man-db/ChangeLog
index 6e89c7f9a52d..270e99a00b57 100644
--- a/sys-apps/man-db/ChangeLog
+++ b/sys-apps/man-db/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/man-db
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.18 2011/06/15 18:43:04 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.19 2011/06/16 17:56:47 jer Exp $
+
+ 16 Jun 2011; Jeroen Roovers <jer@gentoo.org> man-db-2.6.0.2.ebuild,
+ +files/man-db-2.6.0.2-flock.h.patch:
+ Fix building with USE=-gdbm by Maciej Mrozowski.
15 Jun 2011; Matt Turner <mattst88@gentoo.org> man-db-2.6.0.2.ebuild:
Added ~mips, bug 371687
diff --git a/sys-apps/man-db/files/man-db-2.6.0.2-flock.h.patch b/sys-apps/man-db/files/man-db-2.6.0.2-flock.h.patch
new file mode 100644
index 000000000000..6fbce45d1562
--- /dev/null
+++ b/sys-apps/man-db/files/man-db-2.6.0.2-flock.h.patch
@@ -0,0 +1,69 @@
+Bug #371937
+
+=== modified file 'NEWS'
+--- a/NEWS 2011-04-13 10:57:54 +0000
++++ a/NEWS 2011-06-16 11:22:10 +0000
+@@ -1,3 +1,13 @@
++man-db 2.6.1
++============
++
++Major changes since man-db 2.6.0.2:
++
++ Fixes:
++ ------
++
++ o --with-db=db* and --with-db=ndbm compile again.
++
+ man-db 2.6.0.2 (13 April 2011)
+ ==============================
+
+
+=== modified file 'libdb/db_btree.c'
+--- a/libdb/db_btree.c 2010-09-26 21:08:59 +0000
++++ a/libdb/db_btree.c 2011-06-16 11:22:10 +0000
+@@ -32,10 +32,7 @@
+ #include <errno.h>
+ #include <string.h>
+
+-#if HAVE_SYS_FILE_H
+-# include <sys/file.h> /* for flock() */
+-#endif
+-
++#include <sys/file.h> /* for flock() */
+ #include <sys/types.h> /* for open() */
+ #include <sys/stat.h>
+
+@@ -48,7 +45,6 @@
+ #include "manconfig.h"
+
+ #include "error.h"
+-#include "flock.h"
+ #include "hashtable.h"
+
+ #include "mydbm.h"
+
+=== modified file 'libdb/db_ndbm.c'
+--- a/libdb/db_ndbm.c 2008-12-03 10:57:14 +0000
++++ a/libdb/db_ndbm.c 2011-06-16 11:22:10 +0000
+@@ -29,10 +29,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+
+-#if HAVE_SYS_FILE_H
+-# include <sys/file.h> /* for flock() */
+-#endif
+-
++#include <sys/file.h> /* for flock() */
+ #include <sys/types.h> /* for open() */
+ #include <sys/stat.h>
+
+@@ -46,8 +43,6 @@
+
+ #include "manconfig.h"
+
+-#include "flock.h"
+-
+ #include "mydbm.h"
+ #include "db_storage.h"
+
+
diff --git a/sys-apps/man-db/man-db-2.6.0.2.ebuild b/sys-apps/man-db/man-db-2.6.0.2.ebuild
index 1a5d373d671b..d261c23af99f 100644
--- a/sys-apps/man-db/man-db-2.6.0.2.ebuild
+++ b/sys-apps/man-db/man-db-2.6.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.6.0.2.ebuild,v 1.3 2011/06/15 18:43:04 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.6.0.2.ebuild,v 1.4 2011/06/16 17:56:47 jer Exp $
EAPI="2"
@@ -33,6 +33,11 @@ pkg_setup() {
enewuser man 13 -1 /usr/share/man man
}
+src_prepare() {
+ # bug #371937
+ epatch "${FILESDIR}"/${PN}-2.6.0.2-flock.h.patch
+}
+
src_configure() {
local db="gdbm"
use berkdb && ! use gdbm && db="db"