summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-08-04 13:59:09 +0000
committerJeroen Roovers <jer@gentoo.org>2011-08-04 13:59:09 +0000
commit640d107c110e26ace6b5574cfe04ca466895e1b2 (patch)
treecf4e64e42960d2441a7edf83213df19b1a85b5bb /sys-apps/lsparisc
parentVersion bump (seems to fix bug #356041), use apache-mirror, added USE-flag to... (diff)
downloadgentoo-2-640d107c110e26ace6b5574cfe04ca466895e1b2.tar.gz
gentoo-2-640d107c110e26ace6b5574cfe04ca466895e1b2.tar.bz2
gentoo-2-640d107c110e26ace6b5574cfe04ca466895e1b2.zip
Move compiler/linker flags forward.
(Portage version: 2.2.0_alpha50/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sys-apps/lsparisc')
-rw-r--r--sys-apps/lsparisc/ChangeLog8
-rw-r--r--sys-apps/lsparisc/files/lsparisc-0.3-compile.patch2
-rw-r--r--sys-apps/lsparisc/lsparisc-0.3-r1.ebuild35
3 files changed, 43 insertions, 2 deletions
diff --git a/sys-apps/lsparisc/ChangeLog b/sys-apps/lsparisc/ChangeLog
index f02e09c3d1bc..6ff88b38c0dd 100644
--- a/sys-apps/lsparisc/ChangeLog
+++ b/sys-apps/lsparisc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/lsparisc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsparisc/ChangeLog,v 1.16 2011/08/04 13:25:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsparisc/ChangeLog,v 1.17 2011/08/04 13:59:08 jer Exp $
+
+*lsparisc-0.3-r1 (04 Aug 2011)
+
+ 04 Aug 2011; Jeroen Roovers <jer@gentoo.org> +lsparisc-0.3-r1.ebuild,
+ files/lsparisc-0.3-compile.patch:
+ Move compiler/linker flags forward.
04 Aug 2011; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Assign to HPPA herd.
diff --git a/sys-apps/lsparisc/files/lsparisc-0.3-compile.patch b/sys-apps/lsparisc/files/lsparisc-0.3-compile.patch
index 4306c9783056..04889983675e 100644
--- a/sys-apps/lsparisc/files/lsparisc-0.3-compile.patch
+++ b/sys-apps/lsparisc/files/lsparisc-0.3-compile.patch
@@ -9,7 +9,7 @@
${PROG}: ${OBJS}
- $(CC) -o ${PROG} ${OBJS} ${LIBS} ${CFLAGS}
-+ $(CC) -o ${PROG} ${OBJS} ${LIBS} $(CFLAGS) $(LDFLAGS)
++ $(CC) -o ${PROG} $(CFLAGS) $(LDFLAGS) ${OBJS} ${LIBS}
clean:
rm -f ${OBJS}
diff --git a/sys-apps/lsparisc/lsparisc-0.3-r1.ebuild b/sys-apps/lsparisc/lsparisc-0.3-r1.ebuild
new file mode 100644
index 000000000000..a4da47417c47
--- /dev/null
+++ b/sys-apps/lsparisc/lsparisc-0.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsparisc/lsparisc-0.3-r1.ebuild,v 1.1 2011/08/04 13:59:08 jer Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Like lspci but for PARISC devices"
+HOMEPAGE="http://packages.debian.org/unstable/utils/lsparisc"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* hppa"
+IUSE=""
+
+DEPEND="sys-fs/sysfsutils"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -e 's|"0.2"|"0.3"|g' -i lsparisc.c
+ epatch "${FILESDIR}"/${P}-compile.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ dobin lsparisc || die "Installing lsparisc executable failed."
+ doman lsparisc.8 || die "Installing lsparisc man page failed."
+ dodoc AUTHORS
+}