summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-29 01:42:49 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-29 01:42:49 +0000
commit03a1b4b9016f77b3fc7de9ff234171c3afceb6b3 (patch)
treeeab68a45163e447fc1b0a363369290404a845471 /sys-apps/logwatch/logwatch-6.0.2.ebuild
parentCleaning (diff)
downloadgentoo-2-03a1b4b9016f77b3fc7de9ff234171c3afceb6b3.tar.gz
gentoo-2-03a1b4b9016f77b3fc7de9ff234171c3afceb6b3.tar.bz2
gentoo-2-03a1b4b9016f77b3fc7de9ff234171c3afceb6b3.zip
Version bump and add a cron script #83641 by Meder Bakirov.
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'sys-apps/logwatch/logwatch-6.0.2.ebuild')
-rw-r--r--sys-apps/logwatch/logwatch-6.0.2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/logwatch/logwatch-6.0.2.ebuild b/sys-apps/logwatch/logwatch-6.0.2.ebuild
new file mode 100644
index 000000000000..8bd957aa7e0e
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-6.0.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/logwatch-6.0.2.ebuild,v 1.1 2005/04/29 01:42:48 vapier Exp $
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="http://www.logwatch.org/"
+SRC_URI="ftp://ftp.kaybee.org/pub/linux/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/cron
+ virtual/mta
+ dev-lang/perl
+ dev-perl/Tie-IxHash
+ dev-perl/Date-Calc
+ virtual/mailx"
+DEPEND=""
+
+src_install() {
+ dodir /etc/log.d/lib
+ dodir /etc/log.d/conf/logfiles
+ dodir /etc/log.d/conf/services
+ dodir /etc/log.d/scripts/services
+ dodir /etc/log.d/scripts/shared
+
+ newsbin scripts/logwatch.pl logwatch.pl
+
+ for i in scripts/logfiles/* ; do
+ exeinto /etc/log.d/$i
+ doexe $i/* || die "doexe $i failed"
+ done
+
+ exeinto /etc/log.d/lib
+ doexe lib/*.pm
+
+ exeinto /etc/log.d/scripts/services
+ doexe scripts/services/*
+
+ exeinto /etc/log.d/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /etc/log.d/conf
+ doins conf/logwatch.conf
+
+ insinto /etc/log.d/conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /etc/log.d/conf/services
+ doins conf/services/*
+
+ exeinto /etc/cron.daily
+ newexe ${FILESDIR}/logwatch.cron logwatch
+
+ doman logwatch.8
+ dodoc License project/CHANGES README HOWTO-Make-Filter
+}