summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-12-05 15:46:35 +0000
committerMike Frysinger <vapier@gentoo.org>2002-12-05 15:46:35 +0000
commit41d35d2885ce0d87a7de6462a26cd196e62a5878 (patch)
tree0285c40564596ff93dcd427eabf57b52f6aa0319 /sys-apps/linux-ntfs/linux-ntfs-1.6.0.ebuild
parentbetter DEPEND (diff)
downloadgentoo-2-41d35d2885ce0d87a7de6462a26cd196e62a5878.tar.gz
gentoo-2-41d35d2885ce0d87a7de6462a26cd196e62a5878.tar.bz2
gentoo-2-41d35d2885ce0d87a7de6462a26cd196e62a5878.zip
repoman
Diffstat (limited to 'sys-apps/linux-ntfs/linux-ntfs-1.6.0.ebuild')
-rw-r--r--sys-apps/linux-ntfs/linux-ntfs-1.6.0.ebuild26
1 files changed, 10 insertions, 16 deletions
diff --git a/sys-apps/linux-ntfs/linux-ntfs-1.6.0.ebuild b/sys-apps/linux-ntfs/linux-ntfs-1.6.0.ebuild
index be012517ec40..aa3e0db0b02d 100644
--- a/sys-apps/linux-ntfs/linux-ntfs-1.6.0.ebuild
+++ b/sys-apps/linux-ntfs/linux-ntfs-1.6.0.ebuild
@@ -1,44 +1,38 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/linux-ntfs/linux-ntfs-1.6.0.ebuild,v 1.1 2002/11/02 07:51:43 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/linux-ntfs/linux-ntfs-1.6.0.ebuild,v 1.2 2002/12/05 15:46:35 vapier Exp $
DESCRIPTION="Utilities and library for accessing NTFS filesystems"
HOMEPAGE="http://linux-ntfs.sourceforge.net/"
-
-S=${WORKDIR}/${P}
SRC_URI="mirror://sourceforge/${PN}/${PN}-${PV}.tar.gz"
-DEPEND=">=sys-devel/gcc-2.96"
+
+DEPEND=">=sys-devel/gcc-2.95"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86"
src_unpack() {
- unpack ${A} || die
+ unpack ${A}
cd ${S} || die
patch -p0 <${FILESDIR}/${P}-gcc3.2.patch || die
}
src_compile() {
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die
+ econf
emake || die
}
src_install() {
make DESTDIR=${D} install || die
- # a normal user cannot run ntfsfix
- cd ${D}
- mv usr/bin/ntfsfix usr/sbin
- rm -rf usr/bin
- cd ${S}
-
# lot's of docs (a good thing :)
dodoc CREDITS ChangeLog NEWS README TODO.include TODO.mkntfs TODO.ntfsfix \
doc/attribute_definitions doc/attributes.txt doc/compression.txt \
doc/system_files.txt doc/system_security_descriptors.txt \
doc/tunable_settings
+
+ # a normal user cannot run ntfsfix
+ cd ${D}
+ mv usr/bin/ntfsfix usr/sbin
+ rm -rf usr/bin
}