summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-07-17 12:30:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-07-17 12:30:36 +0000
commitf2ca5554ce0be69ba8c0993813cc409bed73db5f (patch)
tree6e1d0d666d17faf68a527273236fc181d22b0b45 /sys-apps/kmod
parentVersion bump (diff)
downloadgentoo-2-f2ca5554ce0be69ba8c0993813cc409bed73db5f.tar.gz
gentoo-2-f2ca5554ce0be69ba8c0993813cc409bed73db5f.tar.bz2
gentoo-2-f2ca5554ce0be69ba8c0993813cc409bed73db5f.zip
Another hardcoded path in the Linux source tree (depmod) wrt #426698 by Kyle McFarland
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/kmod')
-rw-r--r--sys-apps/kmod/ChangeLog8
-rw-r--r--sys-apps/kmod/kmod-9-r3.ebuild88
2 files changed, 95 insertions, 1 deletions
diff --git a/sys-apps/kmod/ChangeLog b/sys-apps/kmod/ChangeLog
index 364c85080ad8..5846e6eef102 100644
--- a/sys-apps/kmod/ChangeLog
+++ b/sys-apps/kmod/ChangeLog
@@ -1,5 +1,11 @@
# ChangeLog for sys-apps/kmod
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v 1.42 2012/07/13 16:27:28 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v 1.43 2012/07/17 12:30:36 ssuominen Exp $
+
+*kmod-9-r3 (17 Jul 2012)
+
+ 17 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +kmod-9-r3.ebuild:
+ Another hardcoded path in the Linux source tree (depmod) wrt #426698 by Kyle
+ McFarland
*kmod-9-r2 (13 Jul 2012)
diff --git a/sys-apps/kmod/kmod-9-r3.ebuild b/sys-apps/kmod/kmod-9-r3.ebuild
new file mode 100644
index 000000000000..90a420d33f67
--- /dev/null
+++ b/sys-apps/kmod/kmod-9-r3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-9-r3.ebuild,v 1.1 2012/07/17 12:30:36 ssuominen Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
+
+[[ ${PV} == 9999 ]] && vcs=git-2
+inherit ${vcs} autotools eutils toolchain-funcs libtool
+unset vcs
+
+if [[ ${PV} != 9999 ]] ; then
+ SRC_URI="mirror://kernel/linux/utils/kernel/kmod/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~x86"
+fi
+
+DESCRIPTION="library and tools for managing linux kernel modules"
+HOMEPAGE="http://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="debug doc lzma static-libs +tools zlib"
+
+RDEPEND="!sys-apps/module-init-tools
+ !sys-apps/modutils
+ lzma? ( app-arch/xz-utils )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ lzma? ( virtual/pkgconfig )
+ zlib? ( virtual/pkgconfig )"
+
+# Upstream does not support running the test suite with custom configure flags.
+# I was also told that the test suite is intended for kmod developers.
+# So we have to restrict it.
+# See bug #408915.
+RESTRICT="test"
+
+src_prepare()
+{
+ if [ ! -e configure ]; then
+ if use doc; then
+ gtkdocize --copy --docdir libkmod/docs || die
+ else
+ touch libkmod/docs/gtk-doc.make
+ fi
+ eautoreconf
+ else
+ elibtoolize
+ fi
+}
+
+src_configure()
+{
+ # http://bugs.gentoo.org/410865
+ if has_version '<sys-libs/zlib-1.2.6'; then
+ export zlib_CFLAGS="-I/usr/include"
+ export zlib_LIBS="-lz"
+ fi
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable tools) \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) \
+ $(use_with lzma xz) \
+ $(use_with zlib)
+}
+
+src_install()
+{
+ default
+
+ find "${D}" -name libkmod.la -exec rm -f {} +
+
+ if use tools; then
+ local cmd
+ for cmd in insmod lsmod modinfo rmmod; do
+ dosym kmod /usr/bin/${cmd}
+ done
+ # according to upstream, modprobe can be called directly by the kernel,
+ # so it cannot be moved to /usr/bin at this time.
+ dosym /usr/bin/kmod /sbin/modprobe
+ # another hardcoded path in the Linux source tree, bug #426698
+ dosym /usr/bin/kmod /sbin/depmod
+ fi
+}