summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-06-15 23:31:33 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-06-15 23:31:33 +0000
commitc67d586d1f8fb4ef78c45f619e3164fe8caddc08 (patch)
tree28fca477c7946e6204b71848c2cd1f8c07bf183d /sys-apps/ivman
parentRemove deprecated code. (diff)
downloadgentoo-2-c67d586d1f8fb4ef78c45f619e3164fe8caddc08.tar.gz
gentoo-2-c67d586d1f8fb4ef78c45f619e3164fe8caddc08.tar.bz2
gentoo-2-c67d586d1f8fb4ef78c45f619e3164fe8caddc08.zip
version bump thanks to Daniel Webert <rockoo@gmail.com> in bug 136293
(Portage version: 2.1)
Diffstat (limited to 'sys-apps/ivman')
-rw-r--r--sys-apps/ivman/ChangeLog5
-rw-r--r--sys-apps/ivman/files/digest-ivman-0.6.123
-rw-r--r--sys-apps/ivman/ivman-0.6.12.ebuild67
3 files changed, 74 insertions, 1 deletions
diff --git a/sys-apps/ivman/ChangeLog b/sys-apps/ivman/ChangeLog
index 7e4f8cbff35e..8021f737343f 100644
--- a/sys-apps/ivman/ChangeLog
+++ b/sys-apps/ivman/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/ivman
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ivman/ChangeLog,v 1.36 2006/06/15 18:06:33 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ivman/ChangeLog,v 1.37 2006/06/15 23:31:33 genstef Exp $
+
+ 15 Jun 2006; Stefan Schweizer <genstef@gentoo.org> ChangeLog:
+ version bump thanks to Daniel Webert <rockoo@gmail.com> in bug 136293
15 Jun 2006; Tobias Scherbaum <dertobi123@gentoo.org> ivman-0.6.11.ebuild:
ppc stable, bug #136292
diff --git a/sys-apps/ivman/files/digest-ivman-0.6.12 b/sys-apps/ivman/files/digest-ivman-0.6.12
new file mode 100644
index 000000000000..14507077d4d2
--- /dev/null
+++ b/sys-apps/ivman/files/digest-ivman-0.6.12
@@ -0,0 +1,3 @@
+MD5 031c763d6acc927bf2fefd7c6140247d ivman-0.6.12.tar.bz2 312274
+RMD160 5b1747b6b69452172c26e5c0e8fc27d0a7d9a067 ivman-0.6.12.tar.bz2 312274
+SHA256 1ee40db70a550bd8c42edeb7b6f0d2206ca6a2ce4c562093efd0e92705705628 ivman-0.6.12.tar.bz2 312274
diff --git a/sys-apps/ivman/ivman-0.6.12.ebuild b/sys-apps/ivman/ivman-0.6.12.ebuild
new file mode 100644
index 000000000000..dfe394833d83
--- /dev/null
+++ b/sys-apps/ivman/ivman-0.6.12.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ivman/ivman-0.6.12.ebuild,v 1.1 2006/06/15 23:31:33 genstef Exp $
+
+inherit eutils
+
+DESCRIPTION="Daemon to mount/unmount devices, based on info from HAL"
+HOMEPAGE="http://ivman.sf.net"
+SRC_URI="mirror://sourceforge/ivman/${P}.tar.bz2"
+LICENSE="GPL-2 QPL"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+SLOT="0"
+
+RDEPEND=">=dev-libs/glib-2.6
+ dev-libs/libxml2
+ sys-devel/gettext
+ >=sys-apps/hal-0.4.0
+ >=sys-apps/pmount-0.8"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.5
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf $(use_enable debug) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ exeinto /etc/init.d/
+ newexe ${FILESDIR}/ivman-0.3.init ivman
+}
+
+pkg_postinst() {
+ # Ivman can now run as a non-root user :-) Create a dedicated user account,
+ # so users can add rules to /etc/sudoers for programs Ivman wants to
+ # execute...
+ # The group here is intended to be the one needed to use pmount, but Ivman
+ # will still work as long as the group in IvmConfigBase.xml is correct.
+ enewuser ivman -1 -1 /dev/null plugdev || die "Problem adding ivman user"
+
+ if has_version "<sys-apps/hal-0.5.0"; then
+ einfo "Ivman was built against HAL 0.4.x. If you later upgrade to HAL 0.5,"
+ einfo "you must re-merge Ivman."
+ echo
+ else
+ einfo "Ivman was built against HAL 0.5.x. If you later downgrade to HAL 0.4,"
+ einfo "you must re-merge Ivman."
+ echo
+ fi
+
+ einfo "Note that, as of version 0.6.0, the IvmConfigMappings.xml configuration"
+ einfo "file is no longer required to correctly mount fstab entries which"
+ einfo "use symbolic links. You may safely remove this file if desired."
+ einfo "However, HAL typically does not correctly deal with fstab"
+ einfo "entries of this nature, therefore it is strongly recommanded that"
+ einfo "you have real device names (i.e. not symlinks) in /etc/fstab."
+ echo
+
+ einfo "By default, Ivman will mount any removable disks as they are"
+ einfo "attached. If you want Ivman to do more, such as hibernating"
+ einfo "your laptop when the lid is closed or when the battery is low,"
+ einfo "look at the configuration files in /etc/ivman/ ."
+}