summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-12-22 15:55:46 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-12-22 15:55:46 +0000
commit530e2854b839c3369b4ea828a17d227fbaa42f54 (patch)
tree7598502c7578b52db82f379fbf416850c01c6f23 /sys-apps/iptables
parentI've modified all functions to use the bash builtin variable $FUNCNAME when c... (diff)
downloadgentoo-2-530e2854b839c3369b4ea828a17d227fbaa42f54.tar.gz
gentoo-2-530e2854b839c3369b4ea828a17d227fbaa42f54.tar.bz2
gentoo-2-530e2854b839c3369b4ea828a17d227fbaa42f54.zip
iptables and libraries are moving from /usr/sbin and /usr/lib to /sbin and
/lib respectively. Reason? To bring us one step closer to the reality of having a NFS-mounted /usr. This way, the local machine can get their network interface (with optional NAT/firewalling) up and running without having /usr available.
Diffstat (limited to 'sys-apps/iptables')
-rw-r--r--sys-apps/iptables/files/digest-iptables-1.2.4-r11
-rw-r--r--sys-apps/iptables/iptables-1.2.4-r1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/iptables/files/digest-iptables-1.2.4-r1 b/sys-apps/iptables/files/digest-iptables-1.2.4-r1
new file mode 100644
index 000000000000..a0eea7a3a1ba
--- /dev/null
+++ b/sys-apps/iptables/files/digest-iptables-1.2.4-r1
@@ -0,0 +1 @@
+MD5 e78e5780bc61b9c3016b0ac312c7777f iptables-1.2.4.tar.bz2 225280
diff --git a/sys-apps/iptables/iptables-1.2.4-r1.ebuild b/sys-apps/iptables/iptables-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..93b4cceed6b1
--- /dev/null
+++ b/sys-apps/iptables/iptables-1.2.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iptables/iptables-1.2.4-r1.ebuild,v 1.1 2001/12/22 15:55:46 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Kernel 2.4 routing and traffic control utilities"
+SRC_URI="http://netfilter.samba.org/${P}.tar.bz2"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/g" -e "s:/usr/local:/usr:g" Makefile.orig > Makefile
+}
+
+src_compile() {
+ #I had a problem with emake - DR
+ make || die
+}
+
+src_install() {
+ dodir /usr/{lib,share/man/man8,sbin}
+ # iptables and libraries are now installed to /sbin and /lib. Why? So systems
+ # with remote network-mounted /usr filesystems can get their network interfaces
+ # up and running correctly without /usr.
+ make LIBDIR=${D}/lib \
+ BINDIR=${D}/sbin \
+ MANDIR=${D}/usr/share/man \
+ install || die
+ dodoc COPYING KNOWN_BUGS
+}