summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-07 15:55:15 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-07 15:55:15 +0000
commit36d7d63fc8e533a54bc3008fe078d25b06cc0d55 (patch)
treebbf6a3f305a5e307e2b8b191680365bd8b5a23b2 /sys-apps/gzip
parent*** empty log message *** (diff)
downloadgentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.tar.gz
gentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.tar.bz2
gentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.zip
Maintainence and FHS 2.1 fixes for RC4
Diffstat (limited to 'sys-apps/gzip')
-rw-r--r--sys-apps/gzip/gzip-1.2.4a-r2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-apps/gzip/gzip-1.2.4a-r2.ebuild b/sys-apps/gzip/gzip-1.2.4a-r2.ebuild
new file mode 100644
index 000000000000..1269271f6f87
--- /dev/null
+++ b/sys-apps/gzip/gzip-1.2.4a-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gzip/gzip-1.2.4a-r2.ebuild,v 1.1 2001/02/07 15:51:27 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU compressor"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gzip/${A}
+ ftp://prep.ai.mit.edu/gnu/gzip/${A}"
+HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ try ./configure --host=${CHOST} --prefix=/usr --exec-prefix=/ \
+ --mandir=/usr/share/man --infodir=/usr/share/info
+ try pmake
+}
+
+src_install() {
+
+ dodir /usr/bin /usr/share/man/man1
+ try make prefix=${D}/usr exec_prefix=${D}/ mandir=${D}/usr/share/man/man1 infodir=${D}/usr/share/info install
+
+ cd ${D}/bin
+ for i in gzexe zforce zgrep zmore znew zcmp
+ do
+ cp ${i} ${i}.orig
+ sed -e "1d" -e "s:${D}::" ${i}.orig > ${i}
+ rm ${i}.orig
+ chmod 755 ${i}
+ done
+
+ cd ${D}/usr/share/man/man1
+
+ for i in gzexe gzip zcat zcmp zdiff zforce \
+ zgrep zmore znew
+ do
+ rm ${i}.1
+ ln -s gunzip.1.gz ${i}.1.gz
+ done
+
+ cd ${S}
+ rm -rf ${D}/usr/man ${D}/usr/lib
+
+ dodoc ChangeLog COPYING NEWS README THANKS TODO
+ docinto txt
+ dodoc algorithm.doc gzip.doc
+}
+
+
+
+