summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-10-16 19:33:49 +0000
committerMike Frysinger <vapier@gentoo.org>2014-10-16 19:33:49 +0000
commit20e1cdeb07ad0cd8ba7f99c21789a9cc8ca92fe3 (patch)
tree9589e3d83c999aed6c296bcef22add8ae541705a /sys-apps/grep
parentAdd ruby21 support. (diff)
downloadgentoo-2-20e1cdeb07ad0cd8ba7f99c21789a9cc8ca92fe3.tar.gz
gentoo-2-20e1cdeb07ad0cd8ba7f99c21789a9cc8ca92fe3.tar.bz2
gentoo-2-20e1cdeb07ad0cd8ba7f99c21789a9cc8ca92fe3.zip
Force egrep/fgrep wrapper scripts to always use /bin/sh #523898 by Ruud Koolen.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-apps/grep')
-rw-r--r--sys-apps/grep/ChangeLog8
-rw-r--r--sys-apps/grep/grep-2.20-r1.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/sys-apps/grep/ChangeLog b/sys-apps/grep/ChangeLog
index 561cfe3e3033..d5feeac5bea5 100644
--- a/sys-apps/grep/ChangeLog
+++ b/sys-apps/grep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/grep
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.147 2014/06/04 05:16:30 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.148 2014/10/16 19:33:49 vapier Exp $
+
+*grep-2.20-r1 (16 Oct 2014)
+
+ 16 Oct 2014; Mike Frysinger <vapier@gentoo.org> +grep-2.20-r1.ebuild:
+ Force egrep/fgrep wrapper scripts to always use /bin/sh #523898 by Ruud
+ Koolen.
04 Jun 2014; Samuli Suominen <ssuominen@gentoo.org>
-files/grep-2.15-avoid_maintainer_mode.patch,
diff --git a/sys-apps/grep/grep-2.20-r1.ebuild b/sys-apps/grep/grep-2.20-r1.ebuild
new file mode 100644
index 000000000000..a6d5b7599937
--- /dev/null
+++ b/sys-apps/grep/grep-2.20-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.20-r1.ebuild,v 1.1 2014/10/16 19:33:49 vapier Exp $
+
+EAPI="4"
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="GNU regular expression matcher"
+HOMEPAGE="http://www.gnu.org/software/grep/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls pcre static"
+
+LIB_DEPEND="pcre? ( >=dev-libs/libpcre-7.8-r1[static-libs(+)] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ nls? ( virtual/libintl )
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ static? ( ${LIB_DEPEND} )"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+src_prepare() {
+ sed -i \
+ -e "s:@SHELL@:${EPREFIX}/bin/sh:g" \
+ src/egrep.sh || die #523898
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ # Always use pkg-config to get lib info for pcre.
+ export ac_cv_search_pcre_compile=$(
+ usex pcre "$($(tc-getPKG_CONFIG) --libs $(usex static --static '') libpcre)" ''
+ )
+ econf \
+ --bindir="${EPREFIX}"/bin \
+ $(use_enable nls) \
+ $(use_enable pcre perl-regexp)
+}