summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-02-20 05:49:33 +0000
committerMike Gilbert <floppym@gentoo.org>2014-02-20 05:49:33 +0000
commit55b689363561f981f0721db9bca32f64dd70449d (patch)
tree77bdcd3efd5de044821a8493510a7d3d4ec4f69a /sys-apps/gentoo-systemd-integration
parentMask aura for chromium-34 (build failures). (diff)
downloadgentoo-2-55b689363561f981f0721db9bca32f64dd70449d.tar.gz
gentoo-2-55b689363561f981f0721db9bca32f64dd70449d.tar.bz2
gentoo-2-55b689363561f981f0721db9bca32f64dd70449d.zip
Bump to fix race in make install.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-apps/gentoo-systemd-integration')
-rw-r--r--sys-apps/gentoo-systemd-integration/ChangeLog8
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-4.ebuild28
2 files changed, 35 insertions, 1 deletions
diff --git a/sys-apps/gentoo-systemd-integration/ChangeLog b/sys-apps/gentoo-systemd-integration/ChangeLog
index 1effc3f0efbb..0faa39478e07 100644
--- a/sys-apps/gentoo-systemd-integration/ChangeLog
+++ b/sys-apps/gentoo-systemd-integration/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/gentoo-systemd-integration
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/ChangeLog,v 1.21 2014/02/19 15:05:08 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/ChangeLog,v 1.22 2014/02/20 05:49:33 floppym Exp $
+
+*gentoo-systemd-integration-4 (20 Feb 2014)
+
+ 20 Feb 2014; Mike Gilbert <floppym@gentoo.org>
+ +gentoo-systemd-integration-4.ebuild:
+ Bump to fix race in make install.
*gentoo-systemd-integration-3 (19 Feb 2014)
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-4.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-4.ebuild
new file mode 100644
index 000000000000..31a883c0aa37
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-4.ebuild,v 1.1 2014/02/20 05:49:33 floppym Exp $
+
+EAPI=5
+
+inherit autotools-utils systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://bitbucket.org/mgorny/gentoo-systemd-integration"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207"
+
+src_configure() {
+ local myeconfargs=(
+ "$(systemd_with_unitdir)"
+ # TODO: solve it better in the eclass
+ --with-systemdsystemgeneratordir="$(systemd_get_utildir)"/system-generators
+ )
+
+ autotools-utils_src_configure
+}