summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-05-05 23:49:45 +0000
committerMike Frysinger <vapier@gentoo.org>2013-05-05 23:49:45 +0000
commit2ab427be13718a480f86d9bcb206be8090792fb6 (patch)
tree8292408f03746ed8ebbfcbc3079402a158e39533 /sys-apps/findutils
parentFix building with automake-1.13 #467642 by thomas. (diff)
downloadgentoo-2-2ab427be13718a480f86d9bcb206be8090792fb6.tar.gz
gentoo-2-2ab427be13718a480f86d9bcb206be8090792fb6.tar.bz2
gentoo-2-2ab427be13718a480f86d9bcb206be8090792fb6.zip
Version bump #468654 by Agostino Sarubbo.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-apps/findutils')
-rw-r--r--sys-apps/findutils/ChangeLog7
-rw-r--r--sys-apps/findutils/findutils-4.5.11.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/sys-apps/findutils/ChangeLog b/sys-apps/findutils/ChangeLog
index c878ff8ce32a..2210af7f82a3 100644
--- a/sys-apps/findutils/ChangeLog
+++ b/sys-apps/findutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/findutils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.211 2013/02/19 02:58:40 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.212 2013/05/05 23:49:45 vapier Exp $
+
+*findutils-4.5.11 (05 May 2013)
+
+ 05 May 2013; Mike Frysinger <vapier@gentoo.org> +findutils-4.5.11.ebuild:
+ Version bump #468654 by Agostino Sarubbo.
19 Feb 2013; Zac Medico <zmedico@gentoo.org> findutils-4.5.10-r1.ebuild:
Add ~arm-linux keyword.
diff --git a/sys-apps/findutils/findutils-4.5.11.ebuild b/sys-apps/findutils/findutils-4.5.11.ebuild
new file mode 100644
index 000000000000..04a0cac35ca8
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.5.11.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.5.11.ebuild,v 1.1 2013/05/05 23:49:45 vapier Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="http://www.gnu.org/software/findutils/"
+SRC_URI="mirror://gnu-alpha/${PN}/${P}.tar.gz"
+# mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ # Don't build or install locate because it conflicts with slocate,
+ # which is a secure version of locate. See bug 18729
+ sed -i '/^SUBDIRS/s/locate//' Makefile.in
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ local myconf
+ use userland_GNU || myconf=" --program-prefix=g"
+
+ econf \
+ --with-packager="Gentoo" \
+ --with-packager-version="${PVR}" \
+ --with-packager-bug-reports="http://bugs.gentoo.org/" \
+ $(use_enable nls) \
+ --libexecdir='$(libdir)'/find \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS README TODO ChangeLog
+
+ # We don't need this, so punt it.
+ rm "${D}"/usr/bin/oldfind "${D}"/usr/share/man/man1/oldfind.1 || die
+}