summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-07 20:41:09 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-07 20:41:09 +0000
commit965bac62bf1597696c928e7535d0218673b5e587 (patch)
treece66af9c5efc1dcc2caec79c986da35e97c07218 /sys-apps/file
parentRemove safestrigi patch, since it breaks tags in dolphin, bug 362513 (diff)
downloadgentoo-2-965bac62bf1597696c928e7535d0218673b5e587.tar.gz
gentoo-2-965bac62bf1597696c928e7535d0218673b5e587.tar.bz2
gentoo-2-965bac62bf1597696c928e7535d0218673b5e587.zip
Fix deprecation warnings (bug #362345).
(Portage version: 2.2.0_alpha29_p10/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/ChangeLog6
-rw-r--r--sys-apps/file/file-5.04.ebuild17
-rw-r--r--sys-apps/file/file-5.05.ebuild13
3 files changed, 21 insertions, 15 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index 7d9358bd9d07..7a69da903429 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/file
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.194 2011/04/04 16:47:00 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.195 2011/04/07 20:41:09 arfrever Exp $
+
+ 07 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ file-5.04.ebuild, file-5.05.ebuild:
+ Fix deprecation warnings (bug #362345).
04 Apr 2011; Samuli Suominen <ssuominen@gentoo.org> file-5.05.ebuild:
USE="static-libs" and punt libtool archive if it's not set.
diff --git a/sys-apps/file/file-5.04.ebuild b/sys-apps/file/file-5.04.ebuild
index a33c3a7fe2a3..c5b1adc47735 100644
--- a/sys-apps/file/file-5.04.ebuild
+++ b/sys-apps/file/file-5.04.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.04.ebuild,v 1.9 2010/11/28 17:19:18 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.04.ebuild,v 1.10 2011/04/07 20:41:09 arfrever Exp $
+EAPI="2"
PYTHON_DEPEND="python? 2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
@@ -18,10 +19,7 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE="python"
-src_unpack() {
- unpack ${P}.tar.gz
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${PN}-4.15-libtool.patch #99593
elibtoolize
@@ -33,11 +31,14 @@ src_unpack() {
mv python/README{,.python}
}
-src_compile() {
+src_configure() {
# file uses things like strndup() and wcwidth()
append-flags -D_GNU_SOURCE
- econf || die
+ econf
+}
+
+src_compile() {
emake || die
use python && cd python && distutils_src_compile
diff --git a/sys-apps/file/file-5.05.ebuild b/sys-apps/file/file-5.05.ebuild
index 53916a9a57ab..9d59bb9f0cf5 100644
--- a/sys-apps/file/file-5.05.ebuild
+++ b/sys-apps/file/file-5.05.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.05.ebuild,v 1.9 2011/04/04 16:47:00 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.05.ebuild,v 1.10 2011/04/07 20:41:09 arfrever Exp $
+EAPI="2"
PYTHON_DEPEND="python? *"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="*-jython"
@@ -20,10 +21,7 @@ IUSE="python static-libs"
PYTHON_MODNAME="magic.py"
-src_unpack() {
- unpack ${P}.tar.gz
- cd "${S}"
-
+src_prepare() {
elibtoolize
epunt_cxx
@@ -31,11 +29,14 @@ src_unpack() {
mv python/README{,.python}
}
-src_compile() {
+src_configure() {
# file uses things like strndup() and wcwidth()
append-flags -D_GNU_SOURCE
econf $(use_enable static-libs static)
+}
+
+src_compile() {
emake || die
use python && cd python && distutils_src_compile